|Skip Navigation Links|
|Exit Print View|
|man pages section 9: DDI and DKI Properties and Data Structures|
- options structure for M_SETOPTS message
#include <sys/stream.h> #include <sys/stropts.h> #include <sys/ddi.h> #include <sys/sunddi.h>
Architecture independent level 1 (DDI/DKI)
The M_SETOPTS message contains a stroptions structure and is used to control options in the stream head.
uint_t so_flags; /* options to set */ short so_readopt; /* read option */ ushort_t so_wroff; /* write offset */ ssize_t so_minpsz; /* minimum read packet size */ ssize_t so_maxpsz; /* maximum read packet size */ size_t so_hiwat; /* read queue high water mark */ size_t so_lowat; /* read queue low water mark */ unsigned char so_band; /* band for water marks */ ushort_t so_erropt; /* error option */
The following are the flags that can be set in the so_flags bit mask in the stroptions structure. Note that multiple flags can be set.
Set read option.
Set write offset.
Set minimum packet size
Set maximum packet size.
Set high water mark.
Set low water mark.
Set read notification ON.
Set read notification OFF.
Old TTY semantics for NDELAY reads and writes.
Semantics for NDELAY reads and writes.
The stream is acting as a terminal.
The stream is not acting as a terminal.
Stop on background writes to this stream.
Do not stop on background writes to this stream.
Water marks affect band.
Set error option.
When SO_READOPT is set, the so_readopt field of the stroptions structure can take one of the following values. See read(2).
Read message normal.
Read message discard.
Read message, no discard.
When SO_BAND is set, so_band determines to which band so_hiwat and so_lowat apply.
When SO_ERROPT is set, the so_erropt field of the stroptions structure can take a value that is either none or one of:
Persistent read errors; default.
Non-persistent read errors.
OR'ed with either none or one of:
Persistent write errors; default.
Non-persistent write errors.