- trusted network daemon
/usr/sbin/tnd [-p poll-interval]
The tnd (trusted network daemon) initializes the kernel with trusted network databases and also reloads the databases on demand from an LDAP server and local files. tnd follows the order specified in the nsswitch.conf(4) file when loading configuration databases. tnd is started at the beginning of the boot process.
tnd loads two databases into the kernel: the remote host database, tnrhdb(4) and the remote-host template database, tnrhtp(4). These databases and their effect on the trusted network are described in their respective man pages. When the associated LDAP database or local databases are changed, tnd also updates the local kernel cache at the predetermined interval.
If a local trusted networking database file is modified, the administrator should run tnchkdb(1M) to check the syntax, and should also run svcadm refresh svc:/network/tnd to initiate an immediate database scan by tnd.
tnd is intended to be started from an smf(5) script and to run in the global zone. The following signals cause specific svcadm actions:
Causes svcadm refresh svc:/network/tnd to be run.
Initiates a rescan of the local and LDAP tnrhdb and tnrhtp databases. tnd updates the kernel database with any changes found.
Causes svcadm disable svc:/network/tnd to be run.
Terminates the tnd daemon. No changes are made to the kernel database.
Set poll interval to poll-interval seconds. The default poll-interval is 1800 seconds (30 minutes).
Example 1 Changing the Poll Interval
The following command changes the polling interval to one hour, and puts this interval in the SMF repository. At the next boot, the tnd poll interval will be one hour.
# svccfg -s network/tnd setprop tnd/poll_interval=3600
The following command changes the polling interval, but does not update the repository. At the next boot, the tnd poll interval remains the default, 30 minutes.
# tnd -p 3600
See attributes(5) for descriptions of the following attributes:
Trusted network remote-host database
Trusted network remote-host templates
Trusted zone configuration database
Configuration file for the name service switch
How to Synchronize the Kernel Cache With Trusted Network Databases in Solaris Trusted Extensions Administrator’s Procedures
The tnd service is managed by the service management facility, smf(5), under the service identifier:
svcadm restart svc:/network/tnd