Sun Cluster 3.1 10/03 Data Services Developer's Guide

Navigating Agent Builder

Navigating Agent Builder is simple and intuitive. Agent Builder is a two-step wizard with a corresponding screen for each step (Create and Configure screens). You enter information in each screen by:

The buttons at the bottom of each screen enable you to complete the task, move to the next or previous screen, or exit Agent Builder. Agent Builder highlights or grays out these buttons as appropriate.

For example, when you have filled in the fields and checked the desired options on the Create screen, click the Create button at the bottom of the screen. The Previous and Next buttons are grayed out because no previous screen exists and you cannot go to the next step before you complete this one.

Buttons at bottom of panel that show previous, create, next, and cancel buttons

Agent Builder displays progress messages in the output log area at the bottom of the screen. When Agent Builder finishes, it displays a success message, or a warning to look at the output log. The Next button is highlighted, or if this is the last screen, only the Cancel button is highlighted.

You can select Cancel at any time to exit Agent Builder.

Browse Button

Particular Agent Builder fields enable you to type information or to click the Browse button to browse your directory structure and select a file or directory. Browse button at bottom of panel

When you click Browse, a screen similar to the following screen appears: Browse screen that shows a list of files

Double click on a folder to open it. When you highlight a file, its name appears in the File name box. Click Select when you have located and highlighted the appropriate file.

Note –

If you are browsing for a directory, highlight it and select the Open button. If there are no subdirectories, Agent Builder closes the browse window and places the name of the directory you highlighted in the appropriate field. If this directory has subdirectories, click the close button to close the browse window and return to the previous screen. Agent Builder places the name of the directory you highlighted in the appropriate field.

The icons in the upper right corner of the screen do the following:

Icon that shows up arrow


This icon moves you up one level in the directory tree. 

Icon that shows home


This icon returns you to the home folder. 

Icon that shows a new folder


This icon creates a new folder under the currently selected folder. 

Icon that you use to change views


This icon, for toggling between different views, is reserved for future use. 


Agent Builder provides File and Edit menus.

File Menu

The File men has two commands:

Edit Menu

The Edit menu has commands to clear and save the output log: