The arp program displays and modifies the Internet-to-Ethernet address translation tables used by the address resolution protocol (see arp(7P)).
With no flags, the program displays the current ARP entry for hostname. The host may be specified by name or by number, using Internet dot notation.
Publish; includes IP address for the machine and the addresses that have explicitly been added by the -s option. ARP will respond to ARP requests for this address.
Static; not learned for the ARP protocol.
Unresolved; waiting for ARP response.
Mapping; only used for the multicast entry for '220.127.116.11'.
Delete an entry for the host called hostname. To succeed, the process must inherit the
Read the file named filename and set multiple entries in the ARP tables. See option -s for argument definitions. To succeed, the process must inherit the
sys_net_config privilege. Entries in the file should be of the form:
hostname ether_address [ temp ] [ pub ] [ trail ]
Create an ARP entry for the host called hostname with the Ethernet address ether_address. The Ethernet address is given
as six hexadecimal bytes separated by colons. The entry will be permanent unless the word temp is given in the command. If the word pub is given, the entry will be published. For instance, this system will respond to ARP requests for hostname even though the hostname is not its own. The word trail indicates that trailer encapsulations may be sent to this host. arp -s can be used for a limited form of proxy ARP when a host on one of
the directly attached networks is not physically present on the subnet. Another machine can then be configured to respond to ARP requests using arp -s. This is useful in certain SLIP
or PPP configurations. To succeed, the process must inherit the
See attributes(5) for descriptions of the following attributes:
|ATTRIBUTE TYPE||ATTRIBUTE VALUE|
To run, options -d, -f, and -s need to inherit the