The reboot utility restarts the kernel. The kernel is loaded into memory by the PROM monitor, which transfers control to the loaded kernel.
Although reboot can be run by an administrative role with appropriate privilege and authorization at any time, shutdown(1M) is normally used first to warn all users logged in of the impending loss of service.
The reboot utility normally logs the reboot to the system log daemon, syslogd(1M), and places a shutdown record in the login accounting file /var/adm/wtmpx. These actions are inhibited if the -n or -q options are present.
Normally, the system will reboot itself at power-up or after crashes.
Force a system crash dump before rebooting. See dumpadm(1M) for information on configuring system crash dumps.
Suppress sending a message to the system log daemon, syslogd(1M) about who executed reboot.
Avoid the sync(1M) operation. Use of this option can cause file system damage.
Quick. Reboot quickly and ungracefully, without shutting down running processes first.
These arguments are accepted for compatibility, and are passed unchanged to the uadmin(2) system call.
In the example below, the delimiter `--' (two hyphens) must be used to separate the options of reboot from the arguments of boot(1M).
example# reboot -dl -- -rv
See attributes(5) for descriptions of the following attributes:
|ATTRIBUTE TYPE||ATTRIBUTE VALUE|
reboot requires the
sys_boot privilege in order to run. Shutting down a computer