rpc.nisd_resolv is an auxiliary process which provides DNS forwarding service for NIS hosts requests to both ypserv and rpc.nisd that are running in the NIS compatibility mode. It is generally started by invoking rpc.nisd(1M) with the -B option or ypserv(1M) with the -d option. Although it is not recommended, rpc.nisd_resolv can also be started independently with the following options.
This command is not supported in the Trusted Solaris environment because ypserv and other NIS(YP) compatibility is unsupported.
Run in foreground.
Use fd for service xprt (from nisd).
Verbose. Send output to the syslog daemon.
Verbose. Send output to stdout.
Use transport xx.
Use transient program# yy.
This command is not supported in the Trusted Solaris environment.
See attributes(5) for descriptions of the following attributes:
|ATTRIBUTE TYPE||ATTRIBUTE VALUE|
This command requires that the /etc/resolv.conf file be setup for communication with a DNS nameserver. The nslookup utility can be used to verify communication with a DNS nameserver. See resolv.conf(4) and nslookup(1M).