statd is an intermediate version of the status monitor. It interacts with lockd(1M) to provide the crash and recovery functions for the locking services on NFS. statd keeps track of the clients with processes which hold locks on a server. When the server reboots after a crash, statd sends a message to the statd on each client indicating that the server has rebooted. The client statd processes then inform the lockd on the client that the server has rebooted. The client lockd then attempts to reclaim the lock(s) from the server.
statd on the client host also informs the statd on the server(s) holding locks for the client when the client has rebooted. In this case, the statd on the server informs its lockd that all locks held by the rebooting client should be released, allowing other processes to lock those files.
Lists hosts and network addresses to be contacted after a reboot.
Lists hosts and network addresses that could not be contacted after last reboot.
Includes a number which changes during a reboot.
Contains the rpcgen source code for the interface services provided by the statd daemon.
See attributes(5) for descriptions of the following attributes:
statd must be started with a UID of 0, a sensitivity label of
ADMIN_LOW, and a clearance of
ADMIN_HIGH. It must be started from the Trusted Path
and must have these privileges:
statd creates the directory /var/statmon/sm and all its files, the directory /var/statmon/sm.bak and all its files, and the file /var/statmon/state at the sensitivity label
ADMIN_LOW. The directories /var/statmon/sm and /var/statmon/sm.bak are created with the mode 700.
The crash of a server is only detected upon its recovery.