The tnd (trusted network daemon) initializes the kernel with trusted network databases and also reloads the databases on demand. tnd also services requests for tnrhdb(4) templates from tninfo(1M) and the kernel. tnd is started at the beginning of the boot process.
tnd loads these databases into the kernel: the remote host database, tnrhdb(4); the remote-host template database, tnrhtp(4); and the interface database, tnidb(4). These databases and their effect on the trusted network are described in their respective man pages. When tnrhdb(4) and tnrhtp(4) and the associated NIS+ tables are changed, tnd also updates the local kernel cache at the predetermined interval.
tnd logs its debugging information in a log file (by default, /var/tsol/tndlog) which is set by using the -f option.
If a local trusted networking database file is modified, the administrator should issue a tnchkdb(1M) to check the syntax, and must issue a tnctl to reload the kernel caches.
tnd must be started from the Trusted Path and inherit these privileges to run:
proc_setsl. tnd is intended to be started from an rc script and to run at the
See attributes(5) for descriptions of the following attributes:
|ATTRIBUTE TYPE||ATTRIBUTE VALUE|
Turn on debugging to the level specified by debug_level. debug_level may be 1 or 2; however, currently no distinction is made between the two values. If log file is not specified with the -f option, use /var/tsol/tndlog.
Set logfile path to logfile for writing debugging information. If logfile already exists, append debugging information to it.
Set poll interval to poll-interval seconds. The default poll-interval is 1800 seconds (30 minutes). The inetsvc script uses this flag to set the poll-interval to 120 seconds.
Disable polling of name services when starting up. This option is used when tnd is started in an rc script and it is not intended for use when tnd is started otherwise.
Trusted network interface-control database
Trusted network remote-host database
Trusted network remote-host templates
Log of tnd debugging information
Configuration file for the name service switch