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THIS PRODUCT CONTAINS CERTAIN COMPUTER PROGRAMS AND OTHER PROPRIETARY MATERIAL, THE USE OF WHICH IS SUBJECT TO 
THIS END-USER LICENSE AGREEMENT (THE "AGREEMENT").  DO NOT PROCEED WITH THE INSTALLATION OF THIS PRODUCT UNTIL YOU 
(LATER DEFINED AS LICENSEE) HAVE READ THIS AGREEMENT AND AGREE TO BE BOUND BY AND BECOME A PARTY TO THIS 
AGREEMENT.  BY PROCEEDING WITH THE INSTALLATION OF THIS PRODUCT (OR AUTHORIZING ANY OTHER PERSON TO DO SO), YOU 
AND YOUR COMPANY ACCEPT THIS AGREEMENT.  IF YOU DO NOT AGREE TO THE TERMS OF THIS AGREEMENT, YOU MAY EXIT THE 
INSTALLATION PROCESS AND RETURN THIS PRODUCT, ALL MEDIA AND DOCUMENTATION, AND PROOF OF PAYMENT, TO THE PLACE 
YOU OBTAINED THEM FOR A FULL REFUND WITHIN TEN (10) DAYS OF FIRST ACQUIRING THIS PRODUCT.  WRITTEN APPROVAL IS NOT A 
PREREQUISITE TO THE VALIDITY OR ENFORCEABILITY OF THIS AGREEMENT AND NO SOLICITATION OF ANY SUCH WRITTEN APPROVAL 
BY OR ON BEHALF OF LEGATO SHALL BE CONSTRUED AS AN INFERENCE TO THE CONTRARY.  IF YOU HAVE ORDERED THIS PRODUCT, 
LEGATO’S ACCEPTANCE IS EXPRESSLY CONDITIONAL ON YOUR ASSENT TO THESE TERMS TO THE EXCLUSION OF ALL OTHER TERMS; IF 
THESE TERMS ARE CONSIDERED AN OFFER BY LEGATO, ACCEPTANCE IS EXPRESSLY LIMITED TO THESE TERMS.

1. DEFINITIONS

1.1 Authorization Code:  means the code provided to Licensee by Legato 
for permanent authorization to use the Software.  The Authorization Code 
is provided to Licensee once the Enabler Code is registered with Legato.

1.2 Documentation:  means any user reference materials on any media, 
provided by Legato for use with the Software.

1.3 Enabler Code:  means the code provided by Legato for activation of the 
Software.

1.4 Licensee:  means the person or entity acquiring this License or for 
whom this License was acquired.

1.5 Software means the object code copy of the software program provided 
to You in association with this Agreement, together with the associated 
original electronic media and all accompanying manuals and other 
documentation, and together with all enhancements, upgrades, and 
extensions thereto that may be provided by Legato to You from time to 
time.

2. OWNERSHIP AND ADMINISTRATION OF SOFTWARE 

2.1 Ownership and Title.  As between the parties, Legato, and its licensors, 
own and shall retain all right, title, and interest in and to:  (i) the Software 
including all intellectual property rights embodied therein; (ii) all of the 
service marks, trademarks, trade names, or any other designations 
associated with the Software; and (iii) all copyrights, patent rights, trade 
secret rights, and other proprietary rights relating to the Software.  
Licensee further acknowledges and agrees that it shall have no rights with 
respect to any of the foregoing rights other than the rights expressly set 
forth in this Agreement.

2.2 Software Activation.  Legato employs Enabler Codes and 
Authorization Codes that enable the use of the Software.   The Software is 
shipped in a "Media Kit" which consists of object code software on 
CD-ROM and an Enabler Code for initial activation of the Software or the 
Software and Enabler Code may be delivered electronically.  Once Legato 
receives confirmation from Licensee that the Enabler Code is installed and 
is provided with the host ID information, Legato will provide the 
Authorization Code to Licensee.  Legato administers the generation and 
distribution of Enabler and Authorization Codes, which administration 
may be modified by Legato from time to time.

2.3 Administration of Software.  Legato may include on the media with the 
Software additional computer programs which are not currently licensed 
for use by Licensee and to which the Enabler Code or Authorization code 
will not permit access.  Inclusion of such additional computer programs in 
no way implies a license from Legato and access or use of such programs 
is strictly prohibited unless Licensee procures the right to use any such 
program and the applicable Enabler Code is provided thereto.

3. LICENSE GRANT

3.1 Grant.  Legato grants to Licensee a non-exclusive, nontransferable, 
non-sublicensable, perpetual, unless terminated in accordance with the 
provisions of this Agreement, license (the "License") to (i) use the Software 
installed in accordance with the Documentation and only on the licensed 
computer solely for its own internal operations; and (ii) move the Software 
temporarily in case of computer system malfunction. The License granted 
under this Agreement does not constitute a sale of the Software or any 
portion or copy of it. Licensee may not use the Software on more than one 
computer system unless otherwise specifically authorized by an explicit 
Software product, or additional licenses for additional computers are 
purchased. Rights not expressly granted are reserved by Legato. Where 
the Software is provided to Licensee at no charge for evaluation purposes 
only, the License granted is limited to a continuous thirty (30) day period, 
commencing with the acceptance of this Agreement (the "Evaluation 
Period"). At the conclusion of the Evaluation Period, Licensee agrees to 
destroy the Software and certify its destruction to Legato, in writing, 
within ten (10) days, or shall return the Software to Legato or purchase a 
perpetual license.

3.2 Copies. Licensee may make copies of the Software provided that any 
such copy is:  (i) created as an essential step in utilization of the Software 
on the licensed computer and is used in no other manner; or (ii) used for 
archival purposes to back-up the licensed computers.  All trademark and 
copyright notices must be reproduced and included on such copies.  
Licensee may not make any other copies of the Software.

3.3 Restrictions on use.  Licensee shall not, and shall not aid, abet, or permit 
any third party to:  (i) decompile, disassemble, or otherwise reverse 
engineer or attempt to reconstruct or discover any source code or 
underlying ideas or algorithms of the Software by any means whatsoever; 
(ii) remove any identification, copyright, or other notices from the 
Software; (iii) provide, lease, lend, use for timesharing or service bureau 
purposes, or otherwise use or allow others to use the Software or any 
portion thereof to or for the benefit of third parties; (iv) create a derivative 
work of any part of the Software; or (v) develop methods to enable 
unauthorized parties to use the Software.  If EC law is applicable, the 
restrictions in Section 3.3 (i) are limited so that they prohibit such activity 
only to the maximum extent such activity may be prohibited without 
violating the EC Directive on the legal protection of computer programs.  
Notwithstanding the foregoing, prior to decompiling, disassembling, or 
otherwise reverse engineering any of the Software, Licensee shall request 
Legato in writing, to provide Licensee with such information or assistance 
and Licensee shall refrain from decompiling, disassembling, or otherwise 
reverse engineering any of the Software unless Legato cannot or has not 
complied with such request in a commercially reasonable amount of time.

3.4 Purchase Orders.  Nothing contained in any purchase order, 
acknowledgment, or invoice shall in any way modify the terms or add any 
additional terms or conditions to this Agreement.

3.5 Updates.  This section applies if the Software acquired is an update to 
the original Software ( the "Update").  An Update does not constitute a 
legally licensed copy of the Software unless purchased as an Update to a 
previous version of the same Software.  The Update may only be used in 
accordance with the provisions of this Agreement.  The Update, together 
with the original Software, constitute one (1) legally licensed copy of the 
Software.

3.6 Evaluation License.  This Section applies if the Software is being used 
for an initial thirty (30) day evaluation period.  The license is valid only for 
a period of thirty (30) days from the delivery of the Software, and is 
designed to allow Licensee the right to evaluate the Software during such 
period.  In the event that Licensee desires to enter into a longer-term 
license agreement with Legato, Licensee shall obtain an appropriate 
Enabler and Authorization Code in accordance with Section 2.2 above, 
upon payment of applicable fees, which authorizes use of the Software 
after such evaluation period, but only subject to all of the terms and 
conditions of this Agreement.  In the event Licensee determines not to 
enter into a licensing transaction with Legato at the end of such thirty (30) 
day evaluation period, then Licensee’s rights under this Agreement shall 
terminate automatically and Licensee shall promptly return to Legato or 
destroy all copies of the Software and so certify to Legato.

4. MAINTENANCE AND SUPPORT

4.1 Legato has no obligation to provide support, maintenance, upgrades, 
modifications, or new releases under this Agreement.  Legato may provide 
such services under separate agreement.

5. LIMITED WARRANTY

5.1 Media and Documentation.  Legato warrants that if the media or 
documentation are damaged or physically defective at the time of delivery 
of the first copy of the Software to Licensee and if defective or damaged 
product is returned to Legato (postage prepaid) within thirty (30) days  
thereafter, then Legato will provide Licensee with replacements at no cost.

5.2 Software.  Subject to the conditions and limitations of liability stated 
herein, Legato warrants for a period of thirty (30) days from the delivery 
of the first copy of the Software to Licensee that the Software, as delivered, 
will materially conform to Legato’s then current published 
Documentation for the Software.  This warranty covers only problems 
reported to Legato during the warranty period.



5.3 Remedies.  The remedies available to Licensee hereunder for any such 
Software which does not perform as set out herein shall be either repair or 
replacement, or, if such remedy is not practicable in Legato’s opinion, 
refund of the license fees paid by Licensee upon a return of all copies of the 
Software to Legato.   In the event of a refund this Agreement shall 
terminate immediately without notice.

6. TERM AND TERMINATION

6.1 Term.  The term of this Agreement is perpetual unless terminated in 
accordance with its provisions.

6.2 Termination.  Legato may terminate this Agreement, without notice, 
upon Licensee’s breach of any of the provisions hereof.

6.3 Effect of Termination.  Upon termination of this Agreement, Licensee 
agrees to cease all use of the Software and to return to Legato or destroy 
the Software and all Documentation and related materials in Licensee’s 
possession, and so certify to Legato.  Except for the License granted herein 
and as expressly provided herein, the terms of this Agreement shall 
survive termination.

7. DISCLAIMER AND LIMITATIONS

7.1 Warranty Disclaimer.  EXCEPT FOR THE LIMITED WARRANTY 
PROVIDED IN SECTION 5 ABOVE, LEGATO MAKES NO 
WARRANTIES WITH RESPECT TO ANY SOFTWARE AND DISCLAIMS 
ALL STATUTORY OR IMPLIED WARRANTIES, INCLUDING 
WITHOUT LIMITATION WARRANTIES OF MERCHANTABILITY, 
FITNESS FOR A PARTICULAR PURPOSE, OR ARISING FROM A 
COURSE OF DEALING OR USAGE OF TRADE AND ANY 
WARRANTIES OF NONINFRINGEMENT.  ALL SOFTWARE IS 
PROVIDED "AS IS" AND LEGATO DOES NOT WARRANT THAT THE 
SOFTWARE WILL MEET ANY REQUIREMENTS OR THAT THE 
OPERATION OF SOFTWARE WILL BE UNINTERRUPTED OR ERROR 
FREE.  ANY LIABILITY OF LEGATO WITH RESPECT TO THE 
SOFTWARE OR THE PERFORMANCE THEREOF UNDER ANY 
WARRANTY, NEGLIGENCE, STRICT LIABILITY OR OTHER THEORY 
WILL BE LIMITED EXCLUSIVELY TO THE REMEDIES SPECIFIED IN 
SECTION 5.3 ABOVE.  Some jurisdictions do not allow the exclusion of 
implied warranties or limitations on how long an implied warranty may 
last, so the above limitations may not be applicable.  This warranty 
provides specific legal rights.  Other rights vary from state to state.  
Licensee acknowledges and agrees that Legato is not responsible for and 
will have no liability for hardware, software, or other items or services 
provided by persons other than Legato.

8. LIMITATION OF LIABILITY

8.1 Limitation of Liability.  NOTWITHSTANDING ANYTHING ELSE IN 
THIS AGREEMENT OR OTHERWISE, AND EXCEPT FOR BODILY 
INJURY, LEGATO WILL IN NO EVENT BE LIABLE OR RESPONSIBLE 
FOR OR OBLIGATED WITH RESPECT TO THE SUBJECT MATTER OF 
THIS AGREEMENT UNDER ANY CONTRACT, NEGLIGENCE, STRICT 
LIABILITY, OR OTHER LEGAL CONTRACTUAL OR EQUITABLE 
THEORY FOR:  (I) ANY INDIRECT,  SPECIAL, INCIDENTAL OR 
CONSEQUENTIAL DAMAGES, HOWEVER CAUSED AND WHETHER 
OR NOT ADVISED IN ADVANCE OF THE POSSIBILITY OF SUCH 
DAMAGES; OR (II) DAMAGES FOR LOST PROFITS OR LOST DATA; OR 
(III) COST OF PROCUREMENT OF SUBSTITUTE GOODS, 
TECHNOLOGY, SERVICES, OR RIGHTS; OR (IV) FOR ANY MATTER 
BEYOND ITS REASONABLE CONTROL.  NOTWITHSTANDING 
ANYTHING IN THIS AGREEMENT TO THE CONTRARY OR THE 
FAILURE OF ESSENTIAL PURPOSE OF ANY LIMITATION OF 
LIABILITY OR LIMITED REMEDY, LEGATO’S ENTIRE AGGREGATE 
LIABILITY ARISING FROM OR RELATING TO THIS AGREEMENT OR 
THE SUBJECT MATTER HEREOF, UNDER ANY LEGAL THEORY 
(WHETHER IN CONTRACT, TORT, INDEMNITY OR OTHERWISE) 
SHALL BE LIMITED TO THE AMOUNTS RECEIVED BY LEGATO FOR 
THE SOFTWARE DURING THE SIX (6) MONTH PERIOD PRIOR TO 
THE DATE THE CLAIM AROSE FOR THE PARTICULAR LEGATO 
SOFTWARE THAT CAUSED THE LIABILITY.

9. MISCELLANEOUS

9.1  Governing Law.  This Agreement shall be governed by the laws of the 
State of California, as applied to agreements entered into and to be 
performed entirely within California between California residents, 
without regard to the principles of conflict of laws or the United Nations 
Convention on Contracts for the International Sale of Goods.

9.2 Government Restricted Rights.  This provision applies to Software 
acquired directly or indirectly by or on behalf of any government.  The 
Software is a commercial software product, licensed on the open market at 
market prices, and was developed entirely at private expense and without 
the use of any government funds.  Any use, modification, reproduction, 
release, performance, display, or disclosure of the Software by any 
government shall be governed solely by the terms of this Agreement and 
shall be prohibited except to the extent expressly permitted by the terms of 
this Agreement, and no license to the Software is granted to any 
government requiring different terms.

9.3 U.S. Government Users.  As defined in FAR section 2.101, DFAR section 
252.227-7014(a)(1), DFAR section 252.227-7014(a)(5), or otherwise, all 
software and accompanying documentation provided in connection with 
this Agreement are "commercial items," "commercial computer software" 
and/or "commercial computer software documentation."  Consistent with 
DFAR section 227.7202 and FAR section 12.212, any use, modification, 
reproduction, release, performance, display, disclosure, or distribution 
thereof by or for the U.S. Government shall be governed solely by the 
terms of this Agreement and shall be prohibited except to the extent 
expressly permitted by the terms of this Agreement.  Licensee will ensure 
that each copy used or possessed by or for the government is labeled to 
reflect the foregoing.

9.4 Export and Import Controls.  Regardless of any disclosure made by 
Licensee to Legato of an ultimate destination of the Products, Licensee will 
not directly or indirectly export or transfer any portion of the Software, or 
any system containing a portion of the Software, to anyone outside the 
United States (including further export if Licensee took delivery outside 
the U.S.) without first complying with any export or import controls that 
may be imposed on the Software by the U.S. Government or any country 
or organization of nations within whose jurisdiction Licensee operates or 
does business.  Licensee shall at all times strictly comply with all such 
laws, regulations, and orders, and agrees to commit no act which, directly 
or indirectly, would violate any such law, regulation or order.

9.5 Assignment.  This Agreement may not be assigned or transferred by 
Licensee without the prior written consent of Legato which shall not be 
unreasonably withheld.  Legato may assign or otherwise transfer any or all 
of its rights and obligations under this Agreement upon notice to Licensee.

9.6 Sole Remedy and Allocation of Risk.  Licensee’s sole and exclusive 
remedy is set forth in this Agreement.  This Agreement defines a mutually 
agreed-upon allocation of risk, and the License price reflects such 
allocation of risk.

9.7 Equitable Relief.  The parties agree that a breach of this Agreement 
adversely affecting Legato’s intellectual property rights in the Software 
may cause irreparable injury to Legato for which monetary damages may 
not be an adequate remedy and Legato shall be entitled to equitable relief 
in addition to any remedies it may have hereunder or at law.

9.8 No Waiver.  Failure by either party to enforce any provision of this 
Agreement will not be deemed a waiver of future enforcement of that or 
any other provision, nor will any single or partial exercise of any right or 
power hereunder preclude further exercise of any other right hereunder.

9.9 Severability.  If for any reason a court of competent jurisdiction finds 
any provision of this Agreement, or portion thereof, to be unenforceable, 
that provision of the Agreement will be enforced to the maximum extent 
permissible so as to effect the intent of the parties, and the remainder of 
this Agreement will continue in full force and effect.

10. ENTIRE AGREEMENT

10.1 This Agreement sets forth the entire understanding and agreement 
between the parties and may be amended only in a writing signed by 
authorized representatives of both parties.  No vendor, distributor, dealer, 
retailer, sales person, or other person is authorized by Legato to modify 
this Agreement or to make any warranty, representation, or promise which 
is different than, or in addition to, the warranties,  representations, or 
promises made in this Agreement.
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Preface

This guide provides information on how to configure and manage the Legato 
NetWorker® software to maximize backup and recovery performance. It 
includes tips and instructions for testing and modifying the NetWorker server 
settings to ensure the most efficient configuration for your environment.

NetWorker software must be installed on the server and clients to use the 
information presented here. For installation instructions, refer to the Legato 
NetWorker Installation Guide.

Audience
The information in this guide is intended for system administrators who are 
responsible for installing software and maintaining the servers and clients on 
a network. Operators who monitor the daily backups may also find this 
manual useful. Users of this guide should already be familiar with basic 
NetWorker processes and services.

Product Documentation
Legato offers an extensive archive of product documentation at its web site 
www.legato.com. Most of the documents are in Adobe Acrobat Portable 
Document Format (PDF), and can be viewed by downloading and installing 
the Adobe Acrobat Reader. The Reader is available in the /viewers/acroread 
directory on the Legato Documentation Suite CD-ROM, or directly from 
Adobe at www.adobe.com. To install and use the Reader on the preferred 
platform, refer to the instructions in the CD-ROMs /viewers/acroread/readme.txt 
file or at the Adobe web site.
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Conventions
This document uses the following typographic conventions and symbols to 
make information easier to access and understand.

Convention Indicates Example

boldface Names of line commands, 
daemons, options, 
programs, or scripts

The nsradmin command starts the 
command line version of the administration 
program.

italic in text Pathnames, filenames, 
computer names, new terms 
defined in the Glossary or 
within the chapter, or 
emphasized words

Displayed messages are also written to 
/nsr/logs/daemon.log.

italic in command 
line

A variable that must be 
provided in the command 
line

nwadmin -s server-name

fixed-width Examples and information 
displayed on the screen

media waiting: recover waiting for 
8mm 5GB tape volume name

fixed-width, 
boldface

Commands and options that 
must be typed exactly as 
shown

nsr_shutdown -a

Menu_Name>
Command

A path or an order to follow 
for making selections in the 
GUI

Volume>Change Mode>Appendable

Important: Information that must be 
read and followed to ensure 
successful backup and 
recovery of data

Important: Use the no_verify option with 
extreme caution.
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Information and Services
Legato offers a variety of methods, including electronic, telephone, and fax 
support to obtain company, product, and technical information.

General Information

The Legato web site provides most of the information that customers might 
need. Technical bulletins and binary patches are also accessible on the Legato 
FTP site. For specific sales or training needs, e-mail or call Legato.

Technical Support

The Support section of the Legato web site provides contact information, 
software patches, technical documentation, and information about available 
support programs.

• Customers with an active support agreement have access to Legato’s 
integrated product knowledge base. Help with Legato software issues is 
also available through Legato Technical Support.

• Customers without an active support agreement can contact Support 
Sales and Renewal to purchase annual Software Update Subscriptions, or 
Legato Technical Support services for per-update/per-incident support.

Legato Service or 
Resource

Technical 
Bulletins

Binary 
Patches

Company & 
Product 
Information

Training 
Programs

www.legato.com Yes Yes Yes Yes

ftp.legato.com
(log in as anonymous)

Yes Yes

Legato Sales
(650) 210-7000 (option 1)
sales@legato.com

Yes

Legato Education Services
(650) 842-9357
training@legato.com

Yes
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Licensing and Registration

To license and register Legato products, go to the Legato licensing web site. To 
change contact information, transfer licenses, or ask questions about licensing, 
contact Legato using one of the following methods.

Customer Feedback
Legato welcomes comments and suggestions about software features, the 
installation procedure, and documentation. Please send any suggestions and 
comments to feedback@legato.com. Legato confirms receipt of all e-mail 
correspondence. Although Legato cannot respond personally to every request, 
all comments and suggestions are considered during product design.

Help improve Legato documentation by completing a brief survey. Visit the 
Legato web site at www.legato.com, navigate to the documentation page, and 
click on the link to the survey.

Licensing and Registration Contact

Legato licensing web site http://license.legato.com

Telephone number (650) 812 6000 (option 3, option 2)a

+31 23 554 8881b

a. Contact information for Americas, Asia, and Pacific.
b. Contact information for Europe, Middle East, and Africa.

Fax number (650) 745-1477a

+31 23 554 8808b

E-mail licensing@legato.coma

licensingemea@legato.comb
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Chapter 1: NetWorker Features

The NetWorker product is a network storage management application that is 
optimized for high-speed backup and recovery operations on large amounts 
of complex data across an entire network of computers. The NetWorker 
software is available in four editions. Brief descriptions and distinctions 
between these editions are covered in this chapter, as well as an overview of 
hardware and software performance, in the following sections:

• "Introduction to NetWorker Editions" on page 15
• "Overview of Hardware and Software Performance" on page 17

Introduction to NetWorker Editions
The four editions of the NetWorker software are as follows: 

• Workgroup Edition 
The Workgroup Edition supports small networks that do not require 
clustering or contain large databases and/or filesystems. The Workgroup 
Edition comes with a limited number of client connections, but can easily 
be upgraded to the Network Edition as needed.

• Business Edition
The Business Edition is similar to the Workgroup Edition in that it is 
designed for small business needs. It includes eight client connections and 
support for a 2-drive/1-26 slot autochanger.

• Network Edition 
The Network Edition supports large, distributed networks and a full 
range of add-on products.
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• Power Edition 
The Power Edition addresses the storage management and data protection 
needs of enterprises that have high-performance database servers and 
fileservers, such as very large database (VLDB) applications, online 
transaction processing (OLTP) applications, data warehouses, and web 
servers.

Table 1 on page 16 lists the preconfigured support features for each of the 
NetWorker editions.

In addition to the preconfigured features for each of the NetWorker editions, 
several optional features are also supported. Table 2 on page 16 lists these 
options.

Table 1. Preconfigured Support Features of NetWorker Editions

Features
Workgroup 
Edition

Business 
Edition

Network 
Edition

Power 
Edition

Number of Client 
Connections

8 8 10 10

Number of Simultaneous 
Parallel Data Streams

12 12 32 + 32 per 
storage node

64 + 32 per 
storage node

Number of Devices 4 4 16 per server 
and/or storage 
node

32 per server 
and/or 
storage node

Cluster Support Not supported Client Client Server/Client

Table 2. Supported Options of NetWorker Editions

Options 
Workgroup 
Edition

Business 
Edition

Network 
Edition

Power 
Edition

ClientPak® Yes Yes Yes Yes

Additional Client 
Connections

No No Yes Yes

Library Sharing No No Yes Yes

Dynamic Drive Sharing No No Yes Yes
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Overview of Hardware and Software Performance
Performance is the speed and efficiency with which a task is completed. 
Backup and recovery performance is dependent on several hardware and 
software variables, but in general, backups can go no faster than the speed of 
their slowest component.

This guide provides tests you can use to measure and maximize the various 
components of your computer. By identifying the slowest component in the 
data path between the location of the data and the storage device, you can 
change software settings or replace a hardware component to improve 
performance. 

• Factors that affect the speed of the server include the following: 
– CPU
– Memory 
– Input/output (I/O) bandwidth
– SCSI bandwidth
– Number of ports

• Factors that affect the speed of the devices include the following: 
– I/O transfer rate
– Built-in compression and initialization characteristics
Note: Device speed is combined for all storage devices used concurrently.

If clients are backed up over a network, the following factors can also affect 
performance:

• Client speed 
– CPU
– Memory 
– Disk speed
Note: Client speed is combined for all clients active at a single point in 
time.

• Network speed 
– Network I/O bandwidth
– Network path
– Network load
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Factors impacting software performance include:

• Filesystem management
• Application-specific optimization 
• Backup application (for example, the NetWorker software) 
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Chapter 2: NetWorker Configuration

This chapter briefly describes the features and configurations available with 
the NetWorker software, including details on how the NetWorker product 
performs backups and recoveries, in the following sections:

• "NetWorker Software Services and Programs" on page 19
• "NetWorker Configurations" on page 25

NetWorker Software Services and Programs
This section provides an overview of how the NetWorker products perform 
backup and recovery operations.

All NetWorker servers consist of services and programs that do the following:

• Coordinate the tasks associated with a backup and recovery.
• Record information about what was backed up.
• Track the media that contains the backed-up data.
• Manage storage management client configurations, client file indexes, 

and the media database.

The NetWorker client software includes a client service and user interface 
programs. The services and programs in NetWorker products communicate by 
using the RPC protocol. 

Services and Programs on the NetWorker Server

This section describes the NetWorker master service, as well as other services 
and programs that reside on the NetWorker server. These services and 
programs contact the client for a backup and maintain the client file indexes 
and media database on the server. 
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The nsrd Service

The NetWorker master service, nsrd, provides an RPC-based save and recover 
program function to NetWorker clients, including:

• Starts other services.
• Allocates media services on server computers.
• Authorizes backup and recovery services for the client.
• Contacts clients for scheduled backups.
• Maintains NetWorker configuration information.
• Monitors backup and recovery sessions.
• Maintains server statistics and message logs.

Other Services and Programs

Table 3 on page 20 lists the other services and programs that reside on the 
server. 

Table 3. Services and Programs on the Server

Service or
Program Function

ansrd This service monitors an active save or recover program session. This is an 
agent process spawned by nsrd in response to a save or recover session.

nsrck This service checks the consistency of the client file index. It is invoked by 
nsrd whenever the consistency of the client file index needs to be confirmed.

nsrim This service automatically manages the server media database. This service is 
invoked by nsrmmdbd when it starts up, at the end of the savegrp program, 
and by nsrd when a user removes the oldest backup cycle.

nsrindexd This service provides a method for inserting entries into the client file index 
based on information passed by the save program.

nsrmmd This service provides device support, generates mount requests, and 
multiplexes save set data during a multi-client backup. The nsrd service can 
start several nsrmmd services, up to twice the number of devices specified in 
the server.

nsrmmdbd This service provides media database management services to the local nsrd 
and nsrmmd services and records entries in the media database. This is the 
media management database service.

savegrp This program runs a group of NetWorker clients through the save process.
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Services and Programs on the NetWorker Client

The nsrd service calls upon the NetWorker client service, nsrexecd, and 
several programs on the client when a scheduled or on-demand backup 
request is received. A temporary server agent, the ansrd service, starts on the 
NetWorker server to monitor the progress of the backup session. 

Table 4 on page 21 describes the services and programs on the NetWorker 
client.

How the NetWorker Software Backs Up Data

When you configure a backup group on the NetWorker server, you schedule a 
start time for the backup group. The nsrd service starts the savegrp program 
on the server for the backup group at the scheduled time.

The savegrp Program

The savegrp program queries the Client resources configured on the 
NetWorker server to determine the following:

• Which clients configured on the server are members of the scheduled 
group.

• What level of backup (save) to perform.

Table 4. Services and Programs on the Client

Service or
Program Function

nsrexecd This service authenticates the NetWorker server remote execution request 
and executes the save and savefs commands on the client.

recover This program browses the NetWorker server client file index and restores the 
specified file to primary disk storage.

save This program sends specified files in a multiplexed data stream to the 
NetWorker server for backup to media by nsrmmd and entry in the client file 
indexes by nsrindexd and the media database by nsrmmdbd. A level-based 
system is used to save only those files which have been modified since some 
previous save (a partial save).

savefs This program gathers all the necessary information, such as filesystem and 
level, and sends it to savegrp. savegrp then requests that the save program 
sends the data to the NetWorker server.
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• How many save sets to run concurrently, determined by the parallelism 
value set on the NetWorker server.

• When the most recent backup of the group occurred.

If any of this information is not available on the NetWorker server, the savegrp 
program sends a request (sometimes called a probe) to the nsrexecd client 
service to run savefs on each client assigned to the backup group to gather the 
necessary details.

The savefs program tells savegrp which objects to back up for the client. After 
savegrp receives information about the objects to back up, savegrp assembles 
a work list for the server. The work list specifies the order in which clients are 
contacted for backup. The order of the work list is determined by the Client 
Priority attribute in the Client resource. The client with the lowest value in the 
Client Priority attribute is contacted first.

If problems were encountered with the client file index during the previous 
backup session, nsrd invokes the nsrck service to check the consistency and 
state of the NetWorker server client file indexes. Then, nsrd starts the 
nsrindexd client file index insertion service.

The savegrp program contacts the first client on the server work list. The 
nsrexecd of the client is invoked and starts a save session of the first save set 
listed on the server work list. The save program passes all save criteria to nsrd, 
such as group, client, save sets, and level of the save data. With this 
information, nsrd determines the pool of volumes that will store the data and 
forwards the information to the appropriate media service on the NetWorker 
server.

The nsrmmd Service

The media service, nsrmmd, performs the following:

• Sends a message to the NetWorker server console, requesting a mount of 
the media assigned to the volume pool indicated by nsrd.

• Writes the data sent by save to storage media.
• Forwards storage information to nsrmmdbd for recording in the 

NetWorker server media database.

Any time there is a lull in save set activity from the client, the NetWorker 
server attempts to find another save set in the group to keep the process 
moving. The savegrp program attempts to concurrently back up as many save 
sets as possible, up to the limit set by the Parallelism attribute in the 
NetWorker server configuration. This way, backup devices are utilized to their 
maximum potential. 
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The savegrp program repeats the process for each item on the server work list 
until all clients in the group are backed up. Before the savegrp program 
finishes, if the NetWorker server is part of the group being backed up or the 
server is not part of any enabled group, the NetWorker server bootstrap file is 
backed up. 

If you have set up the bootstrap notification and installed and configured 
TCP/IP print services, a bootstrap printout is sent to the default printer 
configured for the NetWorker server after the bootstrap backup finishes. 

Note: Keep the bootstrap printout in a safe place in case you need to restore 
the NetWorker server.

The final results of the savegrp execution are as follows:

• On Windows NT and Windows 2000 systems, results are returned to the 
server and appended to the \nsr\logs\savegrp.log file. 

• On UNIX and Linux systems, results are appended to the 
/nsr/logs/savegrp.log file.

Figure 1 on page 24 shows how all of the NetWorker client and server services 
and programs interact during a scheduled save.
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Figure 1. NetWorker Services and Programs During a Scheduled Backup

How the NetWorker Server Recovers Data

When the NetWorker server receives a recover request from a client, the nsrd 
master service of the server contacts the nsrmmd media service on the server. 
The nsrmmd service contacts the nsrmmdbd media database service of the 
server to determine which media contain the save set requested by the recover 
program. After nsrmmd finds the save set on the media, nsrmmd issues a 
mount request, the media is positioned to the beginning of the save set, and the 
save set stored on the mounted media is passed to nsrmmd. The media service 
forwards the save set to the recover program of the client, which restores the 
data to the client’s filesystem.
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Client Save Sets Client
File Index

save nsrindexd nsrmmdbd
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Figure 2 on page 25 shows how the NetWorker server and client services and 
programs interact while recovering data to a NetWorker client.

Figure 2. Processes and Programs During a Recover Session

NetWorker Configurations
This section describes various NetWorker configurations. Immediate save and 
recovery is a special feature available in all NetWorker editions of the 
NetWorker software (release 6.0 and later). The text and figures provided here 
illustrate various setups, including:

• "Immediate Save and Recovery" on page 26
• "Local Backup and Recovery of a Client" on page 26
• "Backup and Recovery of Remote Client" on page 27
• "Backup and Recovery to a Storage Node" on page 28
• "Local Backup to a Silo" on page 28
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Immediate Save and Recovery

During a backup session on a NetWorker server or storage node, the 
NetWorker software distinguishes whether the data resides on the same or 
remote computer. 

• When the data resides on the same computer, immediate saves and 
immediate recoveriess are invoked automatically. Instead of transferring 
data across the network, local data is transferred within memory on the 
NetWorker server or storage node. 

• When the data resides on a remote client, the data is transferred over the 
network by using TCP/IP.

Performance for remote backup is improved through RPC enhancements. The 
examples in the following sections illustrate when immediate save can, and 
cannot, be invoked.

Local Backup and Recovery of a Client

When one computer includes either both the client and server software, or the 
storage node software, and they have storage devices attached, the data is 
backed up through immediate save. Figure 3 on page 26 shows an example of 
a local backup of a NetWorker server. The NetWorker software can back up 
data of any type supported by a NetWorker client, including a range of 
databases. 

Figure 3. Local Backup and Recovery

Processes and data that travel through a protocol stack in a standard setup are 
passed in memory on the same computer. With immediate save, the network 
transmission blockage is eliminated. The same is true for recovery operations. 

NetWorker Server Storage Device

SCSI Connection

NetWorker Client

NetWorker Module Client
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If a database is offline, that database can take advantage of immediate save for 
local backup with a NetWorker client. Some NetWorker Module clients can 
also take advantage of immediate save for online database backups. To 
determine whether immediate save for online backup is supported, refer to the 
documentation that accompanied the NetWorker Module software.

Backup and Recovery of Remote Client 

Figure 4 on page 27 shows an example of the NetWorker server installed on a 
computer other than the one where the data resides. 

Figure 4. Remote Backup and Recovery

Because the NetWorker client and the fileserver data reside on a remote 
computer, the data is transferred across the network during backup.

For a recovery, the process is reversed. When the NetWorker client on the 
fileserver computer makes a recovery request, the data is again transferred 
across the network.

Backup and recovery performance over the network is enhanced because of 
Remote Procedure Call (RPC) protocol enhancements. They prevent slower 
clients from slowing down the backup of faster clients. Data that resides on the 
NetWorker server is automatically backed up through immediate save (or 
automatically recovered by using immediate recover).

If the data is backed up to a high-speed device, performance is improved. The 
device can transfer data in less time and write it in larger blocks. 

Fileserver Storage DeviceNetWorker Server

TCP/IP 
Connection

SCSI 
Connection
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Backup and Recovery to a Storage Node

Figure 5 on page 28 shows an example of a NetWorker server that uses a 
storage node for backup and recovery operations. This feature is only available 
with the Power Edition or Network Edition of the NetWorker software. 

Data hosted on each NetWorker storage node is backed up and recovered by 
using immediate save and immediate recover technology. The metadata 
associated with backups is transferred over the network to the controlling 
NetWorker server, and the data is transferred directly to devices attached to 
the storage node. 

NetWorker storage nodes enable you to design scalable configurations.

• Multiple devices can be attached to multiple storage nodes.
• Data transfer operations can run concurrently.

Figure 5. Backup and Recovery with a NetWorker Storage Node

Local Backup to a Silo

When you add a silo to the local backup scenario, performance may improve 
because of the speed and number of devices in the silo. The silo requires 
another computer to be the silo server, which controls the robotics in the silo. 
The silo server cannot be the same computer as the NetWorker server. 

In Figure 6 on page 29, a silo and its silo server are used in the NetWorker local 
backup and recovery configuration. 

NetWorker Server Storage DeviceStorage Node

TCP/IP Connection SCSI Connection

 NetWorker Client  Storage Node 
NetWorker Client
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Figure 6. Local Backup to a Silo

During Backup

During backup, save is invoked to transfer data from the NetWorker client 
processes to the NetWorker server processes in the memory of the NetWorker 
server computer. If the data is written to a device in a silo, the nsrmmd service 
initiates a Silo Tape Library Interface (STLI) call to the silo server, for example, 
to mount a tape. 

The STLI call is transferred across the network connection to the silo server, 
then over a SCSI connection to the device in the silo. The data is transferred 
over a SCSI connection from the NetWorker server to the device.

During Recovery

During a recovery, the process is similar to a backup. Media handling 
information is transferred across the network connection from the NetWorker 
server to the silo. The silo mounts the tapes, and then the data is transferred 
over the SCSI connection to the NetWorker server computer, where the data is 
transferred in memory to the NetWorker client process.

For more information about silos and how they interact with the NetWorker 
software, refer to the Legato NetWorker Administrator’s Guide.
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Chapter 3: Testing and Tuning Basics

Improving the performance of data storage management is more an art than a 
science. If the data storage management process is operating poorly or not at 
all, the cause can be traced to a single problem. If the storage management 
environment seems generally OK, but is not reaching the performance levels 
you want, you might need to investigate and tune multiple elements in the 
environment.

This chapter identifies the different hardware and software components that 
make up the data storage management environment, discusses their impact on 
storage management tasks, and provides general guidelines for locating 
problems and solutions in the following sections:

• "Overview of Performance Testing and Tuning" on page 32
• "Server Hardware" on page 33
• "NetWorker Settings" on page 41
• "Backup Devices" on page 44
• "File Type Device and Staging" on page 49
• "Network Hardware" on page 51

The last two chapters of this guide address specific performance tests and 
fixes, particularly those that pertain to the specific operating system on which 
you are using the NetWorker software.
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Overview of Performance Testing and Tuning
The benchmark tests used in the computer industry are done in controlled 
environments, to simplify analysis and show products at their greatest 
advantage. When you test the performance of the NetWorker server in your 
environment, you must decide the degree to which the test is controlled. 

• To run a fully-controlled test, turn off all extraneous processes to isolate the 
performance of the NetWorker server. The results of this type of test show 
you the optimal performance of the NetWorker server with the current 
hardware and software configuration.

• To run a less-controlled test, do not shut down other applications and 
network traffic. The results of this type of test show you how the 
NetWorker server performs while the computer is running other 
programs and processes. 

If you run both a controlled test and one with a normal or simulated load, the 
difference between the results can help you determine the following:

• How to schedule the backups.
• Whether to run other programs on the NetWorker server.

The tests in this and the following chapters follow a basic process: 

1. Measure the current performance of the NetWorker server.

2. View the results to find a blockage or limiting factor.

3. Adjust the hardware and software to correct the blockage.

4. Measure the performance of the NetWorker server.

Although there will always be some blockage in a system, you can use this 
process to eliminate the greatest obstacles to fast backup performance.

Note: You must have sufficient computer and network hardware installed to 
support a storage application. Failure to meet minimum system requirements, 
particularly for memory, free space, and CPU speed, can have an obvious and 
immediate negative impact on the storage management processes.
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Server Hardware
The following sections address different hardware components of the 
NetWorker server, as well as tests on the performance of these components.

Physical Disks

The physical disks in a computer system are in constant motion, reading and 
writing data for storage and recovery and maintaining the client file indexes 
and media database. Problems with these disks can negatively affect every 
level of performance within a storage management environment.

The type of data you back up and how it is laid out on the disk can cause 
backup performance to vary. If you have large files that are fragmented, or if 
you have many small files, the efficiency of the disk suffers because the disk 
head has to move frequently from one fragment or file to another. The backup 
process is most efficient for large files with minimal fragmentation.

If the data is compressed on the disk, the operating system or application has 
to decompress the data before transferring it for backup. The CPU spends 
cycles to decompress the files, and the disk can rarely go at its maximum 
speed.

Disk Read Speed Testing Methods

Follow these guidelines to determine the read speed of disks:

• Test the read speed of each individual disk, while NetWorker software is 
not running.

• Test the read speed of all disks, while the NetWorker software is not 
running.

• Test the read speed of each individual disk, while NetWorker software is 
running.

• Test the read speed of all disks, while NetWorker software is running.

You can use the NetWorker uasm program, which saves and recovers 
filesystem data, to test how fast the system can read from disk.

The syntax is as follows:

uasm -s [-benouv] [-ix] [-t time] [-f proto] [-p ppath] path

uasm -r [-nuv] [-i {nNyYrR}] [-m src = dst] [-z suffix] path

uasm -c [-nv] path
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For example, enter the following command at the system prompt:

uasm -s filename > /dev/null

where filename is a fairly large file that has not been accessed recently. If the file 
was recently accessed, it may still be in memory and uasm would not actually 
read the file from disk.

The uasm program reads from the disk at the maximum speed. In this 
example, the data is written to a null location so the disk read is not slowed 
down to allow time for writing. 

The uasm program has three modes: save, recover, and compare. For a 
description of how the uasm program performs in the three modes, see Table 
5 on page 34. 

In save mode, uasm can be controlled by directive files. Directive files control 
the following:

• How descendent directories are searched.
• Which files are ignored.
• How the save stream is generated.
• How to process subsequent directive files.

Table 5. uasm Program Modes

In this mode: The uasm program performs the following:

save Scans directory trees and generates a save stream 
on its standard output (stdout) representing the 
files and organization of the directory tree. 
Symbolic links are never followed by application 
specific modules (ASMs), except rawasm, which 
enables NetWorker to process data in raw disk 
partitions.

recover Reads a save stream from its standard input 
(stdin) and creates the corresponding directories 
and files.

compare Reads a save stream from its stdin and compares 
the save stream with the files already on the 
filesystem.
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All ASMs accept the options described in Table 6 on page 35. ASMs can also 
have additional options. The additional options for a particular ASM are in 
capital letters.

Note: Either -s (save), -r (recover) or -c (compare) mode must be specified 
when using the uasm program and must precede any other options. When 
saving, at least one path value must be specified. The path value can be either 
a directory or a filename.

Options Valid for All Modes of uasm

Table 6 on page 35 lists the options that are valid with all modes of uasm.

Table 6. uasm Options

Option Usage

-n Use the -n option to perform a dry run. 

When saving, scan the filesystem but do not attempt to open files 
and produce the save stream.

When recovering or comparing, consume the input save stream 
and do basic checks, but do not create directories or files when 
recovering or do the work of comparing the file data.

-v Use the -v option to turn on verbose mode. The current ASM, its 
specified options, and the file it is processing are displayed. 
When an ASM is operating in filtering mode (that is, processing 
the save stream of another ASM) and modifies the stream, its 
name, specified options, and the current file appear within 
square brackets.
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Options for Save Mode

Table 7 on page 36 lists the options that can be used in save mode.

Table 7. Save Mode Options (Part 1 of 2)

To
Use this 
option

Produce a byte count. This is similar to the -n option, but byte 
count estimates the amount of data to be produced, instead of 
actually reading file data. This option is faster but less 
accurate than the -n option. Byte count mode produces three 
numbers: the number of records (files and directories), the 
number of bytes of header information, and the approximate 
number of bytes of file data. Byte count mode does not 
produce a save stream, so its output cannot be used as input to 
another ASM in recover mode.

-b

Produce an "old style" save stream that can be handled by 
older NetWorker servers.

-o

Do not specify the -e option, because uasm does not generate 
the final "end of save stream" boolean. Use this option only 
when both of the following apply:
• ASM invokes an external ASM.
• An optimization does not consume the generated save 

stream itself.

-e

Ignore all save directives from .nsr directive files found in the 
directory tree.

-i

Specify the location of a .nsr directive file to interpret before 
processing any files. Within the directive file specified by 
proto, path directives must resolve to files within the directory 
tree being processed, otherwise their subsequent directives 
will be ignored.

-f

Specify the path with ppath. When you specify -p ppath, this 
string is added to the beginning of each filename as it is 
output. This option is used internally when one ASM execs 
another external ASM. The path you enter for ppath must be a 
properly formatted path that is either the current working 
directory, or a trailing component of it.

-p
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Options for Recover Mode

Table 8 on page 37 lists the options that can be used in recover mode.

Specify a date with -t date to set the date after which files must 
have been modified before they are saved.

-t

Specify -x to cross filesystem boundaries. Normally, filesystem 
boundaries are not crossed when walking the filesystem. 
Symbolic links are never followed, except in the case of 
rawasm.

-x

Table 8. Recover Mode Options

To:
Use this 
option

Define the initial default overwrite response option. Only one 
overwrite response option is allowed. When the name of the 
file being recovered conflicts with an existing file, the user is 
prompted for overwrite permission. The default response 
option, selected by pressing Return, is displayed within 
square brackets.

For additional information about the -i option, see "The -i 
Option" on page 38.

-i {nNyYrR}

Map the filenames to be created. Any files that start exactly 
with src are mapped to have the path of dst replacing the 
leading src component of the pathname. This option is useful 
if you want to perform relocation of the recovered files that 
were saved using absolute pathnames into an alternate 
directory (for example, -m c:\win32app=.).

-m src=dst

Specify the suffix to append when renaming conflicting files. 
The default suffix is R.

-z suffix

Table 7. Save Mode Options (Part 2 of 2)

To
Use this 
option
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The -i Option
The -i option defines the initial default overwrite response option. Table 9 
on page 38 lists the overwrite response options and their meanings: 

When you specify either N, R, or Y, you are prompted only when the 
NetWorker server cannot auto-rename a file that already ends with the 
rename suffix, and each subsequent conflict is resolved as if the 
corresponding lower-case letter had been selected.

Disk Performance Tuning Methods

If you find a blockage in the disk system, you can make the following changes 
to improve performance:

• Defragment files to reduce the number of disk seeks.
• Use larger files or fewer files to reduce the number of disk seeks.
• Change to a faster SCSI adapter, with synchronous I/O support and bus 

mastering.
• Use stripe sets on multiple disks to accommodate large files and 

databases, so the physical disks can work in parallel to read data.
• Spread disk-intensive programs onto different servers.
• Purchase disks with higher transfer rates. 

Table 9. Overwrite Response Options

 Option Meaning

n Do not recover the current file. This is the initial default overwrite 
response option. Each time a response option other than the 
default is specified, the new response option becomes the default.

N Do not recover any files with conflicting names.

y Overwrite the existing file with the recovered file.

Y Overwrite all files with conflicting names.

r Rename the conflicting file. A dot, “.”, and a suffix (by default 
“R”) are appended to the recovered filename. If a conflict still 
exists, the NetWorker software prompts you again.

R Automatically renames conflicting files by appending a dot, “.”, 
and a suffix. If a conflicting filename already ends in a “.” suffix, 
the NetWorker software prompts you to avoid potential 
auto-rename looping conditions.
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Memory and CPU Usage

Each backup session requires CPU and memory resources on the NetWorker 
server. If other applications are running concurrently with the backup, they 
impose an additional load on the system. Heavy swapping or paging activities 
indicate that the server is CPU- or memory-bound.

Memory Usage

A NetWorker server or storage node computer can never have too much 
memory. Data transfer within memory is much faster than over a network. 
Memory holds frequently used data so the disk does not have to be read as 
often. Open applications, processes in run mode, and disk cache all use 
memory. If the operating system is capable, disk storage space can be used as 
simulated memory, often known as virtual memory.

For best results, install the maximum amount of memory that your computers 
will sustain, especially for the NetWorker server and storage nodes.

CPU Usage

To increase CPU performance and bandwidth:

• Upgrade to a faster CPU.
• Add additional CPUs if the NetWorker server supports multiple 

processors.
• Shut down other processes during backup time. 

This may reduce the processor load and improve backup performance. 

Set scheduled backups for low-traffic periods to avoid performance 
degradation or excessive network traffic. The default NetWorker backup start 
time is 3:33 a.m. 

The operating system of a computer might contain various utilities for testing 
and tuning CPU speed. Additionally, you can check the CPU utilization of 
each NetWorker function. The processes involved in a NetWorker backup are 
the following:

• These NetWorker services
– nsrexecd

– nsrd

– nsrmmd

– nsrmmdbd

– nsrindexd
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• The save program for NetWorker backups 
• Application-specific services, such as for a database server

Note: To measure and record CPU speed for the NetWorker server on the 
Windows platform, you can use the Windows NT or Windows 2000 
Performance Monitor. See "Testing CPU Performance" on page 79.

Server Input/Output

The following performance variables relate to the input/output (I/O) 
throughput on the NetWorker server.

Input/Output Backplane 

On a well-configured NetWorker server, the maximum data transfer rate of the 
server's I/O backplane is the limiting factor for backup throughput. The 
theoretical backup throughput limitation is the following formula: 

Backup throughput = Maximum I/O throughput/2

At a minimum, the NetWorker server requires two I/O transactions per data 
block:

• A read from the disk to memory
• A write from memory to media

SCSI I/O Bandwidth 

SCSI bus performance depends on the technology deployed. Some 
specifications for different types of SCSI technology include the following:

• SCSI-2 single-ended, 10 MB/sec
• FWD (fast-wide-differential), 20 MB/sec
• UltraSCSI, 40 MB/sec
• Fibre

Note the following: 

• The rated speeds of SCSI buses are defined as "best case".
• The selection of UltraSCSI-compatible devices is limited.
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NetWorker Settings
The NetWorker software has several attributes that control the speed and 
volume of data being backed up. You can adjust these attribute settings to 
modify backup levels to attain the best performance on the NetWorker server.

The following sections address the various NetWorker settings in principle. 
Because these attributes appear in different locations in the Windows and 
UNIX versions, refer to the Legato NetWorker Administrator’s Guide for specific 
instructions on how to access these settings based on the server platform.

Server Parallelism

The server Parallelism attribute controls how many savestreams the server 
accepts at the same time. The more savestreams the server can accept, the 
faster the devices and client disks run, up to the limit of their performance or 
the limits of the connections between them.

Client Parallelism

The client Parallelism attribute controls how many savestreams a client can 
send at the same time. To avoid disk contention, do not set a value for client 
parallelism that is higher than the number of physical disks on the client.

Multiplexing

The Target Sessions attribute sets the target number of save streams to write to 
a device at the same time. Because this value is not a limit, a device might 
receive more sessions than the attribute specifies. The larger the number of 
sessions you specify for target sessions, the more save sets that can be 
multiplexed (or interleaved) onto the same volume.

Performance tests and evaluation can help determine whether multiplexing is 
appropriate for the system. Follow these guidelines when evaluating the use 
of multiplexing:

• Find the backup rate of each disk on the client. Use the uasm test 
described in "Disk Read Speed Testing Methods" on page 33.

• Find the maximum rate of each device. Use the bigasm test described in 
"Test Device Performance with bigasm" on page 48.
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If the sum of the backup rates from all disks involved in a backup is greater 
than the maximum rate of the device, do not increase server parallelism. If 
more save groups are multiplexed in this case, backup performance will not 
improve, and recovery performance could slow down. 

Modifying Settings for Performance Tuning 

This section describes measures you can take to improve NetWorker server 
performance related to the following:

• Parallelism and Target Sessions attribute settings
• Workload balance
• Multiplexing
• Backups across a network

Parallelism and Target Sessions Attribute Settings

Follow these guidelines to adjust the Parallelism and Target Sessions attributes 
for the best server performance:

• Set the server Parallelism and Target Sessions attributes so that the total 
of the performance of the disk drives equals the total performance of the 
tape drives. If you set the Parallelism attribute to a higher value, there is 
no benefit. 
To select the right values for the Parallelism and Target Sessions attributes, 
use the following equation:
Parallelism = Number of Devices * Target Sessions

For example, if you have three tape drives available for backup, and you 
want each tape drive to accept two savestreams, set the value of server 
parallelism to 6 and the value of target sessions to 2.

• When a NetWorker server is saving a large number of save sets, such as 
500 or more, memory consumption and file descriptor consumption can 
reach values that are close to operating system limitations. In this event, 
the parallelism may need to be lowered.

• Decrease the server Parallelism and Target Sessions attributes to unload 
an overworked NetWorker server. With the correct settings, the normal 
operation of the computer should not be interrupted by backups or other 
NetWorker server activities. 

• Add more memory to handle a higher parallelism setting. 
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Workload Balance

The following are recommended to avoid overloading the server:

• Increase CPU power by upgrading the CPU or adding additional CPUs to 
the server (if possible).

• Reduce server load by spreading backups across multiple servers or 
storage nodes.

• Balance the number of disks and devices, so that the backups finish at 
about the same time. For instructions on how to change these settings, 
refer to the Legato NetWorker Administrator’s Guide. 
Here are some methods of balancing the work load on disks and devices:
– In general, start backups for the slowest or the biggest disk volumes 

first, because other disks can join in later to match the maximum 
bandwidth of the device.

– Use pools of media to force the bigger and faster disk volumes to 
back up to faster devices.

– If you have a very large and fast disk volume and many tape drives, 
you can manually divide the volume into several save sets, such that 
each of them can go to each tape drive in parallel.

– Balance data load for simultaneous sessions more evenly across 
available devices by adjusting the Target Sessions attribute. This 
parameter specifies the minimum number of save sessions that must 
be established before the NetWorker server attempts to assign save 
sessions to another device. 

Multiplexing

Refer to the following guidelines for improving server performance through 
multiplexing:

• To fully use the bandwidth of a high-speed device when you have many 
slow clients or disks, multiplex the save sets on the media. You maximize 
the performance of the devices, since they do not have to start and stop to 
wait for data.

• To improve recovery performance, multiplex save sets that you will 
recover together onto the same tape. For example, multiplex the disks of 
the same computer onto the same media, because it is likely that the data 
from all the disks would be recovered at the same time.
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Backups Across a NetWork

In cases where you back up data across a network, the following suggestions 
can also improve performance:

• Increase the client Parallelism attribute, especially for clients with a 
logical volume manager and several physical disks. The bandwidth of the 
network could limit the number of savestreams you can transmit at one 
time.

• To reduce server load, split backups across multiple servers.
• Turn on data compression in the NetWorker client to improve effective 

data throughput and reduce network traffic. 
• Configure clients with high transfer rate requirements to have a 

preference for a particular backup server on the same subnet; avoid 
router hops between the NetWorker server and its clients. 

Backup Devices
NetWorker software and other storage management products use backup 
devices to do the following:

• Write backed-up data to the storage media volume.
• Read saved data from the storage media during recoveries. 

Devices pass data to and from the NetWorker server itself, or from a 
NetWorker storage node through a SCSI connection. Backup devices can 
include optical disks, and in most cases, tape drives. When a backup device 
has multiple drives, such as for autochangers, each drive is considered a 
separate device.

Device Write Performance Tuning Methods

If the disk read speed is noticeably faster than the ability of the device to write, 
that might indicate a problem with the write performance of the device. To 
perform a thorough evaluation of device performance, follow these 
guidelines:

1. Measure the write speed of each individual device, while the NetWorker 
software is not in run mode.

2. Measure the write speed of all devices, while the NetWorker software is 
not in run mode.
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3. Measure the write speed of each individual device, while the NetWorker 
software is in run mode.

4. Measure the write speed of all devices, while the NetWorker software is in 
run mode.

First evaluate the device performance without the NetWorker software 
running, and then evaluate the devices again with the NetWorker software 
running.

To ensure consistency in the measurements, make sure you use the same tape 
drives for all tests.

Testing Tape Device Performance without Running NetWorker

The mt program can be used to determine tape device performance when the 
NetWorker software is not running. Use it to evaluate the tape device without 
a need to consider the overhead incurred when using the NetWorker software. 

The mt program allows you to operate a magnetic tape device, which includes 
rewinding, fast-forwarding, and ejecting tapes. 

Note: The mt program cannot be used to measure the writing data rate, but can 
indicate performance rates related to having tapes start off loaded and 
rewound prior to measuring write speeds to tape. 

How to Determine Tape Device Performance

To determine tape device performance when NetWorker software is not 
running, enter the following at the command line:

mt -f devicename command count

By default, the mt program performs the requested operation once. To perform 
the operation more than once, specify a value in place of count.

The mt program returns the following exit status:

• 0 if the operations were successful. 
• 1 if the command was unrecognized or mt was unable to open the 

specified tape drive. 
• 2 if an operation failed.
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Table 10 on page 46 lists the available commands to use with the mt command.

Important: Older UNIX systems may have different options for the mt 
command. Before using the mt command, check the mt man page on your 
system for the available options.

Table 11 on page 46 lists the available commands where count is ignored.

Table 10. Commands to Use with the mt Command

To:
Enter this 
Command:

Write count end of file (EOF) marks at the current position 
on the tape.

eof, weof

Forward space over count EOF marks. The tape is 
positioned on the first block of the file.

fsf

Forward space count records. fsr

Backspace over count EOF marks. The tape is positioned on 
the beginning-of-tape side of the EOF mark.

bsf

Backspace count records. bsr

Backspace count files. The tape is positioned on the first 
block of the file. This is equivalent to count + 1 bsf followed 
by one fsf.

nbsf

Absolute space to count file number. This is equivalent to a 
rewind followed by fsf count.

asf

Table 11. Available mt Commands with Count Ignored (Part 1 of 2)

To:
Enter this 
Command:

Space to the end of recorded media on the tape.This is 
useful for appending files onto previously written tapes.

eom

Rewind the tape. rewind
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Limitations

Not all tape devices support all options. Some options are 
hardware-dependent. For example, by entering the following command on a 
Windows computer:

D:\>mt -f \\.\Tape0 status

the following output is displayed:

\\.\Tape0:

Media Capacity  = 2.12GByte

Media Remaining = 3.06GByte

Media Block size = 0

Media Partition Count = 0

Media is not write protected

default block size = 8192

maximum block size = 1040384

The maximum block size value limits the maximum number of bytes per SCSI 
transfer on disk reads and volume writes. 

Rewind the tape and, if appropriate, take the drive unit 
offline by unloading the tape.

offline, rewoffl

Print status information about the tape unit. status

Rewind the cartridge tape completely, then wind it 
forward to the end of the reel and back to the 
beginning-of-tape to smooth out tape tension.

retension

Erase the entire tape. erase

Format the tape at a low level. format

Table 11. Available mt Commands with Count Ignored (Part 2 of 2)

To:
Enter this 
Command:
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How to Test Device Performance with bigasm

To measure SCSI throughput and the write speed of a device while the 
NetWorker software is running, run the bigasm module. The bigasm module is 
run from a directive and generates a file of the specified size, transfers it over 
a SCSI connection, and writes it to a tape or optical device.

The description and options of bigasm (and all other application specific 
modules) are the same as for the uasm module. For a full description of the 
uasm module, see "Disk Read Speed Testing Methods" on page 33.

To set up a bigasm test:

1. Create a file, bigasm.file, that contains the following command:

bigasm -Ssize : filename

For example:
bigasm -S100M : bigfile

2. Save the file using the NetWorker server. For example, if the directive file 
is called bigasm.file and the NetWorker server is called jupiter, enter the 
following command:

save -s jupiter -f /bigasm.file /tmp/filename

The amount of time it takes for the backup to complete indicates the 
efficiency of the SCSI throughput and the write speed of the device.
The bigasm module can also be used in a scheduled backup by creating a 
directive for it in the nwadmin program.

Device Performance Tuning Methods

The following sections address specific device-related areas where you can 
improve performance.

Input/Output Transfer Rate 

Input/output (I/O) transfer rates can affect device performance. The I/O rate 
is the rate at which data can be written to the device. Depending on the device 
and media technology, device transfer rates can range from 500 KB per second 
to 20 MB per second. Default block size and buffer size of a device affect its 
transfer rate. If you believe that I/O limitations are hampering improved 
performance of the NetWorker server, try upgrading the equipment to affect a 
better transfer rate.
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Built-In Compression

Turn on device compression to increase effective throughput to the device. 
Some devices have a built-in hardware compression feature. Depending on 
how compressible the backup data is, this can improve effective data 
throughput, from a ratio of 1.5:1 to 3:1.

Drive Streaming

To obtain peak performance from most devices, stream the drive at its 
maximum sustained throughput. Without drive streaming, the drive must 
stop to wait for its buffer to refill or to reposition the media before the drive can 
resume writing. This can cause a delay in the cycle time of a drive, depending 
on the device.

Device Load Balancing

Balance data load for simultaneous sessions more evenly across available 
devices by adjusting sessions per device. This parameter specifies the 
minimum number of save sessions that must be established before the 
NetWorker server attempts to assign save sessions to another device.

File Type Device and Staging
The NetWorker software includes file type and advanced file type devices and 
save set staging features, which you can use to improve backup performance. 
Since reading and writing data to disk is generally faster than to tape or optical 
media, you can use the file type or advanced file type device feature to direct 
the backups to disk media instead of tape or optical media.

The advanced file type (adv_file) is designed for very large disk devices. It 
differs from the file type device because the volume for the advanced file type 
device is never marked full.

When an advanced file type device runs out of disk space, the current backup 
is suspended. The following message is displayed:

Filesystem full - recover adv_file space

Immediately after the message is displayed, the NetWorker software begins 
deleting expired save sets until more space is made available. If enough space 
has been cleared, the backup continues.
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Use save set staging in conjunction with backups to the file type or adv_file 
device. Save set staging lets you move save sets you have backed up from one 
medium to another according to criteria you set, such as:

• Space remaining on the disk.
• Age of the save set. 

With staging, you can automate transferring older backups from the file type 
device or adv_file device to a less expensive storage media. This frees up hard 
disk space for new backups.

Configuration of File Type and adv_file Devices

A possible configuration to maximize performance of file type or an adv_file 
device is as follows:

1. Create one directory per user, preferably with a mnemonic name matching 
a client. 

2. Create one file type or adv_file device per directory, setting the volume 
size to 1 GB. 

3. Create one client per system, setting the device that is always used to have 
the matching mnemonic device name.

This configuration limits the system to 64 users or less with the NetWorker 
software, since one user equals one device, and that is how many devices 
Power Edition supports. However, if you use storage nodes, then you can have 
64 devices per each node up to a maximum of 256 devices total for the 
NetWorker server and all attached storage nodes.

If you back up the data to file type devices or adv_file devices, you get 
high-speed backups to a hard drive in near real time, but the disk tends to fill 
quickly with backups. 

Without Save Set Staging

Without save set staging, you would have to closely monitor disk usage to 
avoid running out of space for the backups, and you would either have to 
move save sets to other storage media manually or create very short browse 
and retention policies. 
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With Save Set Staging

With save set staging, the process of moving data from disk storage to tape or 
optical disk is automated, and the space that was occupied by the save set is 
freed to make space for new backups. The browse and retention policies for the 
save sets on tape or optical disk can be as long as you like. You can also use 
save set staging to move files from other types of media, but the space is only 
reclaimed on the file type device.

If you are worried about disk contention when you back up to file type or 
adv_file devices, you can use many smaller drives (for example, 6 drives of 4 
GB each and 4 users per drive, instead of one 23 GB drive).

You can also use a RAID array, which provides redundancy in case of a drive 
failure. Windows NT and Windows 2000 include a software RAID capability 
that works well, but uses many CPU cycles. A hardware RAID solution is more 
efficient, but this solution is more expensive.

Network Hardware
If you back up data from remote clients, the routers, network cables, and 
network interface cards affect the backup and recovery operations. This 
section lists the performance variables in network hardware and suggests 
some basic tuning for networks. The following items address specific network 
issues:

• Network Input/Output Bandwidth
The maximum data transfer rate across a network rarely approaches the 
specification of the manufacturer because of network protocol overhead. 

• Network Path 
Networking components such as routers, bridges, and hubs consume 
some overhead bandwidth, which degrades network throughput 
performance. 

• Network Load 
Other network traffic limits the bandwidth available to the NetWorker 
server and degrades backup performance. As the network load reaches a 
saturation threshold, data packet collisions degrade performance even 
more. 
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How to Tune NetWork Hardware Performance

Employ the following measures to improve network hardware performance:

• Add additional network interface cards to client systems to expand 
network bandwidth available to clients. 

• Upgrade to faster LAN media, such as 100 MB Ethernet or FDDI, to 
improve network bandwidth. Note, however, that TCP packet overhead 
can reduce the total transfer rate.

• Configure clients that have high transfer rate requirements to show a 
preference for a particular backup server (or storage node) on the same 
subnet; avoid router hops between the NetWorker server and clients.

• Minimize the number of network components in the data path between 
the client and server. 



Legato NetWorker
Performance Tuning Guide 53

Chapter 4: Testing and Tuning on UNIX and
Linux

This chapter provides additional performance testing and tuning information 
for the NetWorker server on a UNIX or Linux platform. Information pertaining 
to a specific performance issue or tuning method is covered in both this 
chapter and "Testing and Tuning Basics" on page 31. However, the information 
here was written specifically for the UNIX and Linux environments, and 
provides UNIX and Linux-based examples.

The following topics are discussed:

• "Physical Disks" on page 54
• "Devices" on page 57
• "Using the System Activity Reporter" on page 60
• "Recoveries" on page 63

The multitude of platform- and network-specific variables that can impact 
UNIX or Linux system performance cannot be covered comprehensively in a 
single chapter. The scope of this chapter is therefore limited to the detection 
and analysis of processes that have an impact on how efficiently the 
NetWorker server can perform backups and recoveries.

While there are no simple solutions to performance issues, this chapter 
provides a general testing strategy for locating performance blockages. The 
testing strategy uses benchmarks and baselines derived from common 
utilities. 

Note: This chapter assumes that you are familiar with the following:

• UNIX or Linux system infrastructure, including networking and devices.
• Writing shell scripts and using Linux or UNIX utilities, such as tar.
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The scripts in this chapter use standard utilities. The examples are specific to 
Solaris, but the scripts can be applied to most UNIX and Linux platforms with 
minimal changes.

The testing strategy and scripts use the following scenario:

• All backup processes are local (that is, not over a network).
• All tape devices operate at the same speed.

• Data is stored on a filesystem (no databases are used).

Physical Disks
The following sections provide information and suggestions on testing and 
evaluating the read speed performance on the physical disks of the NetWorker 
server. The UNIX and Linux operating systems provide several utilities for 
determining disk read speed. The following sections detail their usage.

Apply the following testing strategy to collect baselines to measure tape drive 
performance:

• Test the read speed of each individual disk, while the NetWorker 
software is not in run mode.

• Test the read speed of all disks, while the NetWorker software is not in 
run mode.

• Test the read speed of each individual disk, while the NetWorker 
software is in run mode.

• Test the read speed of all disks, while the NetWorker software is in run 
mode.

Benchmark Evaluation

The utility /bin/time reports the amount of time required to execute a 
program, breaking down the total time into three components: 

• Real time — the time that the program takes to run as it would be 
measured by a user sitting at the terminal using a stopwatch.

• User time — the actual time that the computer spent executing code in 
the user state.

• System time — the time the computer spent executing UNIX or Linux 
system code on behalf of the user.
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Note: When running the tar or uasm command, do not specify a file or 
mountpoint that has been accessed recently. The file may still be in memory 
and not read from the disk.

Example: 

The result of running the /bin/time tar cvf - /space2 > /dev/null command on 
a Solaris computer provides the following result for the mount point /space2:

RESULTS:

real     6:53.4

user       18.2

sys      1:48.1

How to Test the Read Speed of a Single Disk

To test the read speed of an individual disk:

1. Enter the df command to display a list of mounted filesystems and their 
respective sizes.

2. Run the /bin/time utility to determine how long it takes to read each 
filesystem. For example, on Solaris, enter:

/bin/time tar cf - mount_point > /dev/null

To achieve a consistent result, no other disk or system activity should be 
running when you run this command.

How to Test the Read Speed of Several Disks

After you execute the /bin/time utility for each individual filesystem, measure 
the read time for all the filesystems on each SCSI bus. If you are running the 
disks in parallel, develop a baseline for the number of parallel disks. For 
example, if there are 300 disks, and 10 are in parallel, measure the baseline for 
the 10 disks.
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To streamline this task, create a shell script using the editor of your choice. 
Following is an example shell script from a Solaris computer that was created 
for multiple disks (/space, /space2, and so forth):

/bin/time tar cf - /space > /dev/null &

/bin/time tar cf - /space2 > /dev/null &

/bin/time tar cf - /space3 > /dev/null &

...

How to Test the Read Speed of a Single Disk While Running the 
NetWorker Software

To test the read speed of an individual disk using the NetWorker software:

1. Enter the df command to display a list of mounted filesystems and their 
respective sizes.

2. Run the uasm program for each disk. For example, on Solaris, enter:

/bin/time uasm -s mount_point > /dev/null

Depending on the configuration of the computer, you might need to 
specify the path for uasm in the command.

For more information on the uasm command, see "Disk Read Speed Testing 
Methods" on page 33.

How to Test the Read Speed of Several Disks While Running the 
NetWorker Software

Test the read speed for all the disks on a SCSI channel. If you are running the 
disks in parallel, develop a baseline for the number of parallel disks. For 
example, if there are 300 disks, and 10 are in parallel, measure the baseline for 
the 10 disks.

To streamline this task, create a shell script using the editor of your choice. 
Following is an example shell script for a Solaris computer that was created for 
multiple disks (/space, /space2, and so forth):

/bin/time uasm -s /space > /dev/null &

/bin/time uasm -s /space2 > /dev/null &

/bin/time uasm -s /space3 > /dev/null &

...



Legato NetWorker
Performance Tuning Guide

Chapter 4: Testing and Tuning on UNIX and Linux

4

57

To calculate the read speed of the disk:

1. Enter the df -k command to obtain the file size (in kilobytes) of /space2:

% df -k

Filesystem kbytes used capacity Mounted on
/dev/dsk/c0t1d0s0 1952573 797935 46% /space2

2. Divide the real time by the size (in kilobytes) of /space2. 

For example, based on the result and size of /space2 above, the read speed 
of /space2 is 1932 KB per second.

Compare the results of the benchmarks generated from the following:

• First, from the individual disks without the NetWorker software running, 
as compared to the results of individual disks running the NetWorker 
software. 

• Then, from multiple disks without the NetWorker software running, as 
compared to the results of multiple disks running the NetWorker 
software.

Devices
Apply the following testing strategy to collect baselines to measure tape drive 
performance:

• Test the write speed of each individual tape drive, while the NetWorker 
software is not in run mode.

• Test the write speed of all tape drives, while the NetWorker software is 
not in run mode.

• Test the write speed of each individual tape drive, while the NetWorker 
software is in run mode.

• Test the write speed of all tape drives, while the NetWorker software is in 
run mode.

To ensure consistency in the measurements, test the same tape drives both 
when the NetWorker software is running and when it is not.
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Benchmark Evaluation

Compare the results of the benchmarks generated from the following:

• First, from individual drives writing data without the NetWorker software 
running, as compared to the results of individual drives writing data 
when the NetWorker software is running. 

• Then, from multiple drives writing data without the NetWorker software 
running, as compared to the results of multiple drives writing data while 
running the NetWorker software.

How to Test the Write Speed of a Single Tape Drive

You can also test just a single tape drive by using the commands in this section.

Important: Using the mt rewind command, followed by the dd command, can 
cause the erasure of a tape. Exercise caution when using these commands.

To test the write speed of a single tape drive, enter the following commands 
for each tape drive:

mt -f /dev/rmt/drive_name rewind

dd if=/dev/zero of=/dev/rmt/drive_name \
bs=block_size count=1;\

/bin/time dd if=/dev/zero of=/dev/rmt/drive_name \
bs=block_size count=1000

Although the block size can vary depending on the environment, a block size 
value of 32 can be used for purposes of testing and examples.

How to Test the Write Speed of Several Tape Drives

Test the write speed of all the tape drives on the SCSI channel. To streamline 
this task, create a shell script using the command demonstrated in "How to 
Test the Write Speed of a Single Tape Drive" on page 58. 
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The following is an example of a shell script for a Solaris computer that was 
created for multiple drives (0mbn, 1mbn, 2mbn, and so forth):

Example: 
mt -f /dev/rmt/0mbn rewind; dd if=/dev/zero \ 
of=/dev/rmt/0mbn bs=32k count=1; \
/bin/time dd if=/dev/zero of=/dev/rmt/0mbn \ 
bs=32k count=1000 &

mt -f /dev/rmt/1mbn rewind; dd if=/dev/zero \ 
of=/dev/rmt/1mbn bs=32k count=1; \
/bin/time dd if=/dev/zero of=/dev/rmt/1mbn \
bs=32k count=1000 &

mt -f /dev/rmt/2mbn rewind; dd if=/dev/zero \ 
of=/dev/rmt/2mbn bs=32k count=1; \
/bin/time dd if=/dev/zero of=/dev/rmt/2mbn \ 
bs=32k count=1000 &
...

How to Test the Write Speed of a Single Drive while Running the 
NetWorker Software

To test the write speed of a single drive while running the NetWorker software:

1. Set target sessions to 1.

2. Label the tape.

3. Set up bigasm:

a. Enter the following command at the prompt to create an empty 
directory:
mkdir /empty

b. Enter the following command at the prompt to go to the directory 
empty:

cd /empty

c. Enter the following command at the prompt to create an empty file:
touch e

d. Using a text editor, create a .nsr file.
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e. Edit the .nsr file by adding the following directive:
bigasm -S100M : e

f. Save the file and edit the text editor.

4. Run the following script to determine the baseline:

save -s server_name /etc/motd; /bin/time save -s 
server_name /empty/e

When NetWorker encounters the .nsr file, the directive results in a 100 MB 
file being written to tape.

The NetWorker server automatically assigns each command to a tape, since 
target sessions are set to 1.

How to Test the Write Speed of Several Drives While Running the 
NetWorker Software

To test the write speed of several drives, repeat steps 1-4 in "Test the Write 
Speed of a Single Drive while Running the NetWorker Software" on page 59 
for every drive on the SCSI channel at the same time.

Using the System Activity Reporter
The System Activity Reporter (sar) is a standard UNIX utility for most systems 
that monitors and reports on system performance, including buffer and block 
device activity, kernel memory allocation, and CPU utilization. Use this utility 
to evaluate and tune a UNIX system. For more information, refer to the sar 
man page.

How to Monitor Buffer Activity

If the read and write buffer cache hit rates (%rcache and %wcache) are 
consistently low, increase the size of the buffer cache to improve disk I/O 
performance.

To monitor buffer read activity, enter the following command:

sar -b %rcache

To monitor buffer write activity, enter the following command:

sar -b %wrcache
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The values of %rcache and %wrcache depend on the combination of 
applications that the system is running, the speed of its disk subsystems, and 
the amount of memory available. The ideal value for both is 100%, but that 
value is unlikely on an average system. If either value is consistently below 
50%, increase the size of the buffer cache.

How to Monitor Block Device Activity

To monitor block device activity, enter the following command:

sar -d

Results similar to the following appear:

23:59:44 device %busy avque r+w/s blks/s avwait avserv 
23:59:49 Sdsk-0 99.42 4.18 39.39 166.28 80.26 25.24 
23:59:54 Sdsk-0 100.00 4.18 38.73 163.64 82.35 25.87 
23:59:59 Sdsk-0 100.00 3.98 38.07 171.95 78.32 26.32 

where:

• device is the device on which the activity is being measured.
• %busy is the percentage of time that the system was transferring data to 

and from the device. 
A consistently high value for %busy indicates a heavily utilized disk. 
Increasing CPU power will create a bottleneck worse because the 
processor produces more I/Os for a disk that is already overloaded.

• avque is the average number of requests pending on the device including 
any on the device itself. 

• r+w/s is the number of read and write transfers to and from the disk.
• blks/s is the number of 512-byte blocks transferred per second. 

The values for r+w/s and blks/s can be used to calculate the average size 
of data transfers by using the following formula: 

Average size of data transfer = blks/s / r+w/s
• avwait is the average time in milliseconds that the request waits in the 

driver before being sent to the device. 
• avserv is the average time in milliseconds that it takes a request to 

complete. The length of time is calculated from the time that the request 
was sent to the device to the moment that the device signals that it has 
completed the request. The value of avserv varies depending on the type 
of disk and any caching on the disk controller. 
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Use the values generated by sar -d to determine which disks are overused and 
which are underused. To avoid bottlenecks, balance the disk load by moving 
some users from the busier disks to the less active disks.

How to Test CPU Utilization

The sar -u command identifies disks to which the NetWorker software writes 
frequently, which could be I/O bottlenecks. To enhance performance, optimize 
these disks.

To test I/O-related CPU activity, enter the following command:

sar -u

The following is reported:

• %usr is the percentage of time the system is in user mode (that is, running 
user or application code). 

• %sys is the percentage of time system programs or system calls are run 
from user programs. 

• %wio is the percentage of time the system is waiting for I/O. 
The %wio value should generally not exceed 25%. A higher percentage 
may indicate that you need to speed up disk throughput or add I/O bus 
capacity. 

• %idle is the percentage of time the system is completely idle. 
If %idle is frequently equal to zero, the system is CPU bound. If the system 
throughput is too low, upgrade to a faster processor or reduce 
computational load on the system. 

The following example shows how to test CPU utilization by taking five 
samples at 60 second intervals. 

Example: 

To test CPU utilization, enter the following command: 

sar -u 60 5 

The following results appear: 

18:22:46 %usr %sys %wio %idle 
18:23:46 13 9 6 73 
18:24:46 25 16 13 45 
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18:25:46 21 9 1 68 
18:26:46 22 10 1 66 
18:27:46 22 11 1 66 

Recoveries
Recovery performance can fluctuate based on a variety of issues, including 
network traffic, bottlenecks, and file sizes. One method of recovering data 
efficiently is to start multiple recover commands simultaneously through the 
save set recovery method. 

For example, you can start three different save set recover programs instead of 
one recover program with three save sets. Separate recover programs provide 
the maximum parallelism possible given the number of daemons and the 
actual volume and save set layout.

Important: If multiple, simultaneous recover programs are being run from the 
same tape, do not let the tape mount and start until all recoveries are ready. If 
the tape is used before all recoveries are ready, the tape will be read through 
multiple times and recovery performance will be slower, rather than faster.

How to Perform Multiple, Simultaneous Recoveries

To perform multiple recoveries:

1. Open one command window for each save set that needs to be recovered.

2. In each window, enter the recover command with the save set to be 
recovered, but do not press [Return].

3. Once all three recover commands are ready, execute each command 
consecutively.

4. Measure the time it takes to recover all three save sets.

5. Once the recoveries are finished, perform another recovery with all three 
save sets in the same recover request.

6. Compare the time needed for the multiple recovery requests to the time 
needed for the single recovery request.
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The multiple recoveries should have finished before the single recovery of 
multiple save sets. If the single recovery completed faster: 

• The tape may have been mounted before all recoveries could start. 
• The computer is CPU-bound rather than I/O-bound. 

To determine the cause of the bottlenecks, use the performance and activity 
monitoring tools available with the operating system.
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Chapter 5: Testing and Tuning on Windows

This chapter addresses specific performance testing and tuning tasks you can 
perform on a NetWorker server in a Windows environment. For a discussion 
of general performance issues affecting all versions of the NetWorker software, 
see "Chapter 3: Testing and Tuning Basics" on page 31.

The following topics are discussed in this chapter:

• "Windows Performance Monitor" on page 65
• "Physical Disk" on page 70
• "Memory" on page 73
• "CPU" on page 79
• "Server Input/Output" on page 82
• "Devices" on page 87
• "Windows Software" on page 90
• "Recoveries" on page 91

Windows Performance Monitor
Use the Windows Performance Monitor program to test system performance. 
In the Performance Monitor, you can choose:

• Which objects to watch, for example, the processor or memory.
• Which counters to test, for example, available bytes of memory.
• How to display the data.

The default view of the data is a real-time line chart. However, the data can 
also be logged or formatted as a report, or alerts can be created that warn when 
a counter reaches a certain limit.
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How to Start the Windows NT Performance Monitor

To start the Windows NT Performance Monitor on the NetWorker server: 

1. Select Start>Programs>Administrative Tools>Performance Monitor. 

2. From the View menu, select Report. 

The default viewing mode of the Performance Monitor is Chart, but the 
Performance Monitor-related tasks in this chapter use the Report mode. 

3. From the Edit menu, select Add To Report.

4. From the Object list, select which component of the NetWorker server you 
want the Performance Monitor to track. 

This Object choice determines the Counter and Instance choices available 
to you.

5. From the Counter list box, select a choice. Click Explain to view 
descriptions of each counter.

6. From the Instances list box, select a choice. 

7. When all choices are selected, click Add. 

The Performance Monitor window reflects the NetWorker server and the 
component to be monitored.

8. Repeat steps 4-7 for each component on the NetWorker server you want to 
test. 

The Performance Monitor window lists each component separately under 
the name of the NetWorker server.

9. Once all the NetWorker server components to be tested have been added, 
click Done.

10. Start a backup, and view or capture the results.

To save the performance monitoring information in log form:

1. Place the Performance Monitor in Log mode.

2. From the Options menu, select Log.

3. Specify a filename and location and save the log file.

To test the maximum performance of the NetWorker software:

1. Shut down all extraneous processes.

2. Run just the necessary software on the NetWorker server.
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How to Start the Windows 2000 Performance Monitor

To start the Windows 2000 Performance monitor on the NetWorker server: 

1. Select Start>Programs>Administrative Tools>Performance. 

2. Right-click anywhere in the System Monitor details pane and select 
Properties.

3. In the General tab, select Report.

Note: The default viewing mode of Performance Monitor is Graph, but the 
Performance Monitor-related tasks in this chapter use the Report mode. 

4. To open the Add Counters dialog box, select the Data tab and click Add.

5. To make sure the local computer is the one that is monitored, select Use 
Local Computer Counters.

6. From the Performance Object list, select the NetWorker server component 
to be tracked by the Performance monitor. 

The Object choice selected determines which Counter and Instance choices 
are available.

7. From the Counter list box, select a choice. Click Explain to view 
descriptions of each counter.

8. From the Instances list box, select a choice. 

9. When all choices are selected, click Add. 

10. Click Close.

The Performance Monitor window displays the NetWorker server and 
component to be monitored.

11. Repeat steps 4-10 for each component on the NetWorker server whose 
performance you want to test. 

Performance Object window lists each component separately under the 
name of the NetWorker server.

12. Once all the NetWorker server components to be tested have been added, 
click OK.

13. Start a backup, and view or capture the results.

To save the performance monitoring information in log form, select 
Performance Logs and Alerts in the Performance window.
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To test the maximum performance of the NetWorker software:

1. Shut down all extraneous processes.

2. Run just the necessary software on the NetWorker server.

Testing a NetWorker Server from Another Computer

Because the Performance Monitor uses system resources, you might want to 
run the Performance Monitor on a different Windows computer on the 
network during controlled tests of the NetWorker server.

When the Performance Monitor is run on a different Windows system, it still 
uses some resources on the NetWorker system, especially adding to network 
traffic during remote backups. However, the performance of the processor and 
SCSI throughput on the NetWorker system are not affected.

How to Test a NetWorker Server from Another Windows NT Computer

To test the performance of one or more NetWorker servers from another 
Windows NT computer:

1. Select Start>Programs>Administrative Tools>Performance Monitor on 
the monitoring Windows NT computer.

2. From the View menu, select Report.

3. From the Edit menu, select Add To Report.

4. Enter the name of the NetWorker server to be tested in the Computer text 
box, either by entering the name directly or by clicking the “...” button that 
allows you to browse to the appropriate NetWorker server.

5. From the Object list, select a choice. The Object choice selected determines 
which Counter and Instance choices are available.

6. From the Counter list box, select a choice. Click Explain to view 
descriptions of each counter.

7. From the Instances list box, select a choice. 

8. When all choices are selected, click Add. 

The Performance Monitor window displays the NetWorker server and 
components to be monitored.

9. Repeat steps 5-8 for each component on the NetWorker server to be tested. 

The Performance Monitor window lists each component separately under 
the NetWorker server name.
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10. Repeat steps 4-8 if you want to monitor the performance of any other 
NetWorker servers (or any other Windows NT computers in general).

11. When you have added all the NetWorker server components to be tested, 
click Done.

12. Start a backup, and view or capture the results.

You can save, add to, and redirect the performance monitoring information 
that results from this procedure. For more detailed information about the 
Performance Monitor and Windows NT, refer to the Microsoft Windows NT 
operating system documentation.

How to Test a NetWorker Server from Another Windows 2000 Computer

To test the performance of one or more NetWorker servers from another 
Windows 2000 computer:

1. Select Start>Programs>Administrative Tools>Performance. 

2. Right-click anywhere in the System Monitor details pane and select 
Properties.

3. In the General tab, select Report.

Note: The default viewing mode of Performance Monitor is Graph, but the 
Performance Monitor-related tasks in this chapter use the Report mode. 

4. To open the Add Counters dialog box, select the Data tab and click Add.

5. Select Counters from Computer and type in the name of the NetWorker 
server.

6. From the Object list, select an object. The Object choice selected determines 
the Counter and Instance choices that are available.

7. From the Counter list box, select a choice. Click Explain to view 
descriptions of each counter.

8. From the Instances list box, select a choice. 

9. When all choices are selected, click Add. 

10. Click Close.

The Performance Monitor window displays the NetWorker server and the 
component to be monitored.
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11. Repeat Steps 6-10 for each component on the NetWorker server to be 
tested. 

The Performance Monitor window lists each component separately under 
the NetWorker server.

12. Repeat Steps 5-10 if you want to monitor the performance of any other 
NetWorker servers (or any other Windows 2000 computer in general).

13. When you have completed adding all the NetWorker server components 
to be tested, click OK.

14. Start a backup, and view or capture the results.

You can save, add to, and redirect the performance monitoring information 
that results from this procedure. For more detailed information about the 
Performance Monitor and Windows 2000, refer to the Microsoft Windows 2000 
operating system documentation.

Physical Disk
This section describes how to use Performance Monitor to test and evaluate 
physical disk performance problems related to the NetWorker server. For a 
general discussion of disk-related performance problems and solutions, see 
"Physical Disks" on page 33.

How to Test Disk Performance for Windows NT

To test the disk performance of the NetWorker server in the Windows NT 
environment:

1. Select Start>Programs>Administrative Tools>Performance Monitor. 

2. From the View menu, select Report. 

3. From the Edit menu, select Add To Report.

4. From the Object list, select Physical Disk.

5. From the Counter list box, select the following counters:

– % Disk Time
– Current Disk Queue Length
To view details on each counter, click Explain.
If the NetWorker server has more than one physical disk, select these 
counters for each disk. 
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6. When all choices are selected, click Add. 

The Performance Monitor window reflects the NetWorker server and the 
component whose performance you want to monitor. 

7. Click Done.

8. Start a backup, and view or capture the results.

Note: If the disk performance counters do not work, you must set Windows 
NT to turn them on. Open an MS-DOS window and enter the following 
command at the prompt:

diskperf -y

Restart the NetWorker server to activate the counters.

How to Test Disk Performance for Windows 2000

To test the disk performance of the NetWorker server in a Windows 2000 
environment:

1. Select Start>Programs>Administrative Tools>Performance. 

2. Right-click anywhere in the System Monitor details pane and select 
Properties.

3. In the General tab, select Report.

4. To open the Add Counters dialog box, select the Data tab and click Add.

5. From the Object list, select Physical Disk.

6. From the Counter list box, select the following counters:

– % Disk Time
– Current Disk Queue Length
To view details on each counter, click Explain.
If the NetWorker server has more than one physical disk, select these 
counters for each disk. 

7. When all choices are selected, click Add. 

8. Click Close.

The Performance Monitor window displays the NetWorker server and the 
component to be monitored. 
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9. Click OK.

10. Start a backup, and view or capture the results.

Note: If the disk performance counters do not work, open a command prompt 
window and enter the following command:

diskperf -y

Restart the NetWorker server to activate the counters.

Disk Performance Evaluation Methods

To determine if the NetWorker server has a disk-related blockage, check the 
values gathered from the performance testing.

• If the value for the Percent Disk Time counter exceeds 90 percent, tune the 
disk performance as suggested in "Disk Tuning Methods" on page 72.
This counter measures the percentage of operating time the disk is 
occupied with read or write requests. 

• If the value for the Disk Queue Length counter exceeds 2, tune the disk 
performance as suggested in "Disk Tuning Methods" on page 72.
This counter measures the average number of read or write requests that 
were waiting to be serviced during the sampling interval.

Disk Tuning Methods

The methods for tuning disk performance on the NetWorker server in a 
Windows environment are the same for tuning computer disks in general, 
including:

• Defragment files to reduce the number of disk seeks.
• Use larger files or fewer files to reduce the number of disk seeks.
• Change to a faster SCSI adapter, with synchronous I/O support and bus 

mastering.
• Use stripe sets on multiple disks to accommodate large files and 

databases, so the physical disks can work in parallel to read data.
• Spread disk-intensive programs onto different servers.
• Purchase disks with higher transfer rates. 
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Memory
This section describes how to use the Performance Monitor to test and evaluate 
memory-related performance problems related to the NetWorker server. For a 
general discussion of memory-related performance problems and solutions, 
see "Memory Usage" on page 39.

How to Test Memory Performance for Windows NT

To test the memory-related performance of the NetWorker server in a 
Windows NT environment:

1. Select Start>Programs>Administrative Tools>Performance Monitor. 

2. From the View menu, select Report. 

3. From the Edit menu, select Add To Report.

4. From the Object list, select Memory.

5. From the Counter list box, select the following counters:

– Available Bytes
– Commit Limit
– Committed Bytes
– Pages/sec
To view details on each counter, click Explain. 

6. When all choices are selected, click Add. 

The Performance Monitor window displays the NetWorker server and the 
component to be monitored. 

7. Click Done.

8. Start a backup, and view or capture the results.

To analyze the results of these tests, see "Memory Performance Evaluation 
Methods" on page 75.
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How to Test Memory Performance on Windows 2000

To test the memory-related performance of the NetWorker server in a 
Windows 2000 environment:

1. Select Start>Programs>Administrative Tools>Performance. 

2. Right-click anywhere in the System Monitor details pane and select 
Properties.

3. In the General tab, select Report.

4. To open the Add Counters dialog box, select the Data tab and click Add.

5. From the Object list, select Memory.

6. From the Counter list box, select the following counters:

– Available Bytes
– Commit Limit
– Committed Bytes
– Pages/sec
To view details on each counter, click Explain. 

7. When all choices are selected, click Add. 

8. Click Close.

The Performance Monitor window displays the NetWorker server and the 
component to be monitored. 

9. Click OK.

10. Start a backup, and view or capture the results.

To analyze the results of these tests, see "Memory Performance Evaluation 
Methods" on page 75.
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Memory Performance Evaluation Methods

Use the values gathered from the performance testing to determine if the 
NetWorker server has a memory-related blockage. Table 12 on page 75 lists the 
counters and which values indicate that tuning is required. 

Table 12. Counter Values

Counter Values

Available Bytes This counter measures how much memory is not already occupied. The 
smaller the value of Available Bytes, the slower the performance. If the 
value is less than 4 MB, the memory performance requires tuning.

Pages/sec This counter measures virtual memory activity; that is, how often the 
memory writes to disk. When the computer is memory-bound, it pages 
to the virtual memory on disk more often. A value of 20 or greater 
indicates that tuning is required.

Committed Bytes This counter is the total memory of all applications in use at the moment. 
Applications generally reserve more memory than they use during 
regular operation. But an application does not write data to memory 
without committing the memory first. So the value for Committed Bytes 
shows the amount of memory the applications currently need.

If more memory is committed than you have physical memory to 
accommodate, the computer pages memory contents to disk (virtual 
memory), and the computer works more slowly, because physical 
memory is faster than virtual memory.

Commit Limit This counter is the size of virtual memory that can be committed without 
having to extend the paging file. Every time the Windows computer 
extends the paging file, it goes to disk and searches for more space to use 
for virtual memory. This process has a high performance cost, and you 
might run out of disk space. The Committed Bytes value should not 
consistently exceed the Commit Limit value.
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Tuning Memory Performance in Windows 

The following section explains how to tune memory performance on the 
NetWorker server.

Note: To determine a good baseline size for the virtual memory file 
(pagefile.sys), log the Committed Bytes counter over a period of time, add 10 to 
20 percent to the maximum value, and enter that value in the Initial Size (MB) 
text box in the Virtual Memory dialog box.

How to Adjust the Virtual Memory for Windows NT

To adjust the allocated size of virtual memory on the NetWorker server in a 
Windows NT environment:

1. Select Start>Settings>Control Panel.

2. Double-click the System icon, then click the Performance tab. 

3. To open the Virtual Memory dialog box, click Change.

4. As needed, adjust the size and location of the disk space allocated to 
virtual memory. 

5. Click OK.

How to Adjust the Virtual Memory for Windows 2000

To adjust the allocated size of virtual memory on the NetWorker server in a 
Windows 2000 environment:

1. Select Start>Settings>Control Panel.

2. Double-click the System icon to open the System Properties dialog box.

3. Select the Advanced tab and click Performance Options. 

4. In the Performance Options window, click Change to open the Virtual 
Memory dialog box.

5. As needed, adjust the size and location of the disk space allocated to 
virtual memory. 

6. Click OK.
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How to Adjust the Physical Memory Allocation for Windows NT

To adjust physical memory allocation on the NetWorker server in the 
Windows NT environment:

1. Select Start>Settings>Control Panel.

2. Double-click the Network icon, then click the Services tab.

3. From the Network Services list box, select Server.

4. To open the Server dialog box, click Properties.

5. Select one of the following options:

– Minimize Memory Used: Use when the server has fewer than 10 
users, such as a local backup on a NetWorker server.

– Balance: Use when the server has 10 to 64 users.
– Maximize Throughput for File Sharing: Allocate most of the memory 

to the fileserver module, for systems with more than 64 users.
– Maximize Throughput for Network Application: Use for a 

client-server application server, such as a NetWorker server with 
remote clients.

6. Click OK.

How to Adjust the Physical Memory Allocation for Windows 2000

To adjust physical memory allocation on the NetWorker server in a Windows 
2000 environment:

1. Select Start>Settings>Control Panel.

2. Double-click the Network and Dial-Up Connections icon.

3. Right-click Local Area Connection and select Properties.

4. In the Local Area Connection Properties dialog box, select File and Printer 
Sharing for Microsoft Networks and click Properties.

5. Select one of the following options:

– Minimize Memory Used: Use when the server has fewer than 10 
users, such as a local backup on a NetWorker server.

– Balance: Use when the server has 10 to 64 users.
– Maximize Throughput for File Sharing: Allocate most of the memory 

to the fileserver module, for systems with more than 64 users.
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– Maximize Throughput for Network Application: Use for a 
client-server application server, such as a NetWorker server with 
remote clients.

6. Click OK.

Memory-Related Server Tuning Methods

To speed up virtual memory, you can implement the disk recommendations in 
"Disk Tuning Methods" on page 72. You can also defragment the disks where 
pagefile.sys resides. 

Note: It is not recommended to put pagefile.sys on either of the following:

• A stripe set, because virtual memory is less efficient when it is 
fragmented.

• A mirrored drive, because every write is done twice, which slows 
down writes to virtual memory. 

You can also reduce the memory that the NetWorker server uses. Suggestions 
to reduce memory requirements include the following:

• Reduce the number of other applications that run on the NetWorker 
server. Dedicate the NetWorker server to run the database server, 
NetWorker client, NetWorker Module client, and NetWorker server.

• Stop services that you do not use. For example, if you have only SCSI 
devices, stop the ATDISK service, which is for IDE devices only.

• Remove communications protocols you do not use. For example, if you 
only use TCP/IP but you also have SPX installed, remove SPX.
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CPU
The following sections address testing and tuning issues for the NetWorker 
server CPU(s). For a general discussion of how CPU issues affect NetWorker 
software performance, see "CPU Usage" on page 39.

Testing CPU Performance

Total CPU utilization and CPU utilization for each individual process 
demonstrate the CPU performance of the NetWorker server.

How to Test Total CPU Utilization on Windows NT

To test total CPU utilization of the NetWorker server during backup in a 
Windows NT environment: 

1. Select Start>Programs>Administrative Tools>Performance Monitor. 

2. From the View menu, select Report. 

3. From the Edit menu, select Add To Report.

4. From the Object list, select Processor.

5. From the Counter list box, select % Processor Time. Click Explain to view 
details on this counter.

6. Select the processors to be tested from the Instance list box if the 
NetWorker server has more than one processor. 

7. When all choices are selected, click Add. 

The Performance Monitor window displays the NetWorker server and the 
component to be monitored. Click Done.

8. Start a backup, and view or capture the results.

How to Test Total CPU Utilization on Windows 2000

To test total CPU utilization of the NetWorker server in a Windows 2000 
environment during backup: 

1. Select Start>Programs>Administrative Tools>Performance. 

2. Right-click anywhere in the System Monitor details pane and select 
Properties.

3. In the General tab, select Report.
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4. Select the Data tab and click Add.

5. From the Object list, select Processor.

6. From the Counter list box, select % Processor Time. Click Explain to view 
details on this counter.

7. Select the processors to be tested from the Instance list box if the 
NetWorker server has more than one processor. 

8. When all choices are selected, click Add. 

9. Click Close.

The Performance Monitor window displays the NetWorker server and the 
component to be monitored. 

10. Click OK.

11. Start a backup, and view or capture the results.

How to Test CPU Performance by Process for Windows NT

You can also test CPU utilization for each process involved in the backup, to 
determine which processes use most of the CPU capacity. 

To test total CPU utilization of the NetWorker server in a Windows NT 
environment during backup: 

1. Select Start>Programs>Administrative Tools>Performance Monitor. 

2. From the View menu, select Report. 

3. From the Edit menu, select Add To Report.

4. From the Object list, select Process.

5. From the Counter list box, select the % Processor Time. Click Explain to 
view details on this counter.

6. Select the individual services, programs, or other processes to be tested 
from the Instance list box.

7. When all choices are selected, click Add. 

The Performance Monitor window displays the NetWorker server and the 
component to be monitored. 

8. Click Done.

9. Start a backup, and view or capture the results.
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There is a CPU blockage if total CPU utilization remains above 90% for long 
periods during the backup process.

How to Test CPU Performance by Process for Windows 2000

You can also test CPU utilization for each process involved in the backup, to 
determine which processes use most of the CPU capacity. 

To test total CPU utilization of the NetWorker server in a Windows 2000 
environment during backup: 

1. Select Start>Programs>Administrative Tools>Performance. 

2. Right-click anywhere in the System Monitor details pane and select 
Properties.

3. In the General tab, select Report.

4. Select the Data tab and click Add.

5. From the Object list, select Process.

6. From the Counter list box, select the % Processor Time. Click Explain to 
view details on this counter.

7. From the Instance list box, select the individual services, programs, or 
other processes to be tested.

8. When all choices are selected, click Add. 

9. Click Close.

The Performance Monitor window displays the NetWorker server and the 
component to be monitored. 

10. Click OK.

11. Start a backup, and view or capture the results.

There is a CPU blockage if total CPU utilization remains above 90% for long 
periods during the backup process.



Legato NetWorker
Performance Tuning Guide

5

Server Input/Output

82

Server Input/Output
The following sections address testing and tuning issues for the NetWorker 
server input/output (I/O). For a general discussion of how I/O issues affect 
NetWorker software performance, see "Server Input/Output" on page 40.

To test the I/O of the NetWorker server most effectively, you must start and 
configure the Performance Monitor, and then run specific NetWorker server 
I/O-related tests. For more information about these tests, see " Server 
Input/Output" on page 40.

How to Test Input/Output Performance on Windows NT

To start and configure the Performance Monitor to test the NetWorker server 
I/O in a Windows NT environment:

1. Select Start>Programs>Administrative Tools>Performance Monitor. 

2. From the View menu, select Report. 

3. From the Edit menu, select Add To Report.

4. From the Object list, select System.

5. From the Counter list box, select File Write Bytes/sec. Click Explain to 
view details on this counter.

6. When all choices are selected, click Add.

The Performance Monitor window displays the NetWorker server and the 
component to be monitored. 

7. Click Done.

8. Run the following tests, and view or capture the results:

– For the uasm program: See "Disk Read Speed Testing Methods" on 
page 33.

– For the mt program: See "Testing Tape Device Performance without 
Running NetWorker" on page 45.

– For the bigasm program: See "Test Device Performance with bigasm" 
on page 48.
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How to Test Input/Output Performance on Windows 2000

To start and configure the Performance Monitor to test the NetWorker server 
I/O in a Windows 2000 environment:

1. Select Start>Programs>Administrative Tools>Performance. 

2. Right-click anywhere in the System Monitor details pane and select 
Properties.

3. In the General tab, select Report.

4. Select the Data tab and click Add.

5. From the Object list, select System.

6. From the Counter list box, select File Write Bytes/sec. Click Explain to 
view details on this counter.

7. When all choices are selected, click Add. 

8. Click Close.

The Performance Monitor window displays the NetWorker server and the 
component to be monitored. 

9. Click OK.

10. Run the following tests, and view or capture the results:

– For the uasm program: See "Disk Read Speed Testing Methods" on 
page 33.

– For the mt program: See "Testing Tape Device Performance without 
Running NetWorker" on page 45.

– For the bigasm program: See "Test Device Performance with bigasm" 
on page 48.

Tuning Input/Output Performance

The rate at which a SCSI device can write data to media is limited by the 
amount of data that transfers over the SCSI bus in a single I/O operation. To 
tune SCSI performance, change the number of memory pages the SCSI host 
bus adapter (HBA) can scatter and/or gather in a single direct memory access 
(DMA). The number of bytes that can be transferred in a single I/O with a SCSI 
device is limited by the number of memory pages that the SCSI host bus 
adapter can scatter and/or gather in a single DMA. 
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The SCSI driver of each vendor specifies the maximum number of pages that 
the HBA can scatter and/or gather for the DMA transfer. When you multiply 
the page size by the number of scatter and/or gather entries, the product is the 
effective limit to the number of bytes that can be transmitted in a single I/O 
operation. 

The equation is the following:

I/O operation size = Page size * (# of scatter/gather entries -1)

User memory is not necessarily page-aligned; therefore:

If MaximumSGList = 255 then the I/O transfer size is 4K * 254 = 1016K.

For the drivers of some SCSI host adapters, you can change the maximum 
number of scatter and/or gather pages. Many tape drives and disk drives 
perform better with a larger I/O limit. A change in the number of scatter 
and/or gather pages can make a large performance difference. For example: 

• The Ampex DST tape drive writes only 3 MB per second with 64 KB SCSI 
transfers and 20 MB per second with 992 KB SCSI transfers. 

• The SCSI disk “CYBERNET 10XP” reads 1.7 MB per second with a 32 KB 
read buffer size and 17 MB per second with a 200 KB read buffer size.

To change the maximum scatter and/or gather pages setting in the Windows 
Registry, add the following new Registry subkey to specify the maximum 
number of scatter and/or gather list elements for each device on a given bus:

HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\
DriverName\Parameters\Device number\MaximumSGList

Important: Modifying the Registry is very dangerous. Do not attempt to 
modify the Registry unless you have an up-to-date backup of the Registry to 
which you can revert and you are convinced that the modification you are 
about to make is correct. Inappropriate changes to the Registry can result in the 
need to reinstall the Windows software.
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How to Add a Subkey Entry to the Windows Registry

To add the subkey entry to the Windows Registry:

1. Start the Windows Registry Editor program as follows:

a. Select Start>Run.
b. Enter the following value in the Open text box: 

regedt32

c. Press [Enter].
Note: You can also open this program at the following location:
%SystemRoot%\Winnt\System32\regedt32.exe

2. Select Window>HKEY_LOCAL_MACHINE to make that window active.

3. Select Edit>Add Key and enter Parameters for Key Name to create a key 
named Parameters, if one does not exist.

4. To create a key named Device, open the Parameters key by selecting 
Edit>Add Key and enter Device for Key Name.

5. To create a DWORD named MaximumSGList, open the Device key by 
selecting Edit>DWORD and entering MaximumSGList for DWORD 
Name.

6. Open the MaximumSGList Value Name and replace the existing Value 
Data in Decimal with a number at least as large as the block size you need 
for the device.

To calculate the value, use the following equation:
(Block_Size / 4) + 1 = Value
Table 13 on page 85 provides block size and corresponding decimal and 
hex values.

Table 13. Block Sizes

Block Size Decimal Value Hex Value

64k 17 decimal 11 hex

96k 25 decimal 19 hex

128k 33 decimal 21 hex

256k 65 decimal 41 hex

512k 129 decimal 81 hex
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7. Reboot the machine.

8. To locate the drives, run the inquire program:

C:\>inquire

Results similar to the following appear:
scsidev@0.5.0:NEC CD-ROM DRIVE:4661.06|CD-ROM

scsidev@0.6.0:ARCHIVE Python 06408-XXX8071|Tape, 
\\.\Tape0

scsidev@1.0.0:HP C5173-7000 3.02|Autochanger (Jukebox)

scsidev@1.2.0:QUANTUM DLT7000 1732|Tape, \\.\Tape1

scsidev@1.3.0:QUANTUM DLT7000 1732|Tape, \\.\Tape2

scsidev@2.0.0:SEAGATE ST39204LC 0002|Disk, 
\\.\PHYSICALDRIVE0

scsidev@2.1.0:QUANTUM ATLAS V  9 SCA  0201|Disk, 
\\.\PHYSICALDRIVE1

scsidev@2.6.0:DELL 1x4 U2W SCSI BP 5.35|Processor

9. To check if the maximum blocksize has changed, run the mt program:

C:\>mt -f \\.\Tape1 status

Results similar to the following appear:
\\.\Tape1:

Media Capacity  = 15.20GByte

Media Remaining = 13.60GByte

Media Blocksize = 0

Media Partition Count = 0

Media is not write protected

default blocksize = 65536

maximum blocksize = 131072

minimum blocksize = 1

MaximumPartitionCount = 0

Partition = 0

Logical block position = 44815

EOTWarningZoneSize = 0

CompressionEnabled

Features: ...

In the above example, the maximum block size is 128 KB (131072 divided 
by 1024). 
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Other suggestions for tuning I/O performance are as follows:

• Move the hardware configuration around; for example, move some disks 
off a SCSI bus that is overloaded.

• If possible, use PCI adapters in the NetWorker server. If you must use 
other adapters, EISA adapters are better than ISA adapters, because ISA 
adapters have bus contention problems that degrade system 
performance.

• Use a dual PCI backplane system, rather than a bridged PCI backplane. 
• Use multiple SCSI buses with devices of the same type (for example, 

UltraSCSI) on the same bus.
• Use short, high-quality cables with active terminators.
• Ensure that SCSI communications are occurring synchronously, not 

asynchronously.

Devices
The following sections address testing and tuning issues for the NetWorker 
backup devices within the Windows environment. For a general discussion of 
how device issues affect NetWorker software performance, see "Backup 
Devices" on page 44.

How to Test Device Performance

To test device input/output, see the bigasm program test described in "How to 
Test Device Performance with bigasm" on page 48.

Tuning Device Performance

Most tape drives come with hardware data compression enabled by default. 
When compression is enabled, device performance and media capacity can 
double. 

Hardware data compression is controlled by the NSR_NO_HW_COMPRESS 
environment variable. When you set this environment variable to Yes, data is 
not compressed by the hardware before it is written to media. 
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Notes:

• For data that is already compressed before it reaches the device, 
additional compression might increase the size of the data. If the data 
comes to the device already compressed, you can disable compression on 
the storage device.

• When you change the name of an existing variable, Windows NT treats it 
as a new variable and does not overwrite or delete original variable.

How to Tune Device Performance on Windows NT

To tune the hardware compression system variable on a Windows NT 
computer:

1. Select Start>Settings>Control Panel.

2. Double-click the System icon and click the Environment tab.

3. Review the variables and values listed in the System Variables list box. 
Depending on whether the NSR_NO_HW_COMPRESS variable already 
exists or not, follow the appropriate step:

– If the NSR_NO_HW_COMPRESS variable is already listed, and you 
simply want to change its value, select it. The variable name and its 
value appear in the Variable and Value text boxes.
a. Change its value to Yes.
b. Click Set to confirm the change. 

The updated value of the NSR_NO_HW_COMPRESS variable is 
reflected in the System Variables list box.

– If the NSR_NO_HW_COMPRESS variable is not listed, you need to 
create it. 
a. Select any variable so that its name and value are displayed in the 

Variable and Value text boxes.
b. Change the existing variable name to 

NSR_NO_HW_COMPRESS.
c. Enter the value yes.
d. Click Set to confirm the new variable. 

The new variable and its value are reflected in the System Variables 
list box, and the original one you selected remains unchanged.

4. Click OK when you have completed adding or modifying the 
NSR_NO_HW_COMPRESS variable and/or its value.

5. Restart the NetWorker server.
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To see the device compression setting, enter the following at the command 
line:

mt -f \\.\Tape0 stat

In the output of a device with compression enabled, the following appears:

Compress Enabled

How to Tune Device Performance on Windows 2000

To tune the hardware compression system variable:

1. Select Start>Settings>Control Panel.

2. Double-click the System icon.

3. Select the Advanced tab and click Environment Variables.

4. Review the variables and values listed in the System Variables list box. 
Depending on whether the NSR_NO_HW_COMPRESS variable already 
exists or not, follow the appropriate step:

– If the NSR_NO_HW_COMPRESS variable is already listed, and you 
simply want to change its value, select it. The variable name and its 
value appear in the Variable and Value text boxes. 
a. Change its value to Yes.
b. Click OK to confirm the change. 

The updated value of the NSR_NO_HW_COMPRESS variable is 
reflected in the System Variables list box.

– If the NSR_NO_HW_COMPRESS variable is not listed, you need to 
create it. 
a. Click New. 
b. Enter the variable name NSR_NO_HW_COMPRESS
c. Enter the value Yes. 
d. Click OK.

5. When you have completed adding or modifying the 
NSR_NO_HW_COMPRESS variable and/or its value, click OK.

6. Restart the NetWorker server.
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To see the device compression setting, enter the following on the command 
line:

mt -f \\.\Tape0 stat

In the output of a device with compression enabled, the following appears:

Compress Enabled

Windows Software
The following variables affect the overall Windows operating system 
performance and the speed of backup:

• Filesystem overhead
Filesystem input/output (I/O) can degrade I/O performance. If you 
integrate logical volume managers with the filesystem, you can increase 
disk performance and add a host of other features to improve 
manageability of large filesystems. Also, depending on the level of RAID 
(Redundant Array of Independent Disks) you implement, RAID can 
improve or adversely affect backup performance. 

• Server memory usage setting
You can set server memory use to be optimized for the following:
– Small number of clients 
– Large number of clients
– Fileserver
– Domain controller 
For more information, see "Memory Performance Evaluation Methods" on 
page 75.

• Page file size
You can adjust the size and location of the virtual memory file (pagefile.sys) 
on the local disks. For more information, see "Memory Performance 
Evaluation Methods" on page 75.
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Recoveries
Recovery performance can fluctuate based on a variety of issues, including 
network traffic, bottlenecks, and file sizes. One method of recovering data 
efficiently is to start multiple recover commands simultaneously through the 
save set recovery method. 

For example, you can start three different save set recover programs instead of 
one save set recover program with three save sets. Separate recover programs 
provide the maximum parallelism possible given the number of daemons and 
the actual volume and save set layout.

Important: If multiple, simultaneous recover programs are being run from the 
same tape, do not let the tape mount and start until all recoveries are ready. If 
the tape is used before all recoveries are ready, the tape will be read through 
multiple times and recovery performance will be slower, rather than faster.

How to Perform Multiple, Simultaneous Recoveries

To perform multiple recoveries:

1. Open one NetWorker User program for each save set that needs to be 
recovered.

2. In each window, select the save set to be recovered, but do not start the 
recovery process.

3. Once all three save sets have been selected in their respective window, 
execute each recovery consecutively.

4. Measure the time it takes to recover all three save sets.

5. Once the recoveries are finished, perform another recovery with all three 
save sets in the same recover request.

6. Compare the time needed for the multiple recover requests to the time 
needed for the single recover request.

The multiple recoveries should have finished before the single recovery of 
multiple save sets. If the single recovery completed faster, the tape may have 
been mounted before all recoveries could start or the computer is CPU-bound 
rather than I/O-bound. To determine the cause of the bottlenecks, use the 
performance and activity monitoring tools available with the operating 
system.
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Appendix A: Troubleshooting

RPC Error Messages
When trying to connect to the NetWorker server, you may encounter the 
following error messages:

Error: ’save: RPC error: Remote system error’

Error: ’save: Cannot open save session’ 

Problem

When under stress, the current RPC implementation can only handle a small 
burst of connection requests. The server services only one connection request 
each time it goes through the select() loop. When the server is busy serving 
other connections, it takes more time to do one select() loop, and the server 
services a lower number of connection requests per second.

For example, there are 10 clients calling the service, and each client takes 10ms 
to service. It takes 200ms to go around the select loop, and it can only service 
10 connection requests per second.

In some customer environments, over 400 clients could be attempting to 
connect to the same server over a short period of time. If the server is under 
stress and can only handle 10 connection request per second, it will not be able 
to handle the burst of 400 connection requests. The server can only queue up 
twenty requests. The connection requests that are not queued up may attempt 
to retry, or they may fail with multiple RPC errors.
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Solution

To avoid this problem, increase the SOMAXCONN parameter, a kernel 
parameter that governs the maximum number of unaccepted socket 
connections that can be waiting in queue. It is also referred to as the listen() 
queue limit. When NetWorker (NSRD) starts, it requests a listen() queue of 200. 
Ensure that the value for SOMAXCONN is set to 200 or higher. This parameter 
must be set before NSRD starts.

The following are examples of setting the SOMAXCONN parameter on 
various platforms:

• For Solaris, enter the following commands:
/usr/sbin/ndd -set /dev/tcp tcp_conn_req_max_q 1024

where the q queue holds sockets awaiting an accept() call.
/usr/sbin/ndd -set /dev/tcp tcp_conn_req_max_q0 2048 

where the q0 queue contains half-open sockets. 
• For Tru64 UNIX:

a. Enter the following command:
/sbin/sysconfig -r socket sominconn=65535

The value of sominconn determines how many simultaneous 
incoming SYN packets can be handled by the system. 

b. /sbin/sysconfig -r socket somaxconn=65535 

The value of somaxconn sets the maximum number of pending TCP 
connections. 

• For HP-UX, enter the following commands:
/usr/sbin/ndd -set /dev/tcp tcp_syn_rcvd_max 1024 

/usr/sbin/ndd -set /dev/tcp tcp_conn_request_max 200 

• For Linux, enter the following command to increase the size of the socket 
queue (effectively, q0):
/sbin/sysctl -w net.ipv4.tcp_max_syn_backlog=1280 
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Troubleshooting Target Sessions
The Target Sessions attribute sets the number of backup sessions accepted by 
an active device. The Target Sessions attribute is configured in the Device 
resource, and a different value can be specified for each device.

If the Target Session value is set too high, the performance of the backup does 
not always improve. For example, suppose the Parallelism attribute is set to 16, 
which means the NetWorker server can handle up to 16 streams of data from 
the NetWorker clients. If the Target Session attribute for each device is set to 
16, then each device can also handle 16 streams. In this case, the 16 data 
streams from the clients may be sent to the same device, since each device can 
handle 16 streams. No benefit is gained by using the Target Sessions attribute.

To optimize device usage, set the Target Session attribute to less than the 
Parallelism attribute so more than one device is selected for multiple backup 
streams.
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Glossary

This glossary contains terms and definitions related to this manual. Most of the 
terms are specific to Legato NetWorker products.

1-9 Intermediate backup levels. Each number represents a 
backup level. Lower levels back up more files.

Administrators 
group

Windows NT user group whose members have all the 
rights and abilities of users in other groups, plus the 
ability to create and manage all the users and groups in the 
domain. Only members of the Administrators group can 
modify Windows NT OS files, maintain the built-in 
groups, and grant additional rights to groups.

annotation A comment that you associate with an archive save set, to 
help identify that data later on. Annotations are stored in 
the media index for ease of searching and are limited to 
1024 characters.

Application-Specific 
Module (ASM)

A program that, when used in a directive, specifies the 
way a set of files or directories is to be backed up and 
recovered.

archive The process by which NetWorker backs up directories or 
files to an archive volume and then optionally deletes 
them to free up disk space.

archive clone pool A volume pool composed exclusively of archive clone 
save sets.

archive pool A volume pool composed exclusively of archive save sets.
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archive volume A tape or other storage medium used for NetWorker 
archives, as opposed to a backup volume.

ASM See Application-Specific Module (ASM).

autochanger A mechanism that uses a robotic arm to move media 
among various components located in a device including 
slots, media drives, media access ports, and transports. 
Autochangers automate media loading and mounting 
functions during backups and recovers. 

Backup Operators 
group 

A Windows NT group whose members have the capability 
of logging on to a domain from a workstation or a server, 
backing it up, and restoring the data. Backup Operators 
also can shut down servers or workstations.

backup volume Backup media, such as magnetic tape or optical disk.

bootstrap Information that includes the server index, media index, 
and configuration files needed for recovering NetWorker 
after a disk crash. 

browse policy The policy that determines how long entries for the files 
remain in the online file index.

carousel A tray or tape cartridge that holds multiple backup 
volumes.

client A computer that accesses the NetWorker server to back up 
or recover files. Clients may be workstations, PCs, or 
fileservers.

clone The process by which NetWorker makes an exact copy of 
saved data (save sets). NetWorker can clone individual 
save sets or the entire contents of a backup volume.

clone volume A duplicated volume. NetWorker can track four types of 
volumes: backup, archive, backup clone, and archive 
clone. Save sets of different types may not be intermixed 
on one volume.

command line The shell prompt, where you enter commands.
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compressasm A NetWorker directive used for compressing and 
decompressing files.

device The backup device (tape drive, optical drive, or 
autochanger) connected to the NetWorker server; used for 
backing up and recovering client files.

directive An instruction directing NetWorker to take special actions 
on a given set of files.

enabler codes Special codes provided by Legato that allow you to run 
the NetWorker software product.

file index A database of information maintained by NetWorker that 
tracks every file or filesystem backed up.

fileserver A computer with disks that provides services to other 
computers on the network.

filesystem 1. A file tree on a specific disk partition or other mount 
point. 2. The entire set of all files. 3. A method of storing 
files.

full (f) A backup level in which all files are backed up, regardless 
of when they last changed.

grooming The process of removing files after a successful archive.

group A client or group of clients that starts backing up its files at 
a designated time.

heterogeneous 
networks

Networks with systems of different platforms that interact 
meaningfully across the network.

himt A choice in the Devices window; represents half-inch 
magnetic tape.

incremental (i) A backup level in which only files that have changed since 
the last backup are backed up.

interoperability The ability of software and hardware on multiple 
computers from multiple vendors to communicate 
meaningfully.
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level (1-9) A backup level that backs up files that have changed since 
the last backup of any lower level.

media Magnetic tape or optical disks used to back up files.

media index A database of information maintained by NetWorker that 
tracks every backup volume.

media manager The NetWorker component that tracks save sets to backup 
volumes.

NetWorker A Legato network-based software product to back up and 
recover filesystems.

NetWorker client A computer that can access the backup and recover 
services from a NetWorker server.

NetWorker server The computer on a network running the NetWorker 
software, containing the online indexes and providing 
backup and recover services to the clients on the same 
network.

notice A response to a NetWorker event.

nsrhost The logical hostname of the computer that is the NetWorker 
server.

online indexes The databases located on the server that contain all the 
information pertaining to the client backups and backup 
volumes.

operator The person who monitors the server status, loads backup 
volumes into the server devices, and otherwise executes 
day-to-day tasks using NetWorker.

override A backup level that takes place instead of the scheduled 
one.

pathname Instructions for accessing a file. An absolute pathname tells 
you how to find a file beginning at the root directory and 
working down the directory tree. A relative pathname tells 
you how to find the file starting where you are now.
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preconfigured Existing selections or configurations for different 
NetWorker features.

print Send data to a printer.

qic A choice in the Devices window; represents quarter-inch 
cartridge tape.

recover The NetWorker command used to browse the server index 
and to recover files from a backup volume to a clients disk.

recycle A volume whose data has passed both its browse and 
retention policies and is available for relabeling.

Registry A database of configuration information central to 
Windows NT operations. The overall effect centralizes all 
Windows NT settings and provides security and control 
over system, security, and user account settings.

retention policy A NetWorker policy that determines how long entries will 
be retained in the media database and thus be recoverable.

retrieval The process of locating and copying back files and 
directories that NetWorker has archived.

save The NetWorker command that backs up client files to 
backup volumes and makes data entries in the online 
index.

save set A set of files or a filesystem backed up onto backup media 
using NetWorker.

save set ID An internal identification number assigned to a save set by 
NetWorker.

scanner The NetWorker command used to read a backup volume 
when the online indexes are no longer available.

server The computer on a network running the NetWorker 
software, containing the online indexes and providing 
backup and recover services to the clients on a network.

shell prompt A cue for input in a shell window where you enter a 
command.
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skip (s) A backup level in which files are skipped and not backed 
up.

stand-alone device A backup device that contains a single drive for backing 
up data. Stand-alone devices cannot store or automatically 
load backup volumes.

system administrator The person normally responsible for installing, 
configuring, and maintaining NetWorker. 

user A person who can use NetWorker from his or her 
workstation to back up and recover files.

volume Backup media, such as magnetic tape or optical disk.

volume ID The internal identification assigned to a backup volume by 
NetWorker.

volume name The name you assign to a backup volume when it is 
labeled.

volume pool A feature that allows you to sort backup data to selected 
volumes. A volume pool contains a collection of backup 
volumes to which specific data has been backed up.



Legato NetWorker
Performance Tuning Guide 103

Index

A

absolute pathnames 37
ansrd service 20–21
application specific module See ASMs
ASMs 34–36
authentication

nsrexecd 21
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backplane
transfer rate 40
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backup devices See devices
backups

balancing disks and devices 43
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remote 26
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scheduled 21
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increased performance 39–40, 43
limitations 17, 44, 51

benchmarks 32
devices 58
disks 54

bigasm module 41, 48, 59, 87
options 48

block device activity
monitoring 61

bootstrap file 23
boundaries

crossing 37
browse policies 51
buffer activity

monitoring 60
Business Edition

advantages 15

features 16
options 16

C

client file index 19, 21–22
consistency check 20
nsrindexd 20

Client Priority attribute 22
clients

backups
ad-hoc 21
groups 22
multiple 20
scheduled 21

compression 44
groups 20–22

backups 22
high transfer rate 44
parallelism 41, 44
programs 21
remote

backup 27
recover 27

services 21
compare mode

uasm program 34
compression 44, 87–89

built-in device 49
of data 33

configuration
file type devices 50
of NetWorker 25

conflicting filenames
options 38
suffix 37–38

contention, disk 51
count value 45
CPU 39, 43, 79

evaluating problems 81
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testing 39, 79
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utilization 62
tuning 39

D

data
compression 44, 49
recovery by NetWorker 24
remote client

backup 27
recover 27

streaming 49
databases

immediate save, using 27
defragmentation 38
devices 43–44, 87–89

balancing backup load 43
benchmarks, evaluating 58
compression, built-in 49
data streaming 49
file type 49–50
high-speed 27
input/output 48
load balancing 49
magnetic tape 45
multiple 28
performance 45, 48
RAID 51
silos 28–29
support 20
testing 44–45, 48, 58–60, 70–71

multiple 58, 60
NetWorker running 59–60

tuning 48
write speed 44, 48, 57–60, 70–71
See also high-speed devices

df command 55–57
directive

bigasm module 48
files 34
ignoring save 36

disk seek reduction 38
disks 33

balancing backup load 43
benchmarks 55
contention 51
data

compression 33
fragmentation 33

evaluating problems 72
file type device usage 50
performance 54, 70, 72
read speed 44, 54–55, 70
testing 33, 35, 54–56

multiple 55–56
NetWorker running 56

tuning 38, 72, 90

E

edition
Business 15
Network 15
Power 16
Workgroup 15

enhancements, RPC 26–27
evaluating

benchmarks 54, 58
CPU 81
disks 72
memory 75

F

file type devices 49–50
configuration 50
disks

contention 51
usage 50

RAID 51
files

defragmentation 38
filesystem boundaries

crossing 37
fragmentation 33

H

high-speed devices 27, 43
See also devices
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I

I/O See input/output
immediate save and recover 26–29
input/output

devices 48
server

backplane 40
SCSI bandwidth 40

Windows filesystem 90

L

load balancing 49
local backup and recover 26, 28
logs, savegrp executions 23

M

media database 19–21
nsrim 20
nsrmmd service 22

memory 39, 42, 73–74
evaluating problems 75
performance 75–76, 78
physical allocation 77
server, usage 90
tuning 76, 78, 90
virtual 76, 90

mt program 45
commands 46–47
count value 45
exit status 45

multiple recoveries 63, 91
multiplexing 20–21, 41–43

N

network
bandwidth 51
input/output 51
load 51
path 51
performance 51
tuning 52

Network Edition
advantages 15
features 16
options 16

NetWorker
backups, how done 21
client file index 19–22
configurations 25
maintaining configuration 20
media database 19–22
older servers 36
overview 19
programs 19
recovery, data 24
services 19
settings 41
testing while running 59–60

nsrck service 20, 22
nsrd service 20–22, 24

ansrd 20
nsrck 20
nsrim 20

nsrexecd service 21–22
nsrim service 20
nsrindexd service 20–22
nsrmmd service 20–22, 24, 29

writing data 22
nsrmmdbd service 20, 22, 24

O

options
bigasm 48
-i 38
mode

recover 37
save 36

mt command 46
overwrite response 38
physical memory allocation 77
proto 36
supported by NetWorker editions 16
uasm 35
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parallelism 22, 41–42
client 41, 44

performance
backups 90
benchmarks

devices 58
disks 54

CPU 79, 81
devices 17, 44–45, 48, 57–60, 70–71, 87
disks 54, 56, 70, 72, 90
evaluating

CPU 81
disks 72
memory 75

factors
hardware 17
network 17
software 18

file type device 49–50
filesystem overhead 90
hardware 17
input/output, server 82
memory 73, 75–76, 78

tuning 90
network 17, 44, 51

tuning 52
overview 17
remote backups 26
RPC enhancements 27
server 17

input/output 82
silos 28
software 18
staging 49–50
stripe sets 38
testing

CPU 79
devices 57–60, 70–71, 87
disks 54–56, 70, 72
memory 73–74
overview 32
server input/output 82

tuning
CPUs 39
devices 48, 87–89

disks 38, 72, 90
file type devices 50
memory 76, 78, 90
network hardware 52
overview 32
settings 42

UNIX-based, overview 53–54
Windows

overview 65
software 90

Performance Monitor
CPU 79, 81
disks 70–72
memory 73–76, 78
overview 65
remote monitoring 68

on Windows 2000 69
on Windows NT 68

server input/output 82
starting

on Windows 2000 67
on Windows NT 66

physical disks See disks
policies

browse 51
retention 51

pools 22, 43
Power Edition

advantages 16
features 16
options 16

programs
backup 24

proto option 36

R

RAID 90
read speed, disks

benchmarks 54–55
testing 33, 35, 44, 54–56

recover mode
uasm program 34

recover program 20–21, 24
recoveries

multiple 63, 91
overview 25
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single file 21
Registry, Windows 84–85
retention policies 51
RPC

enhancements 26–27
save and recover program 20

RPC error message 93

S

save directives
ignoring 36

save mode
uasm program 34

save program 20–22
nsrindexd 20

save sets
backup information 21
multiplexing 20, 43
parallelism 22
staging 49–51

savefs program 21–22
savegrp program 20–23

parallelism 22
SCSI bandwidth 40
server

CPU 43
hardware 33
input/output 40

backplane 40
SCSI bandwidth 40

memory 42
multiplexing 41–42
parallelism 41–42
target sessions 41–43

server input/output 82
service

ansrd 20
backup 24
nsrck 20
nsrd 20
nsrim 20
nsrindexd 20
nsrmmd 20, 22
nsrmmdbd 20

settings
tuning 42

silos 28–29
single file recovery 21
somaxconn 94
SOMAXCONN parameter 94
sominconn 94
staging 49–51
STLI call 29
storage devices See devices
storage nodes 28

with file type devices 50
stripe sets 38
subkey entry, Registry 85
suffix for conflicting filenames 37
symbolic links

limitations 37
System Activity Reporter 60

monitoring
block device activity 61
buffer activity 60

testing CPU utilization 62
system requirements 32

T

target sessions 41–43, 95
TCP/IP 23, 26
testing

controlled 32
CPU 79
devices 44, 57–60, 87
disks 33, 35, 55–56, 70–71
from another computer 68
input/output 82
less controlled 32
memory 73–74
overview 32
See also performance

tuning
backup load 43–44
clients 44
compression 44
CPUs 39
devices 48, 87
disks 38, 43, 72
file type devices 50
memory 76, 78
network hardware 52
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overview 32
parallelism 42

client 44
server 42

recoveries 43
See also performance
settings 42–44
target sessions 42
Windows software 90

U

uasm module 33, 41
syntax 33

uasm program 56
byte count mode 36
compare mode 34
options 35

verbose mode 35
recover mode 34

options 37
save mode 34

options 36
UNIX-based performance

devices 57, 59
benchmarks 58
testing 57–58, 60

disks
benchmarks 54–55
testing 54–56

testing, overview 53–54

V

virtual memory 39
volumes

dividing save sets 43
pools 22, 43

W

Windows-based performance
CPU 79, 81
devices 70–71, 87–89
disks 70, 72
filesystem overhead 90

memory 73–76, 78, 90
counter values 75

operating system 90
Registry

modification 84
subkey entry 85

server input/output 82
testing, overview 65

Workgroup Edition
advantages 15
features 16
options 16

write speed, devices
benchmarks 58
measuring 44
testing 57–60, 70–71
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