deallocate [-s] [-w] [-F] [-z zonename] [-c dev-class | -g dev-type | device]
deallocate [-s] [-w] [-F] [-z zonename] -I
The deallocate command frees an allocated device. It resets the ownership and permissions on all device special files associated with the device, disabling access to that device. deallocate runs the device cleaning program for that device as specified in device_allocate(4).
The default deallocate operation deallocates devices allocated to the user.
The following options are supported:
Deallocates all devices of the specified device class.
Forces deallocation of the device associated with the file specified by device. Only a user with the solaris.device.revoke authorization is permitted to use this option.
Forces deallocation of all allocatable devices. Only a user with the solaris.device.revoke authorization is permitted to use this option. This option should only be used at system initialization.
Silent. Suppresses any diagnostic output.
The following options are supported when the system is configured with Trusted Extensions:
Deallocates a device of device type matching dev-type.
Runs the device cleaning program in a windowing environment. If a windowing version of the program exists, it is used. Otherwise, the standard version is run in a terminal window.
Deallocates device from the zone specified by zonename.
The following exit values are returned:
No entry for the specified device.
An error occurred.
See attributes(5) for descriptions of the following attributes:
The invocation is Uncommitted. The options are Uncommitted. The output is Not-an-Interface.
Controlling Access to Devices
The functionality described in this man page is available only if Solaris Auditing has been enabled. See bsmconv(1M) for more information.
On systems configured with Trusted Extensions, the functionality is enabled by default.