/usr/sbin/lumake [-l error_log] [-o outfile] [-s source_BE] -n BE_name [-X]
/usr/sbin/lumake [-l error_log] -t time [-o outfile] [-s source_BE] -n BE_name [-m email_address] [-X]
The lumake command is part of a suite of commands that make up the Live Upgrade feature of the Solaris operating environment. See live_upgrade(5) for a description of the Live Upgrade feature.
The lumake command populates (that is, copies files to) the file systems of a specified boot environment (BE) by copying files from the corresponding file systems of the active or a source (-s) BE. Any existing data on the target BE are destroyed. All file systems on the target BE are re-created.
The target BE must already exist. Use lucreate(1M) to create a new BE.
The lumake command requires root privileges.
The lumake command has the following options:
Name of the BE to be populated.
The optional name of a source BE. If you omit this option, lumake uses the current BE as the source. A BE must have the status "complete" before you can copy from it. Use lustatus(1M) to determine a BE's status.
Error and status messages are sent to error_log, in addition to where they are sent in your current environment.
All command output is sent to outfile, in addition to where it is sent in your current environment.
Setup a batch job to populate the specified BE at a specified time. The time is given in the format specified by the at(1) man page. At any time, you can have only one Live Upgrade operation scheduled. You can use lucancel(1M) to cancel a scheduled lumake operation.
Allows you to email lumake output to a specified address upon command completion. There is no checking of email_address. Use this option in conjunction with -t, to obtain notification of batch command completion. If you use -m with options other than -t, no email is sent.
Enable XML output. Characteristics of XML are defined in DTD, in /usr/share/lib/xml/dtd/lu_cli.dtd.<num>, where <num> is the version number of the DTD file.
list of BEs on the system
Live Upgrade DTD (see -X option)
See attributes(5) for descriptions of the following attributes:
luactivate(1M), lucancel(1M), lucompare(1M), lucreate(1M), lucurr(1M), ludelete(1M), ludesc(1M), lufslist(1M), lumount(1M), lurename(1M), lustatus(1M), luupgrade(1M), lutab(4), attributes(5), live_upgrade(5)