/usr/sbin/lurename -e BE_name -n new_name [-l error_log] [-o outfile] [-X]
The lurename command is part of a suite of commands that make up the Live Upgrade feature of the Solaris operating environment. See live_upgrade(5) for a description of the Live Upgrade feature.
The lurename command renames the boot environment (BE) BE_name to new_name.
The string new_name must not exceed 30 characters in length and must consist only of alphanumeric characters and other ASCII characters that are not special to the Unix shell. See the “Quoting” section of sh(1). The BE name can contain only single-byte, 8–bit characters. It cannot contain whitespace characters. Also, new_name must be unique on the system.
Renaming a BE is often useful when you upgrade the BE from one Solaris release to another. For example, following an operating system upgrade, you might rename the BE solaris7 to solaris8.
The lurename command requires root privileges.
The lurename command has the options listed below.
Name of the BE whose name you want to change.
Error and status messages are sent to error_log, in addition to where they are sent in your current environment.
New name of the BE. new_name must be unique on a given system.
All command output is sent to outfile, in addition to where it is sent in your current environment.
Enable XML output. Characteristics of XML are defined in DTD, in /usr/share/lib/xml/dtd/lu_cli.dtd.<num>, where <num> is the version number of the DTD file.
list of BEs on the system
Live Upgrade DTD (see -X option)
See attributes(5) for descriptions of the following attributes:
luactivate(1M), lucancel(1M), lucompare(1M), lucreate(1M), lucurr(1M), ludelete(1M), ludesc(1M), lufslist(1M), lumake(1M), lumount(1M), lustatus(1M), luupgrade(1M), lutab(4), attributes(5), live_upgrade(5)