Solaris 10 Installation Guide for IBM BladeCenter Servers

ProcedureHow to Create Options to Support a Solaris Installation (DHCP Manager)

Before You Begin

Perform the following tasks before you create DHCP options for your installation.

  1. On the DHCP server, become superuser or assume an equivalent role.

    Roles contain authorizations and privileged commands. For more information about roles, see Configuring RBAC (Task Map) in System Administration Guide: Security Services.

  2. Start DHCP Manager.

    # /usr/sadm/admin/bin/dhcpmgr &

    The DHCP Manager window is displayed.

  3. Select the Options tab.

  4. Choose Create from the Edit menu.

    The Create Option dialog box opens.

  5. Type the option name for the first option, then type values appropriate for that option.

    Use the output of the add_install_client command , and the information in the tables in this section to check the option names and values for options that you must create. Notice that the vendor client classes are only suggested values. See Table 1–7. Create classes to indicate the actual client types that need to obtain Solaris installation parameters from the DHCP service. See Working With DHCP Options (Task Map) in System Administration Guide: IP Services for information about how to determine a client's vendor client class.

  6. Click OK after you have typed all the values.

  7. In the Options tab, select the option that you just created.

  8. Select Duplicate from the Edit menu.

    The Duplicate Option dialog box opens.

  9. Type the name of another option, then modify other values appropriately.

    The values for code, data type, granularity, and maximum are most likely to need modification. See Table 1–6.

  10. Repeat Step 7 through Step 9 until you have created all the options.

    You can now create macros to pass the options to network installation clients, as explained in the following procedure.

    Note –

    You do not need to add these options to a Solaris client's /etc/dhcp/inittab file because they are already included in that file.