Solaris 10 10/09 Release Notes

Perl Version 5.6.1

Perl version 5.6.1 might not be supported in a future Solaris OS release. Perl version 5.8.4, the default version in the Solaris 10 OS, is not binary compatible with Perl version 5.6.1. However, the earlier version is still retained in this Solaris release. Customized modules that are installed by the customer must be rebuilt and reinstalled to use Perl version 5.8.4. Modify any scripts that require the use of version 5.6.1 to specifically use version 5.6.1 of the interpreter instead of version 5.8.4. The interpreters of the respective Perl versions are located in the following directories:

Perl 5.6.1


Perl 5.8.4

/bin/perl, /usr/bin/perl, or /usr/perl5/bin/perl