Sun Java System Message Queue 4.3 Release Notes

Installation Issues

This section describes issues related to the installation of Message Queue version 4.3.

Product Registry and Java ES

Message Queue 4.3, like Message Queue 4.2 and 4.1, is installed by a relatively new installer, which also installs and upgrades the Java Enterprise System (Java ES) shared components required by Message Queue; for example, JDK, NSS, JavaHelp, and so on.

The new Message Queue installer and the older Java ES installer, which was used to install previous Message Queue versions, do not share the same product registry. If a version of Message Queue that was installed with the Java ES installer is removed and then Message Queue 4.3 is subsequently installed by the Message Queue installer, the Java ES product registry might be in an inconsistent state. As a result, if the Java ES uninstaller is run, it may inadvertently remove Message Queue 4.3 and the shared components upon which it depends, even though it did not install them.

The best way to upgrade Message Queue software that was installed by the Java ES installer is as follows.

  1. Use the Java ES uninstaller to remove Message Queue and its shared components.

  2. Use the Message Queue installer to install Message Queue 4.3.

Installing on All Platforms

These issues affect installation on all platforms.

Installing on Windows

When installing Message Queue on Windows, please note the following limitations.

Installing on Solaris

Installing on Linux

The following issues affect installation on the Linux Platform:

Version Anomalies in the Installer

The installer displays Message Queue version information in an opaque form. (Bug 6586507)

Solaris Platform

On the Solaris platform, refer to the following table to determine the Message Queue version displayed by the installer.

Table 1–11 Version String Translation

Version as Displayed by the Installer on Solaris OS 

Corresponding Message Queue Release 



4.1 Patch 2 

4.1 Patch 1 


3.7 UR2 Patch 1 

3.7 UR2 

3.7 UR1 


3.6 SP4 

3.6 SP3 

3.6 SP2 

3.6 SP1 

Note –

For Patch releases to 3.6 SP4 (for example, 3.6 SP4 Patch 1), the releases string displayed by the installer stays the same. You need to run the command imqbrokerd -version to determine the exact version.

Linux Platform

On the Linux platform, the version number displayed by the installer is in the following form.


For example, 3.7–22. This tells us only that this is one of the 3.7 releases, but not which specific one. To determine the installed Message Queue version, run the command:

imqbrokerd -version.

Localization Issues

The following issues relate to localization problems.