2.2. Client Device Requirements and Support

This section describes the supported platforms and requirements for client devices.

2.2.1. Supported Client Platforms

The following table lists the supported client platforms for the SGD Client. Also included are the supported browsers, and the supported desktop menu systems when the SGD Client is operating in Integrated mode.

Supported Client Platform

Supported Browsers

Integrated Mode Support

Microsoft Windows 7 (32-bit and 64-bit)

Internet Explorer 8

Mozilla Firefox 3

Microsoft Windows Start Menu

Microsoft Windows Vista (32-bit and 64-bit)

Internet Explorer 7

Internet Explorer 8

Mozilla Firefox 3

Microsoft Windows Start Menu

Microsoft Windows XP Professional (32-bit)

Internet Explorer 7

Internet Explorer 8

Mozilla Firefox 3

Microsoft Windows Start Menu

Oracle Solaris on SPARC platforms

At least Oracle Solaris 10 10/09

Mozilla Firefox 3

Java Desktop System Launch Menu

Oracle Solaris on x86 platforms

At least Oracle Solaris 10 10/09

Mozilla Firefox 3

Java Desktop System Launch Menu

Oracle Solaris Trusted Extensions on SPARC platforms

At least Oracle Solaris 10 10/09

Mozilla Firefox 3

Not supported

Oracle Solaris Trusted Extensions on x86 platforms

At least Oracle Solaris 10 10/09

Mozilla Firefox 3

Not supported

Mac OS X 10.6

Safari 5

Safari 4

Mozilla Firefox 3

Not supported

Red Hat Enterprise Linux 5.5 Desktop (32-bit and 64-bit)

Mozilla Firefox 3

Gnome or KDE Start Menu

Ubuntu 10.04 (32-bit and 64-bit)

Mozilla Firefox 3

Gnome Start Menu

The SGD Administration Console is not supported on Safari browsers.

Beta versions or preview releases of browsers are not supported.

Browsers must have the JavaScript™ programming language enabled.

To support the following functionality, browsers must have Java™ technology enabled:

  • Downloading and installing the SGD Client automatically

  • Determining proxy server settings from the user’s default browser

If Java technology is not available, the SGD Client can be downloaded and installed manually. Manual installation is available for all supported client platforms except Mac OS X. On Microsoft Windows platforms, you need administrator privileges to install the SGD Client.

Only Java Plug-in software version 1.6 is supported as a plug-in for Java technology.

Caution

Due to known issues, Java Plug-in software version 1.7 is not supported in this release. Please ensure that any issue you report to Oracle Support can be reproduced using Java Plug-in software version 1.6.

When users start more than one user session using the same client device and browser, the user sessions join rather than the new session ending the existing session. For user sessions to join in this way, the browser must be configured to allow permanent cookies. If permanent cookies are not allowed, user sessions always end and this might cause application windows to disappear.

For best results, client devices must be configured for at least 256 colors.

The SGD Client and webtop are available in the following supported languages:

  • French

  • German

  • Japanese

  • Korean

  • Simplified Chinese

  • Traditional Chinese

2.2.1.1. Virtualization Support

The supported client platforms for SGD are supported on a Type 1 (bare metal) hypervisor or a Type 2 (hosted) hypervisor, for example Oracle VM VirtualBox, VMWare, or Oracle VM Server for SPARC (previously called Sun Logical Domains or LDoms).

2.2.1.2. Retirements to Supported Client Platforms

The following table shows the SGD Client installation platforms, browsers and Java Plugin tools that have been retired.

SGD Version

Platforms No Longer Supported

4.60

Mac OS X 10.5

OpenSolaris (all versions)

Red Hat Enterprise Linux Desktop 5.0 to 5.4

Solaris 10 OS up to, and including, 5/09

Ubuntu 8

Firefox 2

Internet Explorer 6

Safari 2

Safari 3

Java Plugin tool version 1.5

4.50

Fedora Linux 8

Mac OS X 10.4

Microsoft Windows 2000 Professional

Solaris 8 OS

Solaris 9 OS

SUSE Linux Enterprise Desktop 10

Ubuntu 7.04

2.2.2. Supported Proxy Servers

To connect to SGD using a proxy server, the proxy server must support tunneling. You can use HTTP, Secure (SSL) or SOCKS version 5 proxy servers.

For SOCKS version 5 proxy servers, SGD supports the Basic and No Authentication Required authentication methods. No server-side configuration is required.

2.2.3. PDF Printing Support

To be able to use PDF printing, a PDF viewer must be installed on the client device. SGD supports the following PDF viewers by default.

Client Platform

Default PDF Viewer

Microsoft Windows platforms

Adobe Reader, at least version 4.0

Oracle Solaris on SPARC platforms

Adobe Reader (acroread)

GNOME PDF Viewer (gpdf)

Oracle Solaris on x86 platforms

GNOME PDF Viewer (gpdf)

Linux

GNOME PDF Viewer (gpdf)

Evince Document Viewer (evince)

X PDF Reader (xpdf)

Mac OS X

Preview App (/Applications/Preview.app)

Note

The Adobe Reader PDF viewer must support the -openInNewWindow command option. The Preview App PDF viewer must support the open -a command option.

To be able to use a supported PDF viewer, the application must be on the user’s PATH.

Support for alternative PDF viewers can be configured in the user’s client profile.

2.2.4. Supported Smart Cards

SGD works with any Personal Computer/Smart Card (PC/SC)-compliant smart card and reader supported for use with Microsoft Remote Desktop services.