acctprc reads the standard input, in the form described by acct(4) , and converts it to total accounting records (see the tacct record in acct(4) ). acctprc divides CPU time into prime time and non-prime time and determines mean memory size (in memory segment units). acctprc then summarizes the tacct records, according to user IDs, and adds login names corresponding to the user IDs. The summarized records are then written to the standard output. acctprc1 reads input in the form described by acct(4) , adds login names corresponding to user IDs, then writes for each process an ASCII line giving user ID, login name, prime CPU time (tics), non-prime CPU time (tics), and mean memory size (in memory segment units). If ctmp is given, it should contain a list of login sessions sorted by user ID and login name. If this file is not supplied, it obtains login names from the password file, just as acctprc does. The information in ctmp helps it distinguish between different login names that share the same user ID.
From the standard input, acctprc2 reads records in the form written by acctprc1 , summarizes them according to user ID and name, then writes the sorted summaries to the standard output as total accounting records.
The acctprc command is typically used as shown below:
example% acctprc < /var/adm/pacct > ptacct
The acctprc1 and acctprc2s commands are typically used as shown below:
example% acctprc1 ctmp </var/adm/pacct example% acctprc2 > ptacct
See attributes(5) for descriptions of the following attributes:
|ATTRIBUTE TYPE||ATTRIBUTE VALUE|
Although it is possible for acctprc1 to distinguish among login names that share user IDs for commands run from a command line, it is difficult for acctprc1 to make this distinction for commands invoked in other ways. A command run from cron(1M) is an example of where acctprc1 might have difficulty. A more precise conversion can be done using the acctwtmp program in acct(1M) . acctprc does not distinguish between users with identical user IDs.
A memory segment of the mean memory size is a unit of measure for the number of bytes in a logical memory segment on a particular processor.
During a single invocation of any given command, the acctprc , acctprc1 , and acctprc2 commands can process a maximum of
6000 distinct sessions
1000 distinct terminal lines
2000 distinct login names
If at some point the actual number of any one of these items exceeds the maximum, the command will not succeed.