Solaris Common Desktop Environment: User's Guide

Using a Template to Compose a Mail Message

You can save a message as a template for use repeatedly, such as a template for a status report that you send out monthly. The status report template might contain, for example, the addresses, subject, and headings for the message body. You could use that template and fill in the contents before emailing it as a status report every month.

To Create a Template

  1. Choose Templates from the Options menu of the Mail Options dialog box.

    The Templates Options dialog box is displayed.

  2. Click the New Template button.

    A Compose window is displayed.

  3. Type the headers and template body.

  4. Choose Template from the Save As button menu at the bottom of the window, or from the Save As submenu of the File menu.

    The Mailer Save As Template dialog box is displayed.

  5. Type the template name in the text field, and click Save.

    The template is saved in the default directory HomeDirectory/MailTemplates. Its name and path are displayed in the Templates scrolling list.

    You can save an attachment as part of a template. Doing so is equivalent to copying the attachment there. Editing or moving the source of the attachment after it has been included in the template does not affect the attachment in the template.

To Use a Template

  1. From the main window, choose New, Use Template from the Compose menu, then choose the template you would like to use from the submenu.

    The Compose window opens with the template loaded.

    Note -

    If the Compose window is already open, you can load the template by choosing its name from the Use Template submenu of the Format menu in the Compose window.

  2. Edit the headers and body, as necessary, and send the message as usual.

    For more details, See "Editing and Formatting Outgoing Messages".