Solaris 8 (SPARC Platform Edition) 2/04 Release Notes

awk and nawk Field Limitation Might Cause Installation of Additional Software to Fail (4533901)

The 200 field limitation of the awk and nawk utilities might cause installations of additional software to fail. This problem occurs under the following circumstances.

A message similar to the following text displays.

Installing VxVM for Solaris 8
awk: record `Patch: 108528-13 Obs...' has too many fields
 record number 12

        Alternate Pathing (AP) version 2.3.1 has been detected.

        This version of VxVM requires the following patch(es) 
        to co-existwith AP 2.3.1:


        Install the above patch(es) before you continue the VxVM
        installation. This installation will now be aborted.

pkgadd: ERROR: request script did not complete successfully

Installation of <VRTSvxvm> failed.
No changes were made to the system.

Workaround: Contact your support channels to obtain the Solaris patch that increases the awk and nawk field limitation.