Sun Java System Application Server Platform Edition 9 Upgrade and Migration Guide

JAXP and SAX Incompatibilities

Sun Java System Application Server 9 supports JAXP 1.3, which in turn supports SAX 2.0.2. In SAX 2.0.2, DeclHandler.externalEntityDecl requires the parser to return the absolute system identifier for consistency with DTDHandler.unparsedEntityDecl. This might cause some incompatibilities when migrating applications that use SAX 2.0.0.

To migrate an application that uses SAX 2.0.0 to SAX 2.0.2 without changing the previous behavior of externalEntityDecl, you can set the resolve-dtd-uris feature to false. For example:

SAXParserFactory spf = SAXParserFactory.newInstance();

Other incompatibilities between SAX 2.0.0 and SAX 2.0.2 are documented in the JAXP Compatibility Guide.