Sun Java System Connector for Microsoft Outlook 7.2 Administration Guide

ProcedureTo create an end-user desktop installation package

  1. Locate and launch (double-click) the file Admin.exe, in C:\Program Files\Sun\Deployment Configuration Program\, or from a desktop shortcut icon or from the Start program menu.

    The Deployment Configuration Program then opens its Configuration Window on your desktop, as shown in Figure 2–1.

    Figure 2–1 Deployment Configuration Program: Configuration Window

    Deployment Configuration Program: Configuration Window

    The Configuration Window contains:

    • Nine tabbed panels where you will enter the information to characterize an end user’s configuration of the Connector for Microsoft Outlook (described separately below).

    • A Help button, which opens a separate window of information about the entry options available on the currently displayed panel.

    • Three menus: File, Tools and Help.

      The File Menu offers several standard, familiar Windows features for file management: New, Open..., Save, Save As..., Print Setup..., Print..., and Exit.

      The Help Menu offers context-sensitive access to the online help system that accompanies this Deployment Configuration Program.

      The Tools Menu offers a Create Package feature that lets you create a new installation package for an existing .ini configuration file that has been opened into this Configuration Window. You may use File->Open... to locate and open an existing .ini file.

  2. Complete the information in the nine tabbed panels, as described separately (per tab) below. Click on each tab to display the associated panel.

    If you begin creating an installation package but then decide to finish it at a later time, you may File->Save a partially completed package, and then File->Open... it later to resume and complete your work.

  3. When you have entered all of the information requested in all nine tabbed panels, select File->Save to save your configuration choices in an .ini file and create a new installation package. Your Save command activates a standard, familiar Windows Save dialog box.

  4. In the dialog box: Enter an appropriate path and filename for the .ini file and .exe file, and click the Save button.

    The Save command actually creates two new files: the .ini file, which is saved to whatever folder you designate in the Save dialog box, and an .exe file (the bundled installation package, including a copy of the .ini file), which is saved by default to the same folder where the .ini file is saved. Both the .ini and .exe files carry whatever filename you designate in the Save dialog box.


If the program reports a Logon failure or “Could not locate...” a necessary resource while it is running. If you know that the resource exists in the location you have specified, then the administrator account you are using to run this Deployment Configuration Program is not authenticated to the file server where the resource resides. Make sure that you are logged in to the locations of all such resources and then run the Deployment Configuration Program again.