Sun Java Communications Suite 5 Release Notes

Communications Express Compatibility Issues

The following table lists the known incompatibilities between Communications Express 6.3 and earlier versions




The User Interface for creation of a new calendar event has been changed from earlier versions of Communications Express 6.3 release. In this release, when users create new calendar events, the Start Time, and End Time of the event has to be supplied. In previous releases, only the Start Time and Duration had to be supplied (6305790). 


The change has been made only in the User Interface. The behavior of the way events are created is not affected. 

Java Enterprise System (JES) 4 release of Communications Express is incompatible with JES3 version of Messaging Server Multiplexor (6328658). 

A HTTP 502 error is displayed when users log in with valid credentials when Communications Express is upgraded with the JES4 version. 

If you upgrade Communications Express to JES4, you must also upgrade Messaging Server Multiplexor to JES4. 

JES4 release of Communications Express is not compatible with the Communications Suite version 5 version of Messaging Server. This incompatibility is seen in a setup containing a JES4 version of Messaging Server, Communications Express, Calendar Server, and Access Manager are installed on the same machine, if only Messaging Server is upgraded to the Communications Suite 5 version, some functionality in Communications Express is broken (6395931). 

Some of the Communications Express functionality such as compose mail, search, and folder management do not work. 

If Messaging Server is on machine and Webmail, Messaging MultiPlexor, and UWC are on different machines, Messaging Server can be upgraded to Communications Suite 5 version. If you upgrade only Webmail and Messaging Multiplexor without upgrading Communications Express, some of the Communications Express functionality do not work.