Logical Domains 1.3 Release Notes

Required Software and Patches

This section lists the required software and patches for use with LDoms 1.3 software.

Required and Recommended Solaris OS

To use all the features of LDoms 1.3 software, the operating system on all domains should be at least equivalent to the Solaris 10 10/09 OS. This can be either a fresh or upgrade installation of the following:

Note –

The Logical Domains 1.3 software is supported on the OpenSolaris OS starting with the OpenSolaris 2009.06 release. The Logical Domains 1.3 documentation focuses on the use of Logical Domains on the Solaris 10 OS. The same Logical Domains features are available for both the Solaris 10 OS and the OpenSolaris OS. However, you might encounter slight differences when using Logical Domains with the OpenSolaris OS. For more information about the OpenSolaris OS, see the OpenSolaris Information Center.

The following table shows the patches that are required for older releases of the Solaris 10 OS to have the Logical Domains 1.3 functionality. These patches are included in the Solaris 10 10/09 OS.

Table 1–1 Patches for Older OS Versions and Domains Needing a Patch

Patch ID 

Control Domain 

Service-I/O Domain 

Guest Domain 

139946-01 (niumx)


141054-01 (cnex)



141444-09 (Solaris 10 10/09 feature kernel update) 

141514-02 (vntsd)



142055-03 (vlds)


142245-01 (ncp Crypto)

Note –

This patch list includes the minimum required patch revisions. You can install later revisions of the same patch.

Required Software to Enable LDoms 1.3 Features

To enable all the LDoms 1.3 features, you must be running at least Version 7.2.7 of the system firmware on both UltraSPARC T2 based servers and UltraSPARC T2 Plus based servers. For information about the required Solaris OS, see Required and Recommended Solaris OS.

Minimum Version of Software Required

It is possible to run the LDoms 1.3 software along with previous revisions of the other software components. For example, you could have differing versions of the Solaris OS on the various domains in a machine. To take advantage of all features of Logical Domains 1.3, ensure that your logical domains run Solaris 10 10/09. Note that you can run different OS releases in each logical domain on the same system. For those domains that run earlier versions of the OS, you might not have all the features that are available in Logical Domains 1.3. However, an alternate upgrade strategy could be to upgrade the control and service domains to Solaris 10 10/09 or to apply the patches listed in Table 1–1, and to continue running the guest domains at the existing patch level.

Following is a matrix of the minimum versions of software required. The LDoms 1.3 package, SUNWldm, can be applied to a system running at least the following versions of software. The minimum software versions are platform specific and depend on the requirements of the CPU in the machine. The minimum Solaris OS version for a given CPU type applies to all domain types (control, service, I/O, and guest).

Table 1–2 Minimum Versions of Software

Supported Server 

System Firmware  

Solaris OS 

UltraSPARC T2 Plus based servers 


Solaris 10 8/07 plus patch ID 127111-08 at a minimum 

UltraSPARC T2 based servers 


Solaris 10 8/07 

Required System Firmware Patches

To take advantage of all features of Logical Domains 1.3, ensure that your server runs at least these revisions of the following system firmware patches:


Sun SPARC Enterprise T5120 and T5220 Servers


Sun Blade T6320 Server Module


Netra T5220 Server


Sun SPARC Enterprise T5140 and T5240 Servers


Netra T5440 Server


Sun SPARC Enterprise T5440 Server


Sun Blade T6340 Server Module

Location of LDoms 1.3 Software

You can find the LDoms 1.3 software to download at http://www.sun.com/servers/coolthreads/ldoms/index.jsp.

Note –

The Logical Domains 1.3 software no longer comes bundled with SST to provide security services. For more information about SST, see Optional Software.

The LDoms_Manager-1_3.zip file that you download contains the following:

The directory structure of the zip file is similar to the following:


Location of Patches

You can find the required Solaris OS and system firmware patches at the SunSolveSM site:


Location of Documentation

The Logical Domains 1.3 Administration Guide and these Logical Domains 1.3 Release Notes can be obtained from:


The Sun Logical Domains Wiki contains Best Practices, Guidelines, and Recommendations for deploying LDoms software.


The Beginners Guide to LDoms: Understanding and Deploying Logical Domains can be used to get a general overview of Logical Domains software. However, the details of the guide specifically apply to the LDoms 1.0 software release and are now out of date for LDoms 1.3 software. The guide can be found at the Sun BluePrintsTM site.