Solaris 7 5/99 Release Notes (SPARC Platform Edition)

Sun UltraSPARC System (sun4u) May Need Flash PROM (Open Boot) Upgrade

If you want to run the 64-bit Solaris operating environment on an UltraSPARC system, you may need to upgrade its Flash PROM firmware. The Solaris 7 installation programs have a new check box for adding 64-bit support. This new 64-bit support is selected by default when installing on Sun UltraSPARC systems.


Note -

If you choose to run the 32-bit Solaris operating environment on any Sun or UltraSPARC system, the Flash PROM upgrade is not needed.


The following table lists the UltraSPARC (sun4u) systems that are affected and the minimum firmware versions needed. If the system is not listed in the table, it does not need a Boot PROM upgrade. Use uname -i to check the system type. Use prtconf -V to identify the firmware version.

System Type from uname -i

Minimum Fimware Version from prtconf -V

SUNW,Ultra-1-Engine 

3.10.0 

SUNW,Ultra-1 

3.11.1 

SUNW,Ultra-2 

3.11.2 

SUNW,Ultra-4 

3.7.107 

SUNW,Ultra-Enterprise 

3.2.16 


Note -

For instructions on performing the Flash PROM update using the Solaris CD, refer to the Solaris 7 Sun Hardware Platform Guide. If you do not have this manual, it can be obtained at http://docs.sun.com.