Solaris 7 (Intel Platform Edition) 8/99 Release Notes

Errors May Occur During A European Upgrade (4230247, 4225787)

After upgrading from the Solaris 7 3/99 or 5/99 operating environments to the Solaris 7 8/99 operating environment, the following errors may appear in the upgrade logs:

Doing pkgadd of SUNWplow to /.
pkgadd: ERROR: unable to create package object </a/usr/openwin/share/locale/de.ISO8859-15>.
    file type <s> expected <d> actual
    unable to remove existing directory at </a/usr/openwin/share/locale/de.ISO8859-15>
Installation of <SUNWplow> partially failed.
pkgadd return code = 2

Doing pkgadd of SUNWpldte to /.
WARNING: /a/usr/dt/appconfig/types/de.ISO8859-15 
may not overwrite a populated directory.
pkgadd: ERROR: /a/usr/dt/appconfig/types/de.ISO8859-15 could not be installed.
Installation of <SUNWpldte> partially failed.
pkgadd return code = 2

This warning occurs because the patch switches the affected directories listed in the upgrade logs from symbolic links to directories. The upgrade process then attempts to install an updated version of the package that does not include the change. These errors do not affect the operating environment on your system.

Workaround: Ignore these error messages.