Solaris Common Desktop Environment: User's Transition Guide

Chapter 1 Moving from the OpenWindows Environment to Solaris CDE

This chapter helps you to use the CDE environment for the first time if you are already familiar with the OpenWindows environment. It takes you through the CDE login process, and then discusses aspects of the CDE environment.

Where helpful, the difference between OpenWindows behavior and CDE behavior is explained.

This book does not describe CDE in detail. For detailed procedures and descriptions consult Solaris Common Desktop Environment: User's Guide and the CDE online help volumes.

To Log In to CDE for the First Time

  1. Display the login screen on your workstation.

  2. Choose Session from the Options menu.

  3. Select Common Desktop Environment (CDE).

    The CDE logo is displayed on the login screen.

  4. Type your username and click OK.

    Use your standard UNIX username and password. If you previously used OpenWindows, try the username and password you used for that environment, otherwise contact your system administrator.

    The login screen prompts you to enter your password.

  5. Type your password and click OK.

    CDE logs you in and displays the default workspace, the Front Panel, and a welcome message.

    Note -

    For more information on logging in, see "Chapter 2, Starting a Desktop Session" in Solaris Common Desktop Environment: User's Guide.

Now read the following topics and explore the CDE desktop.


Graphical environments such as the CDE and OpenWindows desktops use windows and other objects to represent applications, files, and services available to the user. When you log into CDE, the CDE desktop is displayed.

Figure 1-1 CDE Desktop


CDE Desktop

The CDE desktop comprises a Front Panel sitting over a selected workspace, or screen background. The Front Panel displays information about your workstation, and enables you to run applications, to log out, and to switch between workspaces. Applications that are running are represented by windows and icons on the workspace. As in OpenWindows, a Workspace menu is also available.

Front Panel

The Front Panel (see Figure 1-2) is a collection of frequently used controls and desktop services available in every workspace.

Some Front Panel controls have subpanels associated with them. The subpanels contain related groups of controls. Click the triangle above the Front Panel control to open its subpanel. Click an inverted triangle to close a subpanel.

Controls on the Front Panel enable you to access most applications; applications that do not have a control on the Front Panel can be accessed using Application Manager.

Figure 1-2 Front Panel and Application Manager


Tip -

You can minimize the Front Panel to release space on the desktop.


Workspaces are like separate screens or desktops. You can only display one workspace at a time, but applications in all workspaces can run simultaneously. To display another workspace, you click its button in the workspace switch in the center of the Front Panel.

By default, four workspaces named One through Four are available.

Tip -

You can specify whether an application is displayed on one or all workspaces by clicking mouse button 3 on its window frame and selecting an item from the pop-up menu.

Workspace Menu

When you click mouse button 3 on an unused area of a workspace, the Workspace menu is displayed. It includes items on the Front Panel and Application Manager. Most applications are on the Applications menu (see Figure 1-1).

Applications and Actions

In CDE you run an application by clicking its control on the Front Panel, by double-clicking its icon in Application Manager, or by choosing it from the Workspace menu.

 Task or Feature OpenWindows Method CDE Methods
Run an application from the desktop Choose a menu item on the Workspace menu

Click a control on Front Panel  

Choose a menu item from the Workspace menu 

Double-click an icon in Application Manager 

Add a personal application to Front Panel Not applicable (no Front Panel) Drop a program icon on an Add Icon drop zone on a subpanel
 Run an OpenWindows application Choose a menu item on the Workspace menu Double-click an icon in the OpenWindows folder in Application Manager

You can also run an application by dropping the appropriate file on a drop zone on the Front Panel. For example, dropping a file on the printer icon prints the file.

Tip -

You can also start an application by entering UNIX commands on a command line in a terminal window. To display a terminal window, choose This Host on the Hosts subpanel of the Front Panel.

About Application Manager

Application Manager enables you to organize applications for easy access by storing their icons in special folders. For example, you can launch your OpenWindows applications from icons in the OpenWindows folder (see Figure 1-2).

Working With Files

Like OpenWindows, CDE provides full-functioned File Manager and File Finder applications. The Files subpanel gives you access to these applications and to other file-related devices and applications.

Figure 1-3 Files Subpanel


In File Manager files and folders are represented by icons that indicate their types. Clicking on mouse button 3 displays options for the selected object, and double-clicking an object invokes the default action for that object. For example, double-clicking a compressed file expands it, and double-clicking on an audio file plays it.

 Task or Feature OpenWindows Method CDE Methods
 To find a file In File Manager, choose Find from the File menu Click Find File on the Files subpanel
 To carry out an action on a file Click mouse button 3 and choose from general pop-up menu

Click mouse button 3 on the file and choose from pop-up menu 

Drag and drop the file on an appropriate drop zone 

Click a control on the Files subpanel 

 Print a file Select file in File Manager and choose Print from the File menu Drop a file on the printer control on Front Panel
 Access a floppy diskette or CD-ROM In File Manager, choose Check for Floppy from the File menu Click Open Floppy or Open CD-ROM on the Files subpanel

Deleting Files

Like OpenWindows, CDE provides a trash or wastebasket facility. The Trash Can is a temporary store for objects (files and folders) to be deleted.

You can move selected objects to the Trash Can using drag-and-drop, by mapping certain menu items, or by pressing the Delete key. Once in the Trash Can, the objects no longer appear in their original folder.

In OpenWindows, you are offered the opportunity to empty the wastebasket when you exit File Manager.

To permanently remove the deleted files in CDE, you use the Empty Trash Can control on the Trash subpanel. To permanently remove the deleted files in OpenWindows, you use the Empty Waste button in the Wastebasket application, or you accept an option to empty the wastebasket that is presented when you are exiting File Manager.

Windows and Objects

The appearance and use of windows, icons, dialog boxes, and so on differs slightly between the OpenWindows and CDE environments.

Working with Windows

Application windows have common controls, title areas, and grab handles. Some of these are shown in the following figure.

Figure 1-4 CDE Window Controls


Minimize turns the window into an icon, and Maximize enlarges the window to its largest possible size, that is, the full screen.

In CDE and OpenWindows the verb to close has different meanings: When you close a CDE window, the application is killed; when you close an OpenWindows window, the application is displayed as an icon and continues to run.

Table 1-1 Window Control Comparison
 Task or Feature OpenWindows Method CDE Methods
 Minimize a window Choose Close from Window menu Click the Minimize button
 Expand or enlarge a window Double-click on window frame (expands vertically) Click the Maximize button (window covers entire screen)
 Remove pop-up windows and dialog boxes Click the pushpin

Choose Close or Cancel from the Window menu 

Click the Close or Cancel button in the dialog box 

 Terminate an application Choose Quit from the Window menu Choose Close from the Window menu or Exit from the File menu
 Move a window Grab anywhere on window frame (except the corners) and move Grab the title bar and move

Note -

Do not confuse closing a window with closing a file within an application. For example, when you choose Close from the File menu of a CDE application, the file is closed, but the application window may remain open.

See also "Chapter 1, Basic Skills" in Solaris Common Desktop Environment: User's Guide.

Moving Text and Objects

CDE has a clipboard facility, a drag-and-drop facility, and a duplication facility.


CDE provides a clipboard facility that can handle text and graphics simultaneously. Most CDE applications have an Edit menu that provides the standard clipboard items (Cut, Copy, and Paste). Cut, Copy and Paste are also available through the following key combinations.

Table 1-2 Clipboard Key Comparison
 Task or Feature OpenWindows Keys CDE Keys
 Cut Meta+X, or Cut Alt+X, or Control+Delete, or Cut
 Copy Meta+C, or Copy Alt+C, or Control+Insert, or Copy
 Paste Meta+V, or Paste Alt+V, or Shift+Insert, or Paste

Drag and Drop

As in OpenWindows, in CDE you can drag a selected object or text from one location to another inside the application, or from one application to another. Unlike OpenWindows, CDE does not enable you to drop objects on a minimized program icon, but it enables you to drop objects and text on the Front Panel.

Table 1-3 Drag and Drop Behavior
 Task or Feature OpenWindows Behavior CDE Behavior
 Drop an icon on the workspace Launches application Creates reference to item (original item still appears in File Manager)
 Drop text or files on message area in Mailer Inserts in message body Only supported for Compose window. Inserts text at insertion point and attaches files.
 Drop text or files in Attachments area in Mailer Attaches messages

Attaches files to message being composed 

Attaches dropped text as text file 

 Drop text into text window Text appears at drop point Text appears at insertion point (same as choosing Include from the File menu)
 Drop a file on a minimized application Application runs its default action (such as opening or printing the file) if it is of the appropriate type Not supported

See also "Chapter 1, Basic Skills" in Solaris Common Desktop Environment: User's Guide.

Duplication Button

In OpenWindows, mouse button 2 was referred to as the ADJUST button-because it was used to highlight the text to the right of a position selected by mouse button one. CDE uses mouse button 2 as a useful text duplication button, which is used to duplicate, or make copies of, selected text.

Duplication is faster than copy and paste or drag-and-drop, especially when you want to quickly copy a long file path into File Manager, or when you want to copy commands in a terminal window. The contents of the clipboard are unaffected when duplicating.

To Duplicate Selected Text
  1. Select the required text by holding down mouse button 1 and dragging the cursor over it.

  2. Release mouse button 1.

  3. Point the mouse at the location to which you wish to duplicate the text, and click mouse button 2.

    The text is copied to the new location without removing it from its original location.

  4. (Optional), Repeat step 2 and duplicate the text in other locations.


CDE uses all three mouse buttons (where available) to provide full point-and-click, drag-and-drop, and duplication services, as explained earlier.

In CDE, you use Control+mouse button 1 to select multiple elements in a window; in OpenWindows, you use mouse button 2. For example, use this keyboard-and-mouse combination when selecting multiple files in a File Manager window, or when selecting several messages from the Mailer message header list.

Keyboard Mnemonics and Special Keys

Unlike OpenWindows applications, CDE applications use mnemonics, or memorable key combinations, to enable you to select menu items without using the mouse. Mnemonics for a menu item are indicated by an underlined letter in the menu item name, such as the letter F in the File menu in File Manager. You activate a menu by pressing the Alt key and the underlined key, for example Alt+F to activate the File menu in File Manager.

As with OpenWindows, CDE supports the standard keyboards supplied with SunTM WorkstationsTM. For keyboards on IA-based systems, you need to use special key combinations, such as Control+Alt for the Meta key, to emulate keys not provided.

 Task or Feature OpenWindows Method CDE Method
 To access a menu Point and click

Point and click the mouse. 

Use keyboard mnemonics (Alt+underlined _key)

 To switch the focus from one application window to another Click on the window Click on the window, or press Alt+Tab repeatedly until the window has the focus
 Key mappings OpenWindows defaults CDE defaults (same as OpenWindows defaults)
 Delete key Deletes previous character Deletes next character

User Preferences

Most user preferences are set using the Application Manager - Desktop_Controls application, which is available via the Front Panel.


Startup and Shutdown Preferences

By default CDE saves the current session, or the details of applications running when you log out, and resumes the current session the next time you log in. You can change this and other login behavior by clicking Startup in Style Manager.

Tip -

To customize login time environment settings for the CDE login screen, modify your $HOME/.dtprofile file. (In OpenWindows, you modified your $HOME/.login file or $HOME/.profile file.)

Adding Personal Applications

Preferences for an Application

In a CDE application, preferences that affect only that application are set using the Options or Format menu items on the File or Options menu. In an OpenWindows application, such preferences are set using Properties dialog box, accessed from the Workspace menu.

Color and Font Preferences

Use the Color dialog box in Style Manager to set colors. Use the Font dialog box in Style Manager to set the font size, type, and character group, and to add and delete font groups.

The Style Manager is the CDE equivalent of the OpenWindows Workspace Properties dialog box.

Note -

Be sure you know what you are changing on the desktop as certain color combinations may not give you the best results. For more information see ColorUse, dynamicColor, foregroundColor, shadowPixmaps resources, and the Color Server section in the dtsession(1) or dtstyle(1) man pages located in /usr/dt/man/man1.

Color Flashing

If you are using a workstation that does not use a 24-bit graphics card, running certain applications may result in a phenomenon know as color flashing, where the application appears with incorrect colors while the rest of the desktop appears normal; when given the focus it displays with correct colors but the rest of the desktop does not. This is due to fundamental limitations in the X Windows system.

If you experienced color flashing in OpenWindows, you will probably experience it in CDE. You may be able to avoid color flashing by using the Number of Colors to Use setting, which is available from the Color dialog box in Style Manager.

Keyboard Preferences

CDE supports the default keyboard special key combinations for OpenWindows. However, keyboard settings in OpenWindows will not be preserved in CDE, so you need to make these settings again in CDE. See "Chapter 7, Customizing the Desktop Environment" in Solaris Common Desktop Environment: User's Guide. If you need to make changes to your UNIX® keyboard bindings, refer to "Chapter 10, Using Text Editor" in Solaris Common Desktop Environment: User's Guide.

Mouse Preferences

CDE supports the three-button mouse. To change settings for the mouse, click Mouse in Style Manager. Your mouse defaults should stay the same within CDE. If you want to change your defaults, use the Style Manager Mouse dialog box. In CDE, mouse button order is called handedness.

Printing Preferences

In CDE, printing status and commands are available through the Personal Printers subpanel on the Front Panel. Some tasks relating to printer setup require the system administrator to edit configuration files.

Help and User Documentation

The AnswerBook2(R) control on the Help subpanel contains gives you access to online documentation for Solaris Common Desktop Environment. The online documentation provides hierarchical browsing, full text search, and hypertext links.

You can also consult the help volumes. Help is available when you:

Unlike OpenWindows, the CDE help volumes provide comprehensive indexing, a multi-volume table of contents, printing, and a copy-and-paste facility.