installf informs the system that a pathname not listed in the pkgmap(4) file is being created or modified. It should be invoked before any file modifications have occurred.
When the second synopsis is used, the pathname descriptions will be read from standard input. These descriptions are the same as would be given in the first synopsis but the information is given in the form of a list. The descriptions should be in the form:
pathname [ ftype [ major minor ] [ mode owner group ]]
After all files have been appropriately created and/or modified, installf should be invoked with the -f synopsis to indicate that installation is final. Links will be created at this time and, if attribute information for a pathname was not specified during the original invocation of installf, or was not already stored on the system, the current attribute values for the pathname will be stored. Otherwise, installf verifies that attribute values match those given on the command line, making corrections as necessary. In all cases, the current content information is calculated and stored appropriately.
Class to which installed objects should be associated. Default class is none.
Indicates that installation is complete. This option is used with the final invocation of installf (for all files of a given class).
Instruct installf not to use the $root_path/etc/vfstab file for determining the client's mount points. This option assumes the mount points are correct on the server and it behaves consistently with Solaris 2.5 and earlier releases.
Define the full path name of a directory to use as the root_path. All files, including package system information files, are relocated to a directory tree starting in the specified root_path. The root_path may be specified when installing to a client from a server (for example, /export/root/client1).
Specify an alternative fs_file to map the client's file systems. For example, used in situations where the $root_path/etc/vfstab file is non-existent or unreliable.
Name of package instance with which the pathname should be associated.
Pathname that is being created or modified.
block special device
character special device
a file to be edited upon installation or removal
a standard executable or data file
volatile file (one whose contents are expected to change)
an exclusive directory
The major device number. The field is only specified for block or character special devices.
The minor device number. The field is only specified for block or character special devices.
The octal mode of the file (for example, 0664). A question mark (?) indicates that the mode will be left unchanged, implying that the file already exists on the target machine. This field is not used for linked or symbolically linked files.
The owner of the file (for example, bin or root). The field is limited to 14 characters in length. A question mark (?) indicates that the owner will be left unchanged, implying that the file already exists on the target machine. This field is not used for linked or symbolically linked files.
The group to which the file belongs (for example, bin or sys). The field is limited to 14 characters in length. A question mark (?) indicates that the group will be left unchanged, implying that the file already exists on the target machine. This field is not used for linked or symbolically linked files.
The following example shows the use of installf, invoked from an optional pre-install or post-install script:
#create /dev/xt directory #(needs to be done before drvinstall) installf $PKGINST /dev/xt d 755 root sys || exit 2 majno=`/usr/sbin/drvinstall -m /etc/master.d/xt -d $BASEDIR/data/xt.o -v1.0` || exit 2 i=00 while [ $i -lt $limit ] do for j in 0 1 2 3 4 5 6 7 do echo /dev/xt$i$j c $majno `expr $i ? 8 + $j` 644 root sys | echo /dev/xt$i$j=/dev/xt/$i$j done i=`expr $i + 1` [ $i -le 9 ] && i="0$i" #add leading zero done | installf $PKGINST - || exit 2 # finalized installation, create links installf -f $PKGINST || exit 2
See attributes(5) for descriptions of the following attributes:
|ATTRIBUTE TYPE||ATTRIBUTE VALUE|
When ftype is specified, all applicable fields, as shown below, must be defined:
|p, x, d, f, v, or e||mode owner group|
|c or b||major minor mode owner group|
The installf command will create directories, named pipes and special devices on the original invocation. Links are created when installf is invoked with the -f option to indicate installation is complete.
Links should be specified as path1=path2. path1 indicates the destination and path2 indicates the source file.
Files installed with installf will be placed in the class none, unless a class is defined with the command. Subsequently, they will be removed when the associated package is deleted. If this file should not be deleted at the same time as the package, be certain to assign it to a class which is ignored at removal time. If special action is required for the file before removal, a class must be defined with the command and an appropriate class action script delivered with the package.
When classes are used, installf must be used in one of the following forms:
installf -c class1 ... installf -f -c class1 ... installf -c class2 ... installf -f -c class2 ...