The lustatus command is part of a suite of commands that make up the Live Upgrade feature of the Solaris operating environment. See live_upgrade(5) for a description of the Live Upgrade feature.
The lustatus command displays the status information of the boot environment (BE) BE_name. If no BE is specified, the status information for all BEs on the system is displayed.
The headings in the lustatus information display are described as follows:
Name of the BE.
Indicates whether a BE is able to be booted. Any current activity or failure in an lucreate() or luupgrade(1M) operation causes a BE to be incomplete. For example, if there is a copy operation proceeding on or scheduled for a BE, that BE is considered incomplete.
Indicates whether the BE is currently active. The "active" BE is the one currently booted.
Indicates whether the BE becomes active upon next reboot of the system.
Indicates whether the creation or repopulation of a BE is scheduled or active (that is, in progress). A status of ACTIVE, COMPARING (from lucompare(1M)), UPGRADING, or SCHEDULED prevents you performing Live Upgrade copy, rename, or upgrade operations.
The following is an example lustatus display:
BE_name Complete Active ActiveOnReboot CopyStatus ------------------------------------------------------------------------ disk_a_S7 yes yes yes - disk_b_S7database yes no no UPGRADING disk_b_S8 no no no -
Note that you could not perform copy, rename, or upgrade operations on disk_b_S8, because it is not complete, nor on disk_b_S7database, because a Live Upgrade operation is pending.
The lustatus command requires root privileges.
The lustatus command has the following options:
Error and status messages are sent to error_log, in addition to where they are sent in your current environment.
All command output is sent to outfile, in addition to where it is sent in your current environment.
Enable XML output. Characteristics of XML are defined in DTD, in /usr/share/lib/xml/dtd/lu_cli.dtd.<num>, where <num> is the version number of the DTD file.
Name of the BE for which to obtain status. If BE_name is omitted, lustatus displays status for all BEs in the system.
list of BEs on the system
Live Upgrade DTD (see -X option)
See attributes(5) for descriptions of the following attributes:
|ATTRIBUTE TYPE||ATTRIBUTE VALUE|
lu(1M), luactivate(1M), lucancel(1M), lucompare(1M), lucreate(1M), lucurr(1M), ludesc(1M), ludelete(1M), lufslist(1M), lumake(1M), lumount(1M), lurename(1M), luupgrade(1M), lutab(4), attributes(5), live_upgrade(5)