The reboot utility restarts the kernel. The kernel is loaded into memory by the PROM monitor, which transfers control to the loaded kernel.
The reboot utility normally logs the reboot to the system log daemon, syslogd(1M), and places a shutdown record in the login accounting file /var/adm/wtmpx. These actions are inhibited if the -n or -q options are present.
Normally, the system reboots itself at power-up or after crashes.
Force a system crash dump before rebooting. See dumpadm(1M) for information on configuring system crash dumps.
Suppress sending a message to the system log daemon, syslogd(1M) about who executed reboot.
Avoid calling sync(2) and do not log the reboot to syslogd(1M) or to /var/adm/wtmpx. The kernel still attempts to sync filesystems prior to reboot, except if the -d option is also present. If -d is used with -n, the kernel does not attempt to sync filesystems.
Quick. Reboot quickly and ungracefully, without shutting down running processes first.
An optional boot_arguments string can be used to specify arguments to the uadmin(2) function that will be passed to the boot program and kernel upon restart. The form and list of arguments is described in the boot(1M) and kernel(1M) man pages. If multiple arguments are specified, they must be quoted for the shell, as shown in the EXAMPLES section. If the boot_arguments begin with a hyphen, they must be preceded by the -- delimiter (two hyphens) to denote the end of the reboot argument list.
In the following example, the delimiter `--' (two hyphens) must be used to separate the options of reboot from the arguments of boot(1M).
example# reboot -dl -- -rv
The following example reboots using a specific disk and kernel. Note that multiple boot arguments are quoted.
example# reboot "disk1 kernel.test/unix"
See attributes(5) for descriptions of the following attributes:
|ATTRIBUTE TYPE||ATTRIBUTE VALUE|
The reboot utility does not execute the scripts in /etc/rcnum.d or execute shutdown actions in inittab(4). To ensure a complete shutdown of system services, use shutdown(1M) or init(1M) to reboot a Solaris system.