#include <signal.h>int raise(int sig);
The raise() function sends the signal sig to the executing program. It uses the kill() function to send the signal to the executing program, as follows:
Upon successful completion, 0 is returned. Otherwise, -1 is returned and errno is set to indicate the error.
See attributes(5) for descriptions of the following attributes:
|ATTRIBUTE TYPE||ATTRIBUTE VALUE|