The mailstats utility prints out the statistics collected by the sendmail(1M) program on mailer usage. These statistics are collected if the file indicated by the StatusFile configuration option of sendmail (defined in /etc/mail/sendmail.cf) exists. The default statistics file is /etc/mail/statistics.
To enable mailstats, you must, as root, touch /etc/mail/statistics. See the StatusFile processing option in sendmail(1M).
mailstats first prints the time that the statistics file was created and the last time it was modified. Then, the statistics for each mailer are displayed on a single line, each with the following whitespace-separated fields:
The mailer number.
Number of messages from the mailer.
Kbytes from the mailer.
Number of messages to the mailer.
Kbytes to the mailer.
Number of messages rejected by the mailer.
Number of messages discarded by the mailer.
The name of the mailer.
After this display, a line totaling the values for all of the mailers is displayed, separated from the previous information by a line containing only equal sign (=) characters.
To reinitialize the statistics file once a night, add an entry to root's crontab(1):
mailstats -p > /dev/null
The following options are supported:
Tries to use submit.cf instead of the default sendmail configuration file.
Specifies a sendmail configuration file.
Specifies a sendmail statistics file.
Does not display the name of the mailer in the output.
Outputs information in program-readable mode and clear statistics.
Outputs information in program-readable mode without clearing statistics.
See largefile(5) for the description of the behavior of mailstats when encountering files greater than or equal to 2 Gbyte ( 231 bytes).
default sendmail statistics file
default sendmail configuration file
See attributes(5) for descriptions of the following attributes:
|ATTRIBUTE TYPE||ATTRIBUTE VALUE|