The pargs utility examines a target process or process core file and prints arguments, environment variables and values, or the process auxiliary vector.
pargs outputs unprintable characters as escaped octal in the format \xxx, unless the character is one of the characters specified in the "Escape Sequences" section of formats(5), in which case the character is printed as specified in that section.
pargs attempts to be sensitive to the locale of the target process. If the target process and the pargs process do not share a common character encoding, pargs attempts to employ the iconv(3C) facility to generate a printable version of the extracted strings. In the event that such a conversion is impossible, strings are displayed as 7-bit ASCII.
The following options are supported:
Prints process arguments as contained in argv (default).
Treats strings in the target process as though they were encoded in 7-bit ASCII, regardless of the locale of the target. The use of iconv(3C) is suppressed.
Prints process environment variables and values as pointed at by the _environ symbol or by pr_envp in /proc/pid/psinfo.
Force. Grabs the target process even if another process has control.
Prints process auxiliary vector.
The following exit values are returned:
An error has occurred (such as no such process, permission denied, or invalid option).
See attributes(5) for descriptions of the following attributes:
|ATTRIBUTE TYPE||ATTRIBUTE VALUE|