The rcp command copies files between machines. Each filename or directory argument is either a remote file name of the form:
or a local file name (containing no ":" (colon) characters, or "/" (backslash) before any ":" (colon) characters).
The hostname can be an IPv4 or IPv6 address string. See inet(7P) and inet6(7P). Since IPv6 addresses already contain colons, the hostname should be enclosed in a pair of square brackets when an IPv6 address is used. Otherwise, the first occurrence of a colon can be interpreted as the separator between hostname and path. For example,
If a filename is not a full path name, it is interpreted relative to your home directory on hostname. A path on a remote host may be quoted using \ , " , or ' , so that the metacharacters are interpreted remotely.
rcp does not prompt for passwords; your current local user name must exist on hostname and allow remote command execution by rsh(1).
rcp handles third party copies, where neither source nor target files are on the current machine. Hostnames may also take the form
to use username rather than your current local user name as the user name on the remote host. rcp also supports Internet domain addressing of the remote host, so that:
specifies the username to be used, the hostname, and the domain in which that host resides. File names that are not full path names will be interpreted relative to the home directory of the user named username, on the remote host.
The following options are supported:
Attempts to give each copy the same modification times, access times, modes, and ACLs if applicable as the original file.
Copies each subtree rooted at filename; in this case the destination must be a directory.
See largefile(5) for the description of the behavior of rcp when encountering files greater than or equal to 2 Gbyte ( 231 bytes).
The rcp command is IPv6–enabled. See ip6(7P).
See attributes(5) for descriptions of the following attributes:
|ATTRIBUTE TYPE||ATTRIBUTE VALUE|
rcp is meant to copy between different hosts. Attempting to rcp a file onto itself, as with:
example% rcp tmp/file myhost:/tmp/file
results in a severely corrupted file.
rcp may not correctly fail when the target of a copy is a file instead of a directory.
rcp can become confused by output generated by commands in a $HOME/.profile on the remote host.
rcp requires that the source host have permission to execute commands on the remote host when doing third-party copies.
If you forget to quote metacharacters intended for the remote host, you will get an incomprehensible error message.
rcp will fail if you copy ACLs to a file system that does not support ACLs.
rcp is CSI-enabled except for the handling of username, hostname, and domain.