The smart2cfg utility issues controller-specific ioctls to the Compaq Smart-2 EISA/PCI and Smart-2SL PCI array controller using the smartii(7D) driver.
smart2cfg provides information about the Smart-2 and Smart-2SL controllers installed on the system, the Logical and Physical drives as well as the details of the ReadWrite cache present on each controller. The utility is text based and is driven by command line arguments. smart2cfg and the smartii(7D) driver communicate using ioctls. smart2cfg also supports multiple commands.
The following options are supported:
Prints cache details of the cache on controller controller_num.
Prints details of all the physical disks, all the logical drives, and the cache on controller controller_num.
Provides on-line help for the smart2cfg utility.
Prints logical drive details of the drive logical_drive_num on controller controller_num.
Prints physical drive details of the disk physical_drive_num on bus bus_num on controller controller_num.
To provide details of the physical disk with SCSI ID 0, on Bus 0, on controller 0:
example% smart2cfg -p -0 0 0
To provide logical drive details of logical drive 0 on controller 0:
example% smart2cfg -l 0 0
To provide cache details of controller 0:
example% smart2cfg -c 0
To provide information on all physical disks, logical drives, and cache on controller 0:
To provide details of the disk with SCSI ID 0, on Bus 0, on controller 0, and logical drive details of logical drive 0 on controller 1:
example% smart2cfg -p 0 0 0 -l 0 1
See attributes(5) for descriptions of the following attributes:
|ATTRIBUTE TYPE||ATTRIBUTE VALUE|
If the controller is not specified, the first controller is taken as default.