The type utility indicates how each name operand would be interpreted if used as a command. type displays information about each operand identifying the operand as a shell built-in, function, alias, hashed command, or keyword, and where applicable, may display the operand's path name.
There is also a shell built-in version of type that is similar to the type utility.
See environ(5) for descriptions of the following environment variables that affect the execution of type: LANG, LC_ALL, LC_CTYPE, LC_MESSAGES, and NLSPATH.
Determine the location of name.
See attributes(5) for descriptions of the following attributes:
|ATTRIBUTE TYPE||ATTRIBUTE VALUE|