mountall is used to mount file systems specified in a file system table. The file system table must be in vfstab(4) format. If no file_system_table is specified, /etc/vfstab is used. If - is specified as file_system_table, mountall reads the file system table from the standard input. mountall mounts only those file systems with the mount at boot field set to yes in the file_system_table.
For each file system in the file system table, the following logic is executed: if there exists a file/usr/lib/fs/FSType/fsckall, where FSType is the type of the file system, save that file system in a list to be passed later, and all at once, as arguments to the /usr/lib/fs/FSType/fsckall script. The /usr/lib/fs/FSType/fsckall script checks all of the file systems in its argument list to determine whether they can be safely mounted. If no /usr/lib/fs/FSType/fsckall script exists for the FSType of the file system, the file system is individually checked using fsck(1M). If the file system does not appear mountable, it is fixed using fsck before the mount is attempted. File systems with a - entry in the fsckdev field are mounted without first being checked.
umountall causes all mounted file systems except root, /usr, /var, /var/adm, /var/run, /proc, and /dev/fd to be unmounted. If the FSType is specified, mountall and umountall limit their actions to the FSType specified. There is no guarantee that umountall unmounts busy file systems, even if the -k option is specified.
The following options are supported:
Specify the FSType of the file system to be mounted or unmounted.
Unmount all file systems listed in /etc/mnttab that are remote-mounted from host.
Use the fuser -k mount-point command. See the fuser(1M) for details.
The -k option sends the
SIGKILL signal to each process using the file. As this option spawns kills for each process, the kill messages might not show up immediately. There is no guarantee that umountall unmounts busy file systems, even if the -k option is specified.
Limit the action to local file systems.
Limit the action to remote file system types.
Do not perform the umount operation in parallel.
Mounted file system table
Table of file system defaults
Script called by mountall to perform the file system check of all file systems of type FSType
See attributes(5) for descriptions of the following attributes:
|ATTRIBUTE TYPE||ATTRIBUTE VALUE|
No messages are printed if the file systems are mountable and clean.