The sppptun utility is used to configure and query the Solaris PPP tunneling device driver, /dev/sppptun. Currently, only PPP over Ethernet (PPPoE) is supported, so the plumb and unplumb arguments are used to specify Ethernet interfaces that are to be used for PPPoE, and the query option lists the plumbed interfaces.
The use of sppptun to add interfaces is similar to the use of ifconfig(1M) to add interfaces to IP. The plumbing is done once for each interface, preferably at system start-up time, and is not normally manipulated on a running system. If multiple instances of PPP are run over a single interface, they share the plumbing to that interface. Plumbing for each session is not required (and not possible for PPPoE).
The proper way to plumb interfaces for PPPoE is to list the interfaces, one per line, in the /etc/ppp/pppoe.if file.
When specified with no additional arguments, the plumb argument lists the protocols that are supported by the utility. These are the strings that are used as the protocol argument below.
This plumbs a new interface into the driver. The protocol parameter is pppoe for the PPP-carrying "Session Stage" connection or pppoed for the PPPoE "Discovery Stage" connection. Both connections must be present for each Ethernet interface that is to be used for PPPoE. The device parameter is the path name of the Ethernet interface to use (use ifconfig(1M) to list available devices). If the path begins with /dev/, then this portion may be omitted.
This removes an existing interface from the driver and terminates any PPP sessions that were using the interface. The interface parameter is the name of the interface as reported when the interface was plumbed.
Displays the canonical names of all interfaces plumbed into the /dev/sppptun device driver.
# sppptun plumb pppoed hme0 hme0:pppoed # sppptun plumb pppoe hme0 hme0:pppoe
Remove the hme0 interface.
# sppptun unplumb hme0:pppoed # sppptun unplumb hme0:pppoe
#!/bin/sh for intf in `sppptun query` do sppptun unplumb $intf done
list of Ethernet interfaces to be plumbed at boot time
Solaris PPP tunneling device driver
See attributes(5) for descriptions of the following attributes:
|ATTRIBUTE TYPE||ATTRIBUTE VALUE|
RFC 2516, Method for Transmitting PPP Over Ethernet (PPPoE), Mamakos et al, February 1999