The elx Ethernet driver is a multi-threaded, loadable, clonable, STREAMS hardware driver supporting the connectionless Data Link Provider Interface, dlpi(7P), over the following 3COM ETHERLINK III Ethernet controllers. For IA based systems: 3C509, 3C509B, 3C579 and 3C59x controllers. Multiple EtherLink III controllers installed within the system are supported by the driver. The elx driver provides basic support for the EtherLink III hardware. Functions include chip initialization, frame transmit and receive, multicast and “promiscuous” support, and error recovery and reporting.
The cloning, character-special device /dev/elx is used to access all EtherLink III devices installed within the system.
The elx driver is dependent on /kernel/misc/gld, a loadable kernel module that provides the elx driver with the DLPI and STREAMS functionality required of a LAN driver. See gld(7D) for more details on the primatives supported by the driver.
The values returned by the driver in the DL_INFO_ACK primitive in response to the DL_INFO_REQ from the user are as follows:
The maximum SDU is 1500 (ETHERMTU).
The minimum SDU is 0. The driver will pad to the mandatory 60-octet minimum packet size.
The dlsap address length is 8.
The MAC type is DL_ETHER.
The sap length value is -2, meaning the physical address component is followed immediately by a 2-byte sap component within the DLSAP address.
The broadcast address value is Ethernet/IEEE broadcast address (FF:FF:FF:FF:FF:FF).
special character device
configuration file for elx driver
See attributes(5) for descriptions of the following attributes:
|ATTRIBUTE TYPE||ATTRIBUTE VALUE|