This module implements Blowfish, a cipher developed by Bruce Schneier, for IPsec. The encrbfsh module uses cipher-block chaining (“CBC”) pursuant to RFC 2451. This module has the following properties:
32 to 448 bits. Keys are encoded internally as 448–bit quantities. A smaller key size will repeat its pattern until 448 bits are reached.
See attributes(5) for descriptions of the following attributes:
|ATTRIBUTE TYPE||ATTRIBUTE VALUE|
Pereira, R. and Adams, R., RFC 2451, The ESP CBC-Mode Cipher Algorithms, The Internet Society, 1998.
Schneier, B., Applied Cryptography: Protocols, Algorithms, and Source Code in C. Second ed. New York, New York: John Wiley & Sons, 1996.