The usb_mid driver is a USBA (Solaris Universal Serial Bus Architecture) compliant nexus driver that binds to device level nodes of a composite (multi interface) device if no vendor or class specific driver is available. The usb_mid driver attempts to bind drivers to each of the composite device's interfaces.
See attributes(5) for descriptions of the following attributes:
|ATTRIBUTE TYPE||ATTRIBUTE VALUE|
Universal Serial Bus Specification 1.0 and 1.1
System Administration Guide: Basic Administration
In addition to being logged, the following messages may appear on the system console. All messages are formatted in the following manner:
Warning: <device path> (usb_mid<instance number>): Error Message...
This device has been disconnected because a device other than the original one has been inserted. The driver informs you of this fact by displaying the name of the original device.
Same condition as described above; however in this case, the driver is unable to identify the original device with a name string.