The arp program displays and modifies the Internet-to-Ethernet address translation tables used by the address resolution protocol (see arp(7P)).
With no flags, the program displays the current ARP entry for hostname. The host may be specified by name or by number, using Internet dot notation.
Mapping; only used for the multicast entry for 22.214.171.124
Publish; includes IP address for the machine and the addresses that have explicitly been added by the -s option. ARP will respond to ARP requests for this address.
Static; not learned for the ARP protocol.
Unresolved; waiting for ARP response.
You can use the -n option with the -a option to disable the automatic numeric IP address-to-name translation. Use arp -an or arp -na to display numeric IP addresses.
Delete an entry for the host called hostname. This option may only be used by the super-user.
hostname ether_address [temp] [pub] [trail]
See the -s option for argument definitions.
Create an ARP entry for the host called hostname with the Ethernet address ether_address. The Ethernet address is given as six hexadecimal bytes separated by colons. The entry will be permanent unless the word temp is given in the command. If the word pub is given, the entry will be published. For instance, this system will respond to ARP requests for hostname even though the hostname is not its own. The word trail indicates that trailer encapsulations may be sent to this host. arp -s can be used for a limited form of proxy ARP when a host on one of the directly attached networks is not physically present on the subnet. Another machine can then be configured to respond to ARP requests using arp -s. This is useful in certain SLIP configurations.
See attributes(5) for descriptions of the following attributes:
|ATTRIBUTE TYPE||ATTRIBUTE VALUE|