devfsadm(1M) is now the preferred command for /dev and /devices and should be used instead of drvconfig.
The default operation of drvconfig is to create the /devices directory tree that describes, in the filesystem namespace, the hardware layout of a particular machine. Hardware devices present on the machine and powered on as well as pseudo-drivers are represented under /devices. Normally this command is run automatically after a new driver has been installed (with add_drv(1M)) and the system has been rebooted.
drvconfig reads the /etc/minor_perm file to obtain permission information and applies the permissions only to nodes that it has just created. It does not change permissions on already existing nodes. The format of the /etc/minor_perm file is as follows:
minor_name may be the actual name of the minor node, or contain shell metacharacters to represent several minor nodes (see sh(1)).
sd:* 0640 root sys zs:[a-z],cu 0600 uucp uucp mm:kmem 0640 root bin
The first line sets all devices exported by the sd node to 0640 permissions, owned by root, with group sys. In the second line, devices such as a,cu and z,cu exported by the zs driver are set to 0600 permission, owned by uucp, with group uucp. In the third line the kmem device exported by the mm driver is set to 0640 permission, owned by root, with group bin.
The following options are supported:
Add the name alias_name to the list of aliases that this driver is known by. This option, if used, must be used with the -m major_num, the -b and the -i drivername options.
Add a new major number to name binding into the kernel's internal name_to_major tables. This option is not normally used directly, but is used by other utilities such as add_drv(1M). Use of the -b option requires that -i and -m be used also. No /devices entries are created.
The driver being added to the system exports the class class_name. This option is not normally used directly, but is used by other utilities. It is only effective when used with the -b option.
Specify the major number major_num for this driver to add to the kernel's name_to_major binding tables.
Do not try to load and attach any drivers, or if the -i option is given, do not try to attach the driver named drivername.
Build the device tree under the directory specified by rootdir instead of the default /devices directory.
Device nodes directory
Minor mode permissions
Major number binding
Driver class binding file
See attributes(5) for descriptions of the following attributes:
|ATTRIBUTE TYPE||ATTRIBUTE VALUE|
This document does not constitute an API. /etc/minor_perm, /etc/name_to_major, /etc/driver_classes, and /devices may not exist or may have different contents or interpretations in a future release. The existence of this notice does not imply that any other documentation that lacks this notice constitutes an API.