fsirand installs random inode generation numbers on all the inodes on device special, and also installs a file system ID in the superblock. This helps increase the security of file systems exported by NFS.
fsirand must be used only on an unmounted file system that has been checked with fsck(1M) The only exception is that it can be used on the root file system in single-user mode, if the system is immediately re-booted afterwards.
See largefile(5) for the description of the behavior of fsirand when encountering files greater than or equal to 2 Gbyte ( 231 bytes).
See attributes(5) for descriptions of the following attributes:
|ATTRIBUTE TYPE||ATTRIBUTE VALUE|