The operating system image, or kernel, is the collection of software comprising the image files (unix and genunix) and the modules loaded at any instant in time. The system will not function without a kernel to control it.
The kernel is loaded by the boot(1M) command in a machine-specific way. The kernel may be loaded from disk, CD-ROM, or DVD (diskfull boot) or over the network (diskless boot). In either case, the directories under /platform and /kernel must be readable and must contain executable code which is able to perform the required kernel service. If the -a flag is given, the user is able to supply different pathnames for the default locations of the kernel and modules. See boot(1M) for more information on loading a specific kernel.
If the kernel name is not explicitly specified, then on systems capable of supporting the 64-bit kernel, the boot program will attempt to load the 64-bit kernel in preference to the 32-bit kernel by default. See boot(1m).
The moddir variable contains a colon-separated list of directories that the kernel searches for modules. moddir can be set in the /etc/system file. The minimal default is /platform/platform-name/kernel:/kernel:/usr/kernel, but this default can be overridden by a specific platform. It is common for many systems to override the default path with:
The kernel configuration can be controlled using the /etc/system file (see system(4)).
genunix is the platform-independent component of the base kernel.
The following options are supported:
Asks the user for configuration information, such as where to find the system file, where to mount root, and even override the name of the kernel itself. Default responses will be contained in square brackets ([ ]), and the user may simply enter RETURN to use the default response (note that RETURN is labeled ENTER on some keyboards). To help repair a damaged /etc/system file, enter /dev/null at the prompt that asks for the pathname of the system configuration file. See system(4).
Causes Autoclient systems to flush and reinitialize the client system's local cache. This flag is ignored for all non-Autoclient systems.
Reconfiguration boot. The system will probe all attached hardware devices and assign nodes in the file system to represent only those devices actually found. It will also configure the logical namespace in /dev as well as the physical namespace in /devices. See add_drv(1M) and rem_drv(1M) for additional information about maintaining device drivers.
Boots only to init level 's'. See init(1M).
Boots with verbose messages enabled. If this flag is not given, the messages are still printed, but the output is directed to the system logfile. See syslogd(1M).
Does not boot in clustered mode. This option only has an effect when a version of Sun Cluster software that supports this option has been installed.
See boot(1M) for examples and instructions on how to boot.
Contains kernel components common to all platforms within a particular instruction set that are needed for booting the system. of the core image file.
The platform-specific kernel components.
The kernel components specific to this hardware class.
Contains kernel components common to all platforms within a particular instruction set.
The directories in this section can potentially contain the following subdirectories:
Loadable device drivers
The modules that execute programs stored in various file formats.
File system modules
Miscellaneous system-related modules
Operating system schedulers
System V STREAMS loadable modules
Loadable system calls
Processor specific modules
Time-Of-Day hardware interface modules
Additionally, some of the subdirectories mentioned above contain sparcv9 subdirectories that contain 64-bit versions of the same module classes. For example, /kernel/drv/sparcv9 and /platform/sun4u/kernel/cpu/sparcv9.
See attributes(5) for descriptions of the following attributes:
|ATTRIBUTE TYPE||ATTRIBUTE VALUE|
The kernel gives various warnings and error messages. If the kernel detects an unrecoverable fault, it will panic or halt.
Bugs in the kernel often result in kernel panics.
Reconfiguration boot does not currently remove filesystem entries for devices that have been physically removed from the system.