rpc.smserverd is a server that handles requests from client applications, including the Volume Management daemon (vold(1M)), for access to removable media devices. In addition to vold, rmformat(1) and the CDE Filemanager (when performing removable media operations) are rpc.smserverd clients. The rpc.smserverd daemon is started by inetd(1M) when a client makes a call to a Solaris-internal library to access a SCSI, IDE, or USB device. The daemon is not started if a client attempts to access a floppy or PCMCIA device. Once started, the daemon remains active until such time as it is idle for three minutes or more.
The rpc.smserverd daemon is provided for the exclusive use of the client applications mentioned above. It has no external, customer-accessible interfaces, including no configuration file.
See attributes(5) for descriptions of the following attributes:
|ATTRIBUTE TYPE||ATTRIBUTE VALUE|