soladdapp adds an application to the Solstice application registry. After it is added, the application is displayed in the Solstice Launcher main window (see solstice(1M)).
Define the full path name of the Solstice registry file.
Define the name of the tool to be registered.
Define the full path name of the tool icon.
Define the full path name of the tool.
Specify any arguments to use with the tool.
When executed without options, soladdapp uses /opt/SUNWadm/etc/.solstice_registry (the default registry path).
The following adds an application called Disk Manager to the Solstice application registry for display in the Solstice Launcher main window.
# soladdapp -r /opt/SUNWadm/etc/.solstice_registry -n "Disk Manager" -i /opt/SUNWdsk/etc/diskmgr.xpm -e /opt/SUNWdsk/bin/diskmgr
See attributes(5) for descriptions of the following attributes:
|ATTRIBUTE TYPE||ATTRIBUTE VALUE|
Globally registered applications are used by local and remote users sharing the software in a particular /opt directory. They can be added only using soladdapp.