The sys-unconfig command is used to restore a system's configuration to an “as-manufactured” state, ready to be reconfigured again. The system's configuration consists of hostname, Network Information Service (NIS) domain name, timezone, IP address, IP subnet mask, and root password. This operation is the inverse of those performed by the sysidnet(1M), sysidns(1M), and sysidsys(1M) programs run at boot. See sysidtool(1M).
Saves current /etc/inet/hosts file information in /etc/inet/hosts.saved.
If the current /etc/vfstab file contains NFS mount entries, saves the /etc/vfstab file to /etc/vfstab.orig.
Restores the default /etc/inet/hosts file.
Removes the default hostname in /etc/hostname.interface files for all interfaces configured when this command is run. To determine which interfaces are configured, run the command 'ifconfig-a'. The /etc/hostname.interface files corresponding to all of the interfaces listed in the resulting output, with the exception of the loopback interface (lo0), will be removed.
Removes the default domainname in /etc/defaultdomain.
Restores the timezone to PST8PDT in /etc/TIMEZONE.
Disables the Network Information Service (NIS) and Network Information Service Plus (NIS+) if either NIS or NIS+ was configured.
Removes the entries for this host in /etc/net/*/hosts.
Removes the file /etc/inet/netmasks.
Removes the file /etc/defaultrouter.
Removes the password set for root in /etc/shadow.
Removes the file /etc/.rootkey.
Executes all system configuration applications. These applications are defined by prior executions of a sysidconfig -a application. (See sysidconfig(1M)). When sys-unconfig is run, all system configuration applications are passed one argument, -u.
Removes the file /etc/resolv.conf.
Disables LDAP by removing /var/ldap/ldap_client_cache, /var/ldap/ldap_client_file, /var/ldap/ldap_client_cred, and /var/ldap/cachemgr.log.
When sys-unconfig is finished, it performs a system shutdown. sys-unconfig is a potentially dangerous utility and can only be run by the super user.
process control initialization
host name database
network mask database
super-user's secret key
shadow password file
virtual file system table
See attributes(5) for descriptions of the following attributes:
|ATTRIBUTE TYPE||ATTRIBUTE VALUE|
sys-unconfig is not available on diskless clients.