The ttyadm command is an administrative command that formats ttymon(1M)-specific information and writes it to standard output. The Service Access Facility (SAF) requires each port monitor to provide such a command. Note that the port monitor administrative file is updated by the Service Access Controller's administrative commands, sacadm(1M) and pmadm(1M). ttyadm provides a means of presenting formatted port monitor-specific (ttymon-specific) data to these commands.
The following options are supported:
Set the ``bi-directional port'' flag. When this flag is set, the line can be used in both directions. ttymon will allow users to connect to the service associated with the port, but if the port is free, uucico(1M), cu(1C), or ct(1C) can use it for dialing out.
Set the connect-on-carrier flag for the port. If the -c flag is set, ttymon will invoke the port's associated service immediately when a connect indication is received (that is, no prompt is printed and no baud-rate searching is done).
device is the full pathname of the device file for the TTY port.
Set the hangup flag for the port. If the -h flag is not set, ttymon will force a hangup on the line by setting the speed to 0 before setting the speed to the default or specified value.
Specify the inactive (disabled) response message. This message will be sent to the TTY port if the port is disabled or the ttymon monitoring the port is disabled.
Initialize only. If the -I option is used, ttymon will invoke the service only once. This can be used to configure a particular device without actually monitoring it, as with software carrier.
Specify which ttylabel in the /etc/ttydefs file to use as the starting point when searching for the proper baud rate.
Specify a list of pushable STREAMS modules. The modules will be pushed in the order in which they are specified before the service is invoked. modules must be a comma-separated list of modules, with no white space included. Any modules currently on the stream will be popped before these modules are pushed.
Specify the prompt message, for example, ``login:''.
When the -r option is invoked, ttymon will wait until it receives data from the port before it displays a prompt. If count is 0, ttymon will wait until it receives any character. If count is greater than 0, ttymon will wait until count newlines have been received.
service is the full pathname of the service to be invoked when a connection request is received. If arguments are required, the command and its arguments must be enclosed in double quotes (" ").
Set the software carrier value. y will turn software carrier on. n will turn software carrier off.
Specify that ttymon should close a port if the open on the port succeeds, and no input data is received in timeout seconds.
Set the terminal type. The TERM environment variable will be set to termtype.
Display the version number of the current /usr/lib/saf/ttymon command.
If successful, ttyadm will generate the requested information, write it to standard output, and exit with a status of 0. If ttyadm is invoked with an invalid number of arguments or invalid arguments, or if an incomplete option is specified, an error message will be written to standard error and ttymon will exit with a non-zero status.
See attributes(5) for descriptions of the following attributes:
|ATTRIBUTE TYPE||ATTRIBUTE VALUE|