The usb_ah STREAMS module enables the USB input control device which is a member of the Human Interface Device (HID) class and provides support for volume change and mute button. The usb_ah module is pushed on top of a HID class driver instance (see hid(7D)) and below an Audio Control class driver instance (see usb_ac(7D)). It translates the HID specific events to the events that are supported by the Solaris audio mixer framework.
See attributes(5) for descriptions of the following attributes:
|ATTRIBUTE TYPE||ATTRIBUTE VALUE|
32-bit ELF kernel STREAMS module
64-bit ELF kernel STREAMS module
STREAMS Programming Guide
System Administration Guide: Basic Administration
Universal Serial Bus Specification 1.0 and 1.1
Device Class Definition for Human Interface Devices (HID) 1.1
If USB audio drivers are not loaded, buttons will not be active.