The pwd utility writes an absolute path name of the current working directory to standard output.
See environ(5) for descriptions of the following environment variables that affect the execution of pwd: LANG, LC_ALL, LC_MESSAGES, and NLSPATH.
The following exit values are returned:
An error occurred.
If an error is detected, output will not be written to standard output, a diagnostic message will be written to standard error, and the exit status will not be 0.
See attributes(5) for descriptions of the following attributes:
|ATTRIBUTE TYPE||ATTRIBUTE VALUE|
``Cannot open ..'' and ``Read error in ..'' indicate possible file system trouble and should be referred to a UNIX system administrator.
If you move the current directory or one above it, pwd may not give the correct response. Use the cd(1) command with a full path name to correct this situation.